Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

I am stumped!!!

Old 10-09-2016, 07:42 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2016
Posts: 1
Model: Cherokee
Angry I am stumped!!!

Went out to start the 2000 Grand Cherokee today, and much to my surprise, it started and ran very poorly. The engine is misfiring badly, the instrument cluster is showing lights for the abs and brake, the voltmeter isn't working, and the "check gages " light is on. The alternator is also putting out over 17 volts. I don't understand what happened. It was fine the last time it was driven, which was last week. I have tested both the battery and the alternator, and both are fine. So, what's up with this thing???
Chuck Stout is offline  
Old 10-10-2016, 01:54 AM
  #2  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 11,288
Year: 2000
Model: Grand Cherokee (WJ)
Engine: 4.0L
Default

Welcome to CF!

Believe this or don't, but the problem could just be a bad connection on the battery cables. Corrosion or a loose wire from the clamp to the PDC can cause low voltage and produce the symptoms you report.

Last edited by dave1123; 10-10-2016 at 01:57 AM.
dave1123 is offline  
Old 10-10-2016, 06:39 AM
  #3  
Senior Member
 
XJRed96's Avatar
 
Join Date: Dec 2012
Location: Midwest
Posts: 608
Year: 1998
Model: Cherokee
Engine: 4.0L
Default

is the alternator actually charging at 17volts. because if it is thats not ok.
XJRed96 is offline  
Old 10-10-2016, 07:53 AM
  #4  
CF Veteran
 
Jeepin'_Aint_EZ's Avatar
 
Join Date: Jan 2012
Location: Ocean County, NJ
Posts: 2,208
Year: 1998
Model: Cherokee
Engine: 4.0L
Default

Originally Posted by Chuck Stout View Post
Went out to start the 2000 Grand Cherokee today, and much to my surprise, it started and ran very poorly. The engine is misfiring badly, the instrument cluster is showing lights for the abs and brake, the voltmeter isn't working, and the "check gages " light is on. The alternator is also putting out over 17 volts. I don't understand what happened. It was fine the last time it was driven, which was last week. I have tested both the battery and the alternator, and both are fine. So, what's up with this thing???
Welcome to the forum. Please explain the red text. Alternators should not be charging 17 volts. What were your actual readings when you checked the alternator and battery?

Take Dave's advice and check the battery cables. Check for chewed wires as well. Mice will cause havoc on wiring.
Jeepin'_Aint_EZ is offline  
Old 10-10-2016, 08:35 AM
  #5  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 11,288
Year: 2000
Model: Grand Cherokee (WJ)
Engine: 4.0L
Default

The reason I stated what I did is because this exact thing happened to me. What it turned out to be was corrosion inside the molded battery cable end causing a low voltage supply to the entire system except the starter. There are 2 red wires coming off the battery cable clamp. One goes directly to the starter and the other goes to the PDC which supplies all the power for the rest of the jeep. This happened overnight and replacing the cable end solved the problem.

PS, if the PCM can't read the alternator output, it can't control the voltage OR the amperage.
dave1123 is offline  
Old 10-10-2016, 07:46 PM
  #6  
Seasoned Member
 
Join Date: Dec 2010
Location: Georgia, USA
Posts: 350
Year: 1994
Model: Grand Cherokee
Engine: v8
Default

Yep, remove the terminals and clean well.

I had very similar symptoms, and it turned out to be a thin white film between the terminal and post that wasn't readily visible from the outside.

Cleaned it and it went back to working as it should.
rangermonroe is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
arrowhead_40
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
3
09-24-2016 11:52 PM
Doug Propst
Aftermarket electrical systems
3
08-21-2016 12:38 AM
John Benfer
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
0
08-20-2016 10:34 AM
Mountain Mike
Modified XJ Cherokee Tech
6
08-19-2016 05:48 AM
jerryramos
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
0
08-16-2016 05:28 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: I am stumped!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: