My Cherokee wont stay running - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!
Presented by the all-new Yokohama
Presented by the all-new Yokohama

My Cherokee wont stay running

Reply
 
 
 
Thread Tools Search this Thread
Old 03-12-2010, 04:33 PM   #1
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 7

View waywardson's Photo Album My Photos
Default My Cherokee wont stay running

Hey all,

I have a 93 Grand Cherokee with the 4.0L that will not stay running. The Jeep sat for over a year.

The motor will crank and start, but it dies immediately after 1 or 2 seconds. Giving it gas doesn't help, either.

I drained the tank and put in 1/2 a tank of fresh gas and tested the fuel pump while it was out. There is 40 psi at the rail.

The battery, cap/rotor, cam and crank sensors, TPS, idle control valve, plugs, wires, air and fuel filters were replaced with new parts. The fuel pump relay and fuses have been verified to be good. Also, there are no exhaust restrictions.

I even changed the PCM, but the problem is still there.

I have narrowed it down to a fault of the injector circuit. Using noid lights in the injector harness, when the engine is turning over, the injectors fire. As soon as the motor catches, the injectors STOP firing. Is there a sensor that controls the injectors once the engine has started? Or could this be something related to the ASD relay? Is it possible the PCM is bad? I've heard the PCM controls the grounding of the injectors once the motor is running, but I have not been able to verify this, as I don't have a Factory Service Manual. All help is appreciated, as I don't know what else to suspect. Thanks for all replies!
waywardson is offline   Reply With Quote
Old 03-12-2010, 04:40 PM   #2
CF Veteran
 
OverlandZJ's Avatar
 
Join Date: May 2008
Location: Bristol,Pa
Posts: 5,179

View OverlandZJ's Photo Album My Photos
Default

Welcome to CF.

Where did you source your PCM? New, reconditioned or used?

Did the PCM you replaced have the same last 4 digits? Or was it verified through a dealer as a new part number that supercedes your original?

Do you have a factory security system?
OverlandZJ is offline   Reply With Quote
Old 03-12-2010, 11:17 PM   #3
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 7

View waywardson's Photo Album My Photos
Default

About the PCM,
Unfortunately, I bought the PCM from Ebay. I say unfortunately because the computer I got didn't have the factory sticker with the number on it. It had a different label in a different location (maybe rebuilt?).

I only bought it because the ad stated it would be compatible with Jeep PCM's #56005694, #56027803, #56027762, and #56029009. Other websites I researched stated PCMs with these numbers were compatible.

The original one that came out of the Jeep had the number 56029009; I suspected it was bad because not only would the car not even try to start, but the tach would go haywire with the key on, the Check Engine light worked intermittently and it would not put out trouble codes. The one I bought was supposedly compatible, as long as the drivetrain was a 1993 4.0L/AW4 with no factory security system.

The Check Engine light now works properly, there are no codes, and like I stated in my previous post, the engine actually starts and runs, but loses the injector signal upon ignition and kills the party.

Do you think the computer is at fault? Is there a possibilty of anything else being at fault?
waywardson is offline   Reply With Quote
Old 03-13-2010, 01:36 AM   #4
CF Veteran
 
OverlandZJ's Avatar
 
Join Date: May 2008
Location: Bristol,Pa
Posts: 5,179

View OverlandZJ's Photo Album My Photos
Default

I bought one for a 93 ZJ as well, mine was for a 5.2/Auto with security. I also bought it from ebay through ICQ? dismantlers... pretty good presence and rep on ebay. Maybe worth a call to whoever you bought it from and see about an exchange with one that still has the sticker and is compatible?

From the research i did i knew i needed an exact match or a number that superceded. I got the superceded numbers from a bud who is a parts manager at a dealership.

From what i learned iirc the security system will do excactly what your describing.. run and shut down. Either you have a PCU without security or your security system is going off. Are you experiencing blinking headlights when you turn the key?

I apologise if your familiar with the security system and you already knew this.. but i figure it's worth mentioning. To shut off the security system without a remote simply lock and unlock the passenger door or hatch twice.
OverlandZJ is offline   Reply With Quote
Old 03-15-2010, 12:22 AM   #5
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 7

View waywardson's Photo Album My Photos
Default

Thanks for the reply.

My Jeep didn't come with a factory security system, and the computer was supposedly for a car without a factory security system.

I didn't know about disarming the system with the passenger door lock. I will try it.

If the PCM I installed is for a car WITH a security system, is there some way to bypass it?




waywardson is offline   Reply With Quote
Old 03-16-2010, 12:44 PM   #6
Seasoned Member
 
ToyComa's Avatar
 
Join Date: Sep 2009
Posts: 314

View ToyComa's Photo Album My Photos
Default

Quote:
Originally Posted by OverlandXJ View Post

I apologise if your familiar with the security system and you already knew this.. but i figure it's worth mentioning. To shut off the security system without a remote simply lock and unlock the passenger door or hatch twice.
lol, thank you for posting this. I just pulled my battery to change my head light bulb and then the truck wouldnt start when I put the battery back in and the lights were blinking and security was blinking on the dash and I was like WTF!?!?!? ran in and did a search and bam. problem fixed.
ToyComa is offline   Reply With Quote
Old 06-29-2010, 11:59 PM   #7
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 7

View waywardson's Photo Album My Photos
Default Problem solved!

Hey everyone,The problem is finally fixed. It turned out to be the PCM. The security feature was activated (somehow), and would kill the injector ground circuit. That's why the motor could start off the primer of gas it got from turning the key on, but when that little bit of fuel ran out, no more would be supplied.Now all is well. Thanks to all who replied. This forum is awesome!
waywardson is offline   Reply With Quote
Old 09-18-2015, 12:19 PM   #8
Newbie
 
Join Date: Aug 2015
Posts: 1

View MaxT's Photo Album My Photos
Default

Quote:
Originally Posted by waywardson View Post
Hey everyone,The problem is finally fixed. It turned out to be the PCM. The security feature was activated (somehow), and would kill the injector ground circuit. That's why the motor could start off the primer of gas it got from turning the key on, but when that little bit of fuel ran out, no more would be supplied.Now all is well. Thanks to all who replied. This forum is awesome!
I am currently having very similar problems with my 1990 cherokee. If you could go through the steps of what you did to solve the problem concerning the PCM, I would GREATLY appreciate it! I don't have a security system either and I replaced the "original" ECU with a remanufactured one.
MaxT is offline   Reply With Quote
Old 09-19-2015, 08:47 PM   #9
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 7

View waywardson's Photo Album My Photos
Default PCM reprogramming

After purchasing another PCM, I got it reprogrammed to disable the fuel shutoff that was preventing the engine from continuing to run. It worked perfectly after that. I think there was a vendor on ebaymotors.com that offered the reprogramming service. I'm pretty sure an internet search will turn up others offering the same service today.
waywardson is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The red rocket Reddave Jeep Builds 8 11-11-2015 11:27 PM
Just got my first cherokee, how did I do? skarpyona Cherokee Chat 34 10-07-2015 11:14 AM
need help please schaferjeep OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 5 08-21-2015 08:40 PM
Cherokee Starting/Idling problem hkb OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 4 08-21-2015 05:48 AM
4.88 vs 4.56 DD TwinTurboXj OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 2 08-20-2015 02:59 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:28 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: