Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

need help please

Old 08-20-2015, 04:09 PM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2015
Posts: 2
Model: Cherokee
Default need help please

Hi I'm new to the forums and this is also my first time owning a jeep, I'm hoping that I can find someone who can tell me what's going on with my jeep or has had one that has done what mine is doing. It's a 92 frame with a 93 motor in it, the motor has 250,000 miles. Overall it's in good condition, hadn't been mudded or anything like that. When the original motor in the 92 went bad I had the 93 installed and it ran great previous to swapping, but now it's got a miss to it, it's hard to actually explain but you can start it one day and it will run like a dream, then the next day it acts like it dies for a split second non stop while going down the road. And the faster You drive the worst it will get I mean it will feel like the whole thing is trying to lock up, but it will stay running. I've replaced the dist cap and bug, fuel filter, fuel pump, had the gas tank checked for blockage, New transmission filter and oil, New air and oil filters. I've stuck a lot of money into this thing already and I've took it to several mechanics who tell me they just don't know what's wrong because they can't hook it up to a machine. Please if anyone knows what it might be let me know because I'm at a loss.
schaferjeep is offline  
Old 08-20-2015, 04:46 PM
  #2  
Junior Member
 
zjWaggy's Avatar
 
Join Date: May 2015
Posts: 49
Year: 1993
Model: Grand Cherokee
Engine: 5.2L
Default need help please

If it runs bad only sometimes you should pay attention to the factors. Like outside temperature for instance, weather, what kind of inclination you're on. Etc. once you see a reoccurring theme when it runs bad, that'll get you a lead.
zjWaggy is offline  
Old 08-20-2015, 04:46 PM
  #3  
CF Veteran
 
JPXJMOAB's Avatar
 
Join Date: Jan 2015
Location: Minnesota
Posts: 2,152
Year: 1999
Model: Cherokee
Engine: 4.0L
Default need help please

First off welcome to the forum! Also.. Do you have an XJ or a ZJ? The ZJ wasn't made til 93. It sounds to me like you may have either a failing fuel pressure regulator, or a heat soak issue on the fuel rail. Do you have or able to get a fuel pressure tester?
JPXJMOAB is offline  
Old 08-21-2015, 12:12 PM
  #4  
Newbie
Thread Starter
 
Join Date: Aug 2015
Posts: 2
Model: Cherokee
Default

It's a jeep Cherokee Laredo 92 body with 93 motor. I have noticed that it runs worse than usual on high humidity days or when it rains. It also runs bad going up inclines it seems.
schaferjeep is offline  
Old 08-21-2015, 01:30 PM
  #5  
CF Veteran
 
JPXJMOAB's Avatar
 
Join Date: Jan 2015
Location: Minnesota
Posts: 2,152
Year: 1999
Model: Cherokee
Engine: 4.0L
Default need help please

Sounds to me like a possible weak fuel pump. Test fuel pressure at the rail. Fuel pressure should be around 31-35 on the 4.0L
JPXJMOAB is offline  
Old 08-21-2015, 08:40 PM
  #6  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 11,459
Year: 2000
Model: Grand Cherokee (WJ)
Engine: 4.0L
Default

One thing that leads me to this is the high humidity aspect of the problem. How are the spark plug wires? Are they dried out and brittle?
dave1123 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: