Speedometer and odomete not working - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Speedometer and odomete not working

Reply
 
 
 
Thread Tools Search this Thread
Old 03-22-2012, 08:20 AM   #1
Newbie
Thread Starter
 
Join Date: Mar 2012
Location: Ohio
Posts: 27

View zakattack13's Photo Album My Photos
Cool Speedometer and odomete not working

My speedo in my 92 cherokee doese t work .. Was like this when i bought it couple months ago .. All the dash lights and everythig work though ..was wonderin where i could start to find the problem
zakattack13 is offline   Reply With Quote
Old 03-22-2012, 08:29 AM   #2
CF Veteran
 
caged's Avatar
 
Join Date: Nov 2008
Location: Northern Ontario, Canada
Posts: 7,189

View caged's Photo Album My Photos
Default

two ways to start looking.
first, you could look into the speedo gear at the transfer case. it's tight up in there, but you should be able to get the bolt out, remove the cable end and inspect the teeth on the gear. the gear is plastic, and if once removed, and reinstalled improperly, it could've ground the teeth off the small gear. also inside the hole, there is a speedo ring gear that drives the smaller gear. check that too. you may have to remove the t-case and split it in half.

second thing, remove the plastic dash bezel and unbolt the instrument cluster and see if the speedo cable is pulled from the dash.

good luck.
caged is offline   Reply With Quote
Old 03-22-2012, 08:34 AM   #3
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 33,699

View cruiser54's Photo Album My Photos
Default

Didn't 92 have an electric speedo?
cruiser54 is offline   Reply With Quote
Old 03-22-2012, 09:17 AM   #4
CF Veteran
 
caged's Avatar
 
Join Date: Nov 2008
Location: Northern Ontario, Canada
Posts: 7,189

View caged's Photo Album My Photos
Default

hmmm, not sure. i have a renix and i haven't been into my 93 yet.

if that's the case, it still has a speedo gear, but you may have to inspect the harness for any breaks in the wires.
caged is offline   Reply With Quote
Old 03-22-2012, 09:26 AM   #5
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 33,699

View cruiser54's Photo Album My Photos
Default

Quote:
Originally Posted by caged View Post
hmmm, not sure. i have a renix and i haven't been into my 93 yet.

if that's the case, it still has a speedo gear, but you may have to inspect the harness for any breaks in the wires.
I think it was 87 to 90 Renix that had wavering speedo needles and they never came up with a good fix. Fun being a Service Manager at that time, telling people nothing would fix the wavering needle...The cables made too sharp a bend. IIRC, 91 went electronic. Your advice is good. Wires to VSS and/or the gear that drives the VSS.
cruiser54 is offline   Reply With Quote
Old 03-22-2012, 10:16 AM   #6
Senior Member
 
radio flyer's Avatar
 
Join Date: Feb 2009
Location: Highlands Ranch Co.
Posts: 717

View radio flyer's Photo Album My Photos
Default

https://www.cherokeeforum.com/f2/spe...l-gauge-73815/

Check this out, a bad ground here will prevent your speedo from working.
radio flyer is offline   Reply With Quote
Old 03-22-2012, 11:54 AM   #7
Senior Member
 
kissthis66's Avatar
 
Join Date: Apr 2010
Location: Marshall, WI
Posts: 720

View kissthis66's Photo Album My Photos
Default

Quote:
Originally Posted by zakattack13
My speedo in my 92 cherokee doese t work .. Was like this when i bought it couple months ago .. All the dash lights and everythig work though ..was wonderin where i could start to find the problem
I have fixed this issue on mine and a few others. if it's the electric speedo/no cable, here's what you do. Pull the cluster from the dash. You will see screws going from the back of the cluster to the speedo and your other gauges. Those screws need to be tightened back down as they carry the current to your speedo and tach. You will notice the plastic sheet on the back and see what I'm talking about once it's pulled. What happens is, the heat and cold will cause the plastic that houses the gauges to expand/contact But the screws don't. So over time the screws will loosen up and will lose connection with circuit board. Tightening them back down will reestablish the connection. This will only work if you have an electric speedo. Check the transfer case and see in you have a cable or a electric plug. That will let ya know immediately. Hope this helps.

This fix will take you all of 15 min and only requires one phillips screwdriver.

Last edited by kissthis66; 03-22-2012 at 11:59 AM.
kissthis66 is offline   Reply With Quote
Old 04-04-2012, 06:01 AM   #8
Newbie
 
Join Date: Apr 2012
Posts: 1

View andy-wilcan's Photo Album My Photos
Default

Can any one help me. I have a 1997 Grand Jeep Cherokee 4.olt with the dash lights battery voltage, rev counter and speedo all going off and the electric windows stop working ?? Please Help
andy-wilcan is offline   Reply With Quote
Old 04-04-2012, 08:03 AM   #9
CF Veteran
 
RTorrez1's Avatar
 
Join Date: Sep 2011
Location: Riviera, Texas
Posts: 4,172

View RTorrez1's Photo Album My Photos
Default

Quote:
Originally Posted by andy-wilcan View Post
Can any one help me. I have a 1997 Grand Jeep Cherokee 4.olt with the dash lights battery voltage, rev counter and speedo all going off and the electric windows stop working ?? Please Help
Try putting your post in the correct section. This is for XJ's not the GC.
RTorrez1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Harmonic balancer and overheating Aryl OEM Cherokee Technical. All factory issues and info go here! 8 11-20-2016 09:17 AM
Changed O ring, now no speedometer moparchero OEM Cherokee Technical. All factory issues and info go here! 0 08-26-2015 12:58 PM
Should I buy this.....? nicksan Cherokee Chat 12 08-25-2015 03:42 PM
sputtering real bad batman43 OEM Cherokee Technical. All factory issues and info go here! 2 08-20-2015 08:43 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:28 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send