No start condition - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

No start condition

Reply
 
 
 
Thread Tools Search this Thread
Old 11-11-2012, 02:40 AM   #1
Junior Member
Thread Starter
 
alienxj's Avatar
 
Join Date: Jan 2012
Location: Colorful Colorado
Posts: 73

View alienxj's Photo Album My Photos
Default No start condition

My 89' XJ recently was parked then wouldn't start 2 hours later. The fuel pump primes, It doesn't crank and there is no click at all from the starter. A few days ago it did this then started on a third try. Also, the day before I pressure washed the engine and bay because it was a muddy mess, I covered the distributor with bags it looked dry. Could a wet distributor even cause this?

At first I thought ignition switch but with some research on the internet I found the neutral safety switch issue. Maybe I'm missing something any ideas?
alienxj is offline   Reply With Quote
Old 11-11-2012, 02:46 AM   #2
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,702

View freegdr's Photo Album My Photos
Default

Smack starter with hammer then try
freegdr is offline   Reply With Quote
Old 11-11-2012, 03:01 AM   #3
Junior Member
Thread Starter
 
alienxj's Avatar
 
Join Date: Jan 2012
Location: Colorful Colorado
Posts: 73

View alienxj's Photo Album My Photos
Default

I thought about that but it seemed like a power issue since there was no click at all but what do I know. I'll try it tomorrow.
alienxj is offline   Reply With Quote
Old 11-11-2012, 03:56 AM   #4
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,702

View freegdr's Photo Album My Photos
Default

Gootta start with simple tests first . have a test light check to see if you get current to small wire on starter when keys turned to start if hammer dont work .
freegdr is offline   Reply With Quote
Old 11-11-2012, 06:01 AM   #5
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 33,910

View cruiser54's Photo Album My Photos
Default

When yo uturn the key to Start, do your dash indicator lights dim?

If so, the starter is getting current. If not, it's not.
cruiser54 is offline   Reply With Quote
Old 11-11-2012, 10:55 AM   #6
Junior Member
Thread Starter
 
alienxj's Avatar
 
Join Date: Jan 2012
Location: Colorful Colorado
Posts: 73

View alienxj's Photo Album My Photos
Default

Quote:
Originally Posted by cruiser54 View Post
When yo uturn the key to Start, do your dash indicator lights dim?

If so, the starter is getting current. If not, it's not.
Do you mean the panel and clock going dark when attempting to crank?
alienxj is offline   Reply With Quote
Old 11-11-2012, 10:58 AM   #7
Seasoned Member
 
97xjCrow's Avatar
 
Join Date: Nov 2012
Posts: 305

View 97xjCrow's Photo Album My Photos
Default

Shake your shifter wiggle it while in park while trying to turn it over! Should start right up
97xjCrow is offline   Reply With Quote
Old 11-11-2012, 10:59 AM   #8
Seasoned Member
 
97xjCrow's Avatar
 
Join Date: Nov 2012
Posts: 305

View 97xjCrow's Photo Album My Photos
Default

If it doesnt, clean your neutral safety switch with some electrical contact spray
97xjCrow is offline   Reply With Quote
Old 11-11-2012, 11:56 AM   #9
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 33,910

View cruiser54's Photo Album My Photos
Default

Quote:
Originally Posted by alienxj View Post
Do you mean the panel and clock going dark when attempting to crank?
Yes.
cruiser54 is offline   Reply With Quote
Old 11-11-2012, 12:31 PM   #10
Junior Member
Thread Starter
 
alienxj's Avatar
 
Join Date: Jan 2012
Location: Colorful Colorado
Posts: 73

View alienxj's Photo Album My Photos
Default

Started right up with some wiggling in park. I'll be cleaning the NSS appreciate the help everybody!
alienxj is offline   Reply With Quote
Old 11-11-2012, 12:48 PM   #11
Seasoned Member
 
97xjCrow's Avatar
 
Join Date: Nov 2012
Posts: 305

View 97xjCrow's Photo Album My Photos
Default

Yeahh buddy!
97xjCrow is offline   Reply With Quote
Old 11-11-2012, 02:00 PM   #12
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 33,910

View cruiser54's Photo Album My Photos
Default

Right on.
cruiser54 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Time for Introduction or Jeeps in Saint Petersburg, Russia StPTrucker Introductions 30 11-22-2015 05:07 PM
Project Resurrection SixShooterXJCherokee Jeep Builds 13 10-08-2015 11:45 AM
Need suspension and engine advice! jackieC Cherokee Chat 15 09-07-2015 03:27 PM
need help please schaferjeep Grand Cherokee Tech 5 08-21-2015 08:40 PM
Cam Sensor Hard Failure CCKen OEM Cherokee Technical. All factory issues and info go here! 3 08-20-2015 08:07 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 08:18 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send