Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

wj stall

Old 03-20-2019, 07:17 AM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2018
Location: MA
Posts: 6
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0
Default wj stall

I have a 01 GC Laredo with the inline 6. The motor turns right over and starts, runs for about ten seconds and shuts down. Turn it over and it starts and runs again. When it is running before shutdown I have absolutely no gages either. So I dont think it is a timing or spark problem and at least some fuel is in the line to get it going. I have brand new plugs and a coil rail and the old plugs that came out had normal wear on them so i dont think its there either. Ive read that if the pcm and other sensors are not working correctly it wouldnt even crank. So I guess my question or ?s would be anybody else have an issue similar and whats the fix or could it possibly be a relay? stuck egr? Thanks for your thoughts
Josh
jsith76 is offline  
Old 03-20-2019, 10:43 AM
  #2  
CF Veteran
 
4.3L XJ's Avatar
 
Join Date: Aug 2008
Location: Chico, CA
Posts: 4,412
Year: 1986
Model: Cherokee
Engine: 4.3L with headers and full 3" exhaust system
Default

Have you pulled any code from the ECU?
4.3L XJ is offline  
Old 03-20-2019, 02:10 PM
  #3  
Newbie
Thread Starter
 
Join Date: Mar 2018
Location: MA
Posts: 6
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0
Default

Originally Posted by 4.3L XJ View Post
Have you pulled any code from the ECU?
I am going to try bit with the truck not staying running long enough I'm not sure I can at all.

jsith76 is offline  
Old 03-21-2019, 01:44 PM
  #4  
Newbie
Thread Starter
 
Join Date: Mar 2018
Location: MA
Posts: 6
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0
Default

UPDATE; I have pulled a code off the computer that is showingP1686-no skim bus messages. Now I know the skim is the key system that sends a signal to the ecm that is vehichle specific, so I erased the codes and the truck started and ran. All guages back on no idiot lights nada, five minutes later no guages and all idiot lights including skim back on-TRUCK STAYS RUNNING. Shut down the engine and it starts right back up w no guages all idiot lights lit and STAYS RUNNING! Did that about five times with the same result, start, run, no nada on the cluster. SO....ECM? SKIM BUS and/or KEY?
jsith76 is offline  
Old 03-21-2019, 03:59 PM
  #5  
CF Veteran
 
4.3L XJ's Avatar
 
Join Date: Aug 2008
Location: Chico, CA
Posts: 4,412
Year: 1986
Model: Cherokee
Engine: 4.3L with headers and full 3" exhaust system
Default

I think you probably have an ECM problem, or the chip in the instrument panel is bad
4.3L XJ is offline  
Old 03-22-2019, 05:13 PM
  #6  
CF Veteran
 
Cherryokee's Avatar
 
Join Date: May 2010
Location: Boston
Posts: 1,036
Year: 2000
Model: Grand Cherokee
Engine: 4.7L
Default


Start small and keep it simple. Disconnect your battery, negative post first (good opportunity to connect charger). Get a can of electric/electronic parts cleaner then disconnect the ECM connectors, spray & dry each connector, align, reconnect gently/firmly and do the start/run/road test. I went through this...you have my sympathies.

Last edited by Cherryokee; 03-22-2019 at 05:16 PM.
Cherryokee is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Aman1022
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
17
03-26-2019 10:41 AM
bada$$91xj
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
03-23-2019 07:31 PM
bada$$91xj
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
03-20-2019 02:12 AM
kenzinger
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
03-15-2019 10:16 AM
coffeeCola
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
11
03-14-2019 11:56 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: wj stall


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: