Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

Rough idle

Old 12-23-2018, 06:37 PM
  #1  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 11
Model: Cherokee (XJ)
Default Rough idle

Hi all, happy holidays to everyone that visits this forum. Bought a 93 grand Cherokee 4.0 inline 6 almost 2 months ago from a guy who said he was a mechanic. Well being that he said he was a mechanic I believed him when he said it was mechanically sound no issues except for gas gauge not working always reads E. So he included a new fuel pump assembly with purchase of the jeep. So I have since owning the jeep now have had a mechanic come and replace harmonic balancer and belt and 2 idler pulleys. I had no other issues but that and the battery was bad so security system was constantly giving me issues. Drove it for a couple days after replacing battery and harmonic balancer and it ran great so I figured might as well replace fuel pump before it starts raining again. Replaced pump and filter and new fuel lines from pump to filter cause the ones at the pump broke. Now it starts but has very rough idle so I did some research and did the following to see if it would help the idling issue. I've cleaned throttle body, checked iac valve and. Tps both appear new, new o2 sensor, replaced cps, coil removed and cleaned and. Regapped every spark plug replaced fuel pressure regulator cause other one leaked. Valve cover gasket is next cause it's leaking oil. But even with other stuff done still idles poorly I've checked for vacuum leaks using propane can't find any. I have been doing all the work myself cause we'll I'm not afraid to learn or get my hands dirty but don't know what else to do. Good spark and good fuel pressure. Sorry this so so long just wanted to get as much of what I've done out there. Please help I have to make a 200mile trip Christmas Eve and this is my only vehicle. Thanks
Shortcake1 is offline  
Old 12-23-2018, 11:31 PM
  #2  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,603
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

Replaced pump and filter and new fuel lines from pump to filter cause the ones at the pump broke. Now it starts but has very rough idle
I would suggest a fuel pressure and leak down test of the new install, and or renting a car for Christmas Eve.
97grand4.0 is offline  
Old 12-26-2018, 04:46 PM
  #3  
CF Veteran
 
peep's Avatar
 
Join Date: Oct 2010
Location: Ontario, Canada
Posts: 2,137
Year: 1989 Laredo
Model: Cherokee
Engine: 4.0 L 6 Renix
Default

Is your rough idle still there?
Have you tried and fuel conditioner additives or some isopropyl alcohol if there is any condesate water in the fuel.
Can you obtain a fuel pressure reading?
I have rough idle and hard cold starts on 95ZJ, my fuel pressure is only 29psi, should be 39 - 41psi. New fuel pump going in this holdiay season.
I know you mentioned a fuel pump install. Is there a pressure reading available. When you replaced the filter was the fuel on the output side dirty?
peep is offline  
Old 12-28-2018, 01:28 AM
  #4  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 11
Model: Cherokee (XJ)
Default

Originally Posted by peep View Post
Is your rough idle still there?
Have you tried and fuel conditioner additives or some isopropyl alcohol if there is any condesate water in the fuel.
Can you obtain a fuel pressure reading?
I have rough idle and hard cold starts on 95ZJ, my fuel pressure is only 29psi, should be 39 - 41psi. New fuel pump going in this holdiay season.
I know you mentioned a fuel pump install. Is there a pressure reading available. When you replaced the filter was the fuel on the output side dirty?
Yes. I did replace all spark plugs and fuel pressure regulator and it idles better but really low and will stall out unless I give more gas. I haven't tried any fuel cleaners cause I was always told they can do more harm than any good. No way of doing fuel pressure reading I don't have a gauge but plan on getting one. The pump I replaced the filters weren't too dirty and it was still working fine but the sending unit was shot my gas gauge always was on E. I bought the jeep on the 12th of nov. and its been sitting for most of my ownership. Hell it hasn't moved since the 27th of last month Ive lost my job cause of these problems. Tomorrow Im going to try driving I around the block see if the computer will relearn everything since the battery has been disconnected so many times and dtc codes cleared 2x.Im not sure what else to do. But maybe ill have it running good tomorrow. Thanks for input.
Shortcake1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rdr8887
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
32
08-11-2015 08:42 PM
BlueRidgeMark
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
7
11-06-2013 06:19 PM
tfdilley
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
17
10-28-2013 02:39 PM
Troth
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
11-25-2012 09:25 PM
1000jeep
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
07-31-2010 08:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Rough idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: