Jeep Builds Make your own jeep build thread here, discuss and view jeeps here. All Jeep models are welcome here.

1988 XJ

Old 08-12-2010, 09:20 PM
  #1  
hadi820
Guest
 
Posts: n/a
Default 1988 XJ

I am new to this forum,but i have owned jeeps on and off, but never modified them untill this one, tonight i bought a 1988 laredo with 106k on it , however the speedo motor is gone bad, does this mean the odometer also is shot? if it is im not going to be mad, since the title they gave me said that in 07 the car had 71k miles. and i got it for a steal ( 1100 ) nothing wrong with it, and no rust for the moment , i will post pics tomorrow in the daylight . what do you guys think?
 
Old 08-12-2010, 09:38 PM
  #2  
CF Veteran
 
XxXJ99xX's Avatar
 
Join Date: Jul 2010
Location: WNY
Posts: 1,971
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999
Model: Cherokee
Engine: 4.0 High Output
Default

Originally Posted by hadi820 View Post
I am new to this forum,but i have owned jeeps on and off, but never modified them untill this one, tonight i bought a 1988 laredo with 106k on it , however the speedo motor is gone bad, does this mean the odometer also is shot? if it is im not going to be mad, since the title they gave me said that in 07 the car had 71k miles. and i got it for a steal ( 1100 ) nothing wrong with it, and no rust for the moment , i will post pics tomorrow in the daylight . what do you guys think?
It dosent sound to bad, but what options came with it? And its a possibility that the odometer went bad to but i highly doubt it, how long ago did it go? And an easy way to tell is to take it for a ride for a couple miles, if the odo turns it works
XxXJ99xX is offline  
Old 08-13-2010, 05:55 PM
  #3  
hadi820
Guest
 
Posts: n/a
Default the ODO and the speedo are gone, i started taking

the ODO and the speedo are gone, i started taking out the cluster out, took of all the screws and the cluster is loose but i cant pull it out , i know its connected but it gives me no room to figure out what needs to be unplugged... any suggestions ?
 
Old 08-13-2010, 06:07 PM
  #4  
hadi820
Guest
 
Posts: n/a
Default

heres a pic of the jeep, also this is the speedo thats the previous owner told me i needed to put in and replace the old one, where does that go in the cluster ? also i read that i need to check the connection for the speedo cable that goes to the Tcase, is that it in the last dark picture?
Attached Thumbnails 1988 XJ-2010-08-13-19.00.25.jpg  
Attached Images   
 
Old 08-13-2010, 07:57 PM
  #5  
Seasoned Member
 
Zackqb2's Avatar
 
Join Date: Mar 2009
Location: Ohio
Posts: 416
Likes: 0
Received 0 Likes on 0 Posts
Year: 2001
Model: Cherokee
Engine: 4.0 L
Default

The speedo gear goes in the TCase you can almost see it in the last pic.
Zackqb2 is offline  
Old 08-13-2010, 08:57 PM
  #6  
CF Veteran
 
XxXJ99xX's Avatar
 
Join Date: Jul 2010
Location: WNY
Posts: 1,971
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999
Model: Cherokee
Engine: 4.0 High Output
Default

If you check the connections for the spedo cable make sure nothing on the inside is corroded in any way or has any build up in it, if it does just clean it out and that should do it after you put in the spedo and check to see if it works, if not then check all your connections and make sure there connected properly and dont cut any wires, and check your grounds if there still messed up and most importantly, your fuses, itd suck to go through all this and it wind up being a fuse.
XxXJ99xX is offline  
Old 08-14-2010, 09:21 AM
  #7  
hadi820
Guest
 
Posts: n/a
Default

ok so i woke up today to end this speedo thing now that i know where the gear goes, thinking it was going to be simple, then i get under there and i find that there is no housing like what i saw in write ups online and my setup doesnt seem to have the wiring it looked like one cable ... here are a few pics of what i think im missing and what mine looks like... and in the second picture are what holds the housing in but it as if they are holding nothing? anyone knows what is going on? where should my speedo gear go?
Attached Thumbnails 1988 XJ-2010-08-14-10.13.20.jpg  
Attached Images   
 
Old 08-14-2010, 10:15 AM
  #8  
hadi820
Guest
 
Posts: n/a
Default

ok so forget that last post, i was able to pull out the cable and the housing was inside, there was an orange colored 35 tooth speedo gear , i put the one i have in there which is a 34 tooth one, went for a test drive , still nothing , what do you guys think?
 
Old 08-14-2010, 10:44 AM
  #9  
CF Veteran
 
XxXJ99xX's Avatar
 
Join Date: Jul 2010
Location: WNY
Posts: 1,971
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999
Model: Cherokee
Engine: 4.0 High Output
Default

Originally Posted by hadi820 View Post
ok so forget that last post, i was able to pull out the cable and the housing was inside, there was an orange colored 35 tooth speedo gear , i put the one i have in there which is a 34 tooth one, went for a test drive , still nothing , what do you guys think?
Is the cable in good shape?
XxXJ99xX is offline  
Old 08-14-2010, 10:54 AM
  #10  
hadi820
Guest
 
Posts: n/a
Default

i havent checked what is the best way to check it, do i take that rusted nut you see in the picture off?
 
Old 08-14-2010, 10:59 AM
  #11  
CF Veteran
 
XxXJ99xX's Avatar
 
Join Date: Jul 2010
Location: WNY
Posts: 1,971
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999
Model: Cherokee
Engine: 4.0 High Output
Default

Originally Posted by hadi820 View Post
i havent checked what is the best way to check it, do i take that rusted nut you see in the picture off?
Look for any cuts or tears in the line or if any rust or grease has gotton into it, that can all screw up readings for the spedo
XxXJ99xX is offline  
Old 08-14-2010, 11:05 AM
  #12  
Seasoned Member
 
n_csmith's Avatar
 
Join Date: Mar 2010
Location: Lakenheath, Suffolk
Posts: 470
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Grand Cherokee
Engine: 4.7L
Default

check the speedo cable where it attaches to the back of the speedometer if it is slightly disconnected it wont read.
n_csmith is offline  
Old 08-16-2010, 05:39 PM
  #13  
hadi820
Guest
 
Posts: n/a
Default

finally today i got to get the speedo fixed, the cable was not connected properly like you guys said , i also changed diff. fluids and motor oil, i realized smoke was coming off of the intake manifold where there is some oil and gasoline mixed, turns out an injector is leaking?! im getting the seals for it tomorrow and gonna try and fix it, how serious is that is it gonna catch on fire? OH and i scored 4 black daytona steel wheels for 60!
 
Old 08-20-2010, 06:58 PM
  #14  
hadi820
Guest
 
Posts: n/a
Default

today i replaced the O-rings on all injectors and cleaned the injectors up real good. i also decided to take the rear carpet out and check out the rust situation... it was pretty nice underneath only surface rust, i sanded that down and herculined it , i will do a second coat tomorrow. here are some pictures, and the wheels i got i probably wont get tires for before i lift it.
Attached Thumbnails 1988 XJ-2010-08-17-15.24.23.jpg  
Attached Images     
 
Old 08-20-2010, 07:06 PM
  #15  
hadi820
Guest
 
Posts: n/a
Default

i realized something right after taking the carpet out,i turned the key to go throw that moldy thing at the dump , and the car gets ready to turn on but nothing happens not a noise, i did that about three times , then fired up right away, kinda weird not a single noise.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Travis88XJ
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
19
03-12-2016 07:26 AM
95cherokee89
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
59
10-16-2015 03:17 AM
Arrowhead1911XJ
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
09-09-2015 10:25 AM
Batman33165
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
7
08-27-2015 02:20 PM
csmith237
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
08-24-2015 12:54 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 1988 XJ


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: