Notices
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Why does my Jeep *SOMETIMES* idle high?

Old 04-18-2013, 04:45 PM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2013
Posts: 17
Model: Cherokee
Default Why does my Jeep *SOMETIMES* idle high?

I checked for a vacuum leak and there is no leak. I took my air cleaner hose off to clean the throttle body and the IAC off.

It sometimes idles at 1500 in park and 900 in drive even when WARM. If I go for a 1-2 mile drive then it will return to normal idle at 700 in park and 600 in drive.

87 4.0L I6.
509Cher is offline  
Old 04-19-2013, 06:47 AM
  #2  
Junior Member
 
Join Date: Dec 2008
Location: Minneapolis
Posts: 36
Year: 2001
Model: Cherokee
Engine: Stock
Default

Mine does the same thing when the A/C coolant is low. If it does it when you not in defrost or A/C then it is not the coolant.
macasylum is offline  
Old 04-19-2013, 09:45 AM
  #3  
Senior Member
 
billytoad631's Avatar
 
Join Date: Oct 2011
Location: islip terrace NY
Posts: 522
Year: 1995
Model: Cherokee
Default

my old xj used to do the same thing sometimes, pretty sure it was a tps sensor but i never got around to looking into it before i sold it
billytoad631 is offline  
Old 04-19-2013, 10:33 AM
  #4  
Senior Member
 
89cherokee2gtmudy's Avatar
 
Join Date: Apr 2012
Location: Los Banos CA
Posts: 735
Year: 2000
Model: Cherokee
Engine: 4.0
Default

My 89 xj has the same problem sometimes it likes to go up to 2,000 in drive. It wants to push through stop lights. And I already have bad brakes as is. I will be watching this. I've tried everything. Replaced my iac. Swapped it with the my 88 comanche which runs just fine with the xjs. I have adjusted the tps and done the ground refreshing. I'm about to replace the tps. Can't switch them between the mj and xj cause the mj is a 5 speed.

Last edited by 89cherokee2gtmudy; 04-19-2013 at 10:35 AM.
89cherokee2gtmudy is offline  
Old 04-19-2013, 12:12 PM
  #5  
Seasoned Member
 
playbass's Avatar
 
Join Date: May 2012
Location: Salt Lake City, UT
Posts: 468
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Mine is a 98 so I don't know if it will matter for you, but mine would randomly idle high until I replaced the TPS with a new one. It doesn't do it any more.
playbass is offline  
Old 04-19-2013, 12:47 PM
  #6  
CF Veteran
 
DESERTXJ206's Avatar
 
Join Date: May 2011
Location: Glendale,Az
Posts: 1,458
Year: 1990
Model: Cherokee
Engine: 4.0l 6Cyl
Default

Originally Posted by 89cherokee2gtmudy View Post
My 89 xj has the same problem sometimes it likes to go up to 2,000 in drive. It wants to push through stop lights. And I already have bad brakes as is. I will be watching this. I've tried everything. Replaced my iac. Swapped it with the my 88 comanche which runs just fine with the xjs. I have adjusted the tps and done the ground refreshing. I'm about to replace the tps. Can't switch them between the mj and xj cause the mj is a 5 speed.
I belive you have the C101 connector on ghe driverside fire wall. You should take it apart and clean the tar like substace out of it. Also there are factory crimped grounds in the wire loom near the fire wsll and going down the injector rail. Cut out the grounds that are factory wrspped in duct tspe and solder them all together. Your idl issue may go away after that. That wss the problem in my 88.
DESERTXJ206 is offline  
Old 04-19-2013, 11:38 PM
  #7  
CF Veteran
 
Scotty16's Avatar
 
Join Date: Jun 2010
Location: Placerville, CA
Posts: 2,093
Year: 1989
Model: Cherokee
Engine: 4.0 Inline 6
Default

If the TPS doesn't solve it, try looking at the IAC
Scotty16 is offline  
Old 04-20-2013, 12:04 AM
  #8  
Senior Member
 
89cherokee2gtmudy's Avatar
 
Join Date: Apr 2012
Location: Los Banos CA
Posts: 735
Year: 2000
Model: Cherokee
Engine: 4.0
Default

Originally Posted by DESERTXJ206 View Post

I belive you have the C101 connector on ghe driverside fire wall. You should take it apart and clean the tar like substace out of it. Also there are factory crimped grounds in the wire loom near the fire wsll and going down the injector rail. Cut out the grounds that are factory wrspped in duct tspe and solder them all together. Your idl issue may go away after that. That wss the problem in my 88.
My 88 does have the c101 and my 89 does not. But the 89 likes to high idle. Sorry for any confusion. I also don't mean to take over anyone's thread. I just have a similar problem and would like ways to fix it.
89cherokee2gtmudy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Blackcherokee290
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
24
04-16-2019 06:04 PM
EBowen95
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
49
08-25-2015 08:44 PM
Gtrsrlly
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
08-25-2015 11:50 AM
hockeyfan_83
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
8
08-22-2015 10:27 PM
Ye Ol' Cherokee
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
08-22-2015 01:43 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Why does my Jeep *SOMETIMES* idle high?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: