no fuel no power to pump - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

no fuel no power to pump

Reply
 
 
 
Thread Tools Search this Thread
Old 06-02-2011, 07:34 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default no fuel no power to pump

90 4.0.... ok long story....had bad sending unit (ran out of fuel showing 1/4 tank) had to replace pump too. first pump replacement wouldnt pump up to pressure, second replacement just quit so i put in the original to take my chances on the gauge. next trip alternator dies. replaced alternator...next trip battery went dead (my own fault, left radio on too long with engine off) go a jump start. on the way home it just died. pump not comin on. towed it home recharged battery. pump still wont come on. took pump out put 12volts to it and it works. no power to it. checked and then jumped past relay. still no power. bypassed ballast resistor. no power still. no power to ballast resistor. ive started tracing wires. any other ideas?
elalr is offline   Reply With Quote
Old 06-03-2011, 10:40 AM   #2
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

anyone have a wiring diagram for a 90?
elalr is offline   Reply With Quote
Old 06-03-2011, 07:38 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

ran power to the pump and put it on a switch and it wont start. pump does run and it has pressure. now what? im going to check for spark now. im desperate this a daily driver. where else can i look?
elalr is offline   Reply With Quote
Old 06-03-2011, 08:27 PM   #4
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,536

View freegdr's Photo Album My Photos
Default

freegdr is offline   Reply With Quote
Old 06-03-2011, 08:30 PM   #5
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,536

View freegdr's Photo Album My Photos
Default

havbe you checked for ground at the ple for the pump
freegdr is offline   Reply With Quote
Old 06-03-2011, 10:18 PM   #6
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

i have tried to find all the grounds and freshen them. i cant understand why the pump wont come on with the key in the on pos. but does in the start pos. i read that in crank pos.the ballast is bypassed but i have bypassed it also with no luck.
elalr is offline   Reply With Quote
Old 06-03-2011, 11:09 PM   #7
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,536

View freegdr's Photo Album My Photos
Default

pump only runs for a couple of seconds when you first turn the key on its not doing that
freegdr is offline   Reply With Quote
Old 06-04-2011, 12:38 AM   #8
Seasoned Member
 
mike mike's Avatar
 
Join Date: Oct 2009
Location: Tucson AZ
Posts: 416

View mike mike's Photo Album My Photos
Default

Freegdr is right. When in "on" position pump primes and then the ground is taken away. Pump gets power 4 different ways. when key is on, when cranking, when running and at wide open throttle.
mike mike is offline   Reply With Quote
Old 06-04-2011, 09:07 AM   #9
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

the pump doesnt come on for the 3 sec at the first key turn. only at crank. i worked on it all day tracing wires and gave up. i read somewher also if there is no spark it wont pump but it should still have the 3 sec at first key turn i think.....im starting to lean towards the ecu
elalr is offline   Reply With Quote
Old 06-04-2011, 12:06 PM   #10
Seasoned Member
 
waltermitty's Avatar
 
Join Date: Feb 2011
Location: Memphis,TN area
Posts: 424

View waltermitty's Photo Album My Photos
Default

Quote:
Originally Posted by elalr View Post
the pump doesnt come on for the 3 sec at the first key turn. only at crank. i worked on it all day tracing wires and gave up. i read somewher also if there is no spark it wont pump but it should still have the 3 sec at first key turn i think.....im starting to lean towards the ecu
I would check for battery voltage at the pump plug. Get a girl friend to turn the key while you check the plug for voltage. IF you have voltage it's mote than likely the pump. If not I'd start at the fuse box, you've probably toasted the fuel pump relay fuse.
waltermitty is offline   Reply With Quote
Old 06-04-2011, 12:11 PM   #11
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

update..... i have no spark either. no power at fuel pump plug unless cranking.
elalr is offline   Reply With Quote
Old 06-04-2011, 12:46 PM   #12
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: south mo.
Posts: 85

View elalr's Photo Album My Photos
Default

problem solved!!! ecu exchanged with a doner and its alive!!!! thanks for all your help! the links helped made a difference.
elalr is offline   Reply With Quote
Old 06-04-2011, 12:56 PM   #13
Seasoned Member
 
waltermitty's Avatar
 
Join Date: Feb 2011
Location: Memphis,TN area
Posts: 424

View waltermitty's Photo Album My Photos
Default

Quote:
Originally Posted by elalr View Post
problem solved!!! ecu exchanged with a doner and its alive!!!! thanks for all your help! the links helped made a difference.
Congrats on solving your problem!
waltermitty is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1997 XJ Jeep Cherokee overheat issue solved shelby5041 OEM Cherokee Technical. All factory issues and info go here! 39 11-07-2015 01:22 AM
Fuel System Problems after overheating? Please help! Ye Ol' Cherokee OEM Cherokee Technical. All factory issues and info go here! 8 10-09-2015 10:29 PM
97 xj runs ruff or wont start riderjay253 OEM Cherokee Technical. All factory issues and info go here! 4 09-16-2015 11:31 AM
Fuel Pump Problems Ricardo Siqueiros OEM Cherokee Technical. All factory issues and info go here! 2 09-03-2015 09:17 PM
idk anymore please help Jicki Rough OEM Cherokee Technical. All factory issues and info go here! 1 09-02-2015 09:36 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 05:24 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send