Aftermarket electrical systems Aftermarket electronics only! stereo head units, CD players, MP3 players, speaker systems, amplifiers, hardmounted GPS devices, computers, headlight upgrades, fog lights, off-road lights, general wiring and anti-theft devices.

Total Lost. No sound through radio

Old 01-04-2018, 05:43 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2017
Posts: 3
Model: Cherokee(SJ)
Default Total Lost. No sound through radio

Me and my dad are at a lost... I have a 1998 Jeep Cherokee Classic 4.0 My factor radio works fine except the rear speakers. Recently I have been wanting subs in my Jeep. So I but the pionner 150mp and bought the Metra 70-1817 wiring harness. Far as we know we wired everything up correctly and according to some YouTube installs it is correct to what they have. We plug it on have a proper ground and everything. We had problems with same aftermarket radio before. But it was defective. So we took it back. And got the same one. We plugged it up in the morning. It worked then we go ahead install the subs with amp and all. We plug in the radio. It doesn't work. The subs played sound but no music from regular speakers. No static... Nothing. We unplug the subs still nothing no music. So we order a different brand radio. As the one was out for delivery we had my friends 98 grand cherokee. Plug in his radio and harness(same brand and model harness as mine) and doesn't work... Same issue. He then plugs in back into his Jeep and works again. So we get my harness and my pionner radio and it works in his Jeep. But we plug in my factor radio in mine again. And music is there. We are at a total lost. Please help.
THANK YOU
Joshua Wilkerson is offline  
Old 03-08-2018, 10:13 AM
  #2  
Newbie
 
Join Date: Feb 2018
Posts: 2
Year: 1999
Model: Cherokee(SJ)
Engine: 4.0L
Default

Did you ever figure out the cause? I installed a pioneer head unit in my XJ and everytime I press the brake pedal, the speakers turn off.
Dwyckoff is offline  
Old 03-08-2018, 05:42 PM
  #3  
Newbie
 
Join Date: Aug 2015
Posts: 12
Year: 1995 and 1997
Model: Cherokee
Engine: 4.0
Default No sound

You probably shorted out one of the speaker wires to the brake pedal wire for some reason. I had an issue with my sons stereo and found that I had put a screw through the speaker wire that ran to the overhead speakers.
bugman7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
andresr23
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
07-15-2015 05:35 PM
the_mumbling_jeep
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
15
03-27-2014 08:01 AM
882door
Modified XJ Cherokee Tech
5
07-09-2013 03:44 AM
xj_maniac_newb
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
38
02-15-2012 12:24 AM
SamSissine2
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
05-31-2011 03:14 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Total Lost. No sound through radio


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: