MJ Comanche Tech. Stock & Modified. MJ (86-92)
All discussion regarding the Jeep Comanche, the pickup truck related to the Cherokee platform.

stalling when coming to a stop... still

Old 10-02-2016, 02:25 PM
  #1  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default stalling when coming to a stop... still

been havin this problem for years now. if i adust tps it goes away for a day or two then acts up again. tried re doing the splice in the ground wire, cleaning the c101 new tps and iac. added battery ground. i tried to run a direct ground spliced into the tps ground wire but it just makes the idle race like at2000rpm, wont go down no matter what, i read that guys have done it with success so i dont know whats up with it. runs good other than that tho. does it worse with ac on.

88 5speed 90s motor, all sensors reading correct through snap on scanner.
Gmaster is offline  
Old 10-02-2016, 04:42 PM
  #2  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Are you adjusting the TPS correctly? Engine side per the instructions at www.cruiser54.com?
cruiser54 is offline  
Old 10-02-2016, 05:51 PM
  #3  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Yes. wierd it will run fine for a few trips after adjusting then go back to acting up. I thought tps was bad, but no. its not the throttle body either, i just installed a bored one from the guy on your site. engine does blow by alot but since it runs good after adjusting i think its something electrical. Do you have any idea why running a new ground for the tps would make it freak out? couse i dont understand it. unless the ecm supplies ground.
Gmaster is offline  
Old 10-02-2016, 07:13 PM
  #4  
CF Veteran
 
88whitecomanche's Avatar
 
Join Date: Oct 2013
Location: Miami, fl
Posts: 7,374
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Originally Posted by Gmaster View Post
Yes. wierd it will run fine for a few trips after adjusting then go back to acting up. I thought tps was bad, but no. its not the throttle body either, i just installed a bored one from the guy on your site. engine does blow by alot but since it runs good after adjusting i think its something electrical. Do you have any idea why running a new ground for the tps would make it freak out? couse i dont understand it. unless the ecm supplies ground.
Try unplugging the tps and drive it, I had similar issues and I ran with out a tps for a week until I bought one and adjusted it to cruisers tips...
The moment the tps gets any type of liquid that hits it, it'll be a crap shoot after a couple days....

Also, have you deleted connecter c101?
88whitecomanche is offline  
Old 10-02-2016, 07:17 PM
  #5  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Originally Posted by 88whitecomanche View Post
Try unplugging the tps and drive it, I had similar issues and I ran with out a tps for a week until I bought one and adjusted it to cruisers tips...
The moment the tps gets any type of liquid that hits it, it'll be a crap shoot after a couple days....

Also, have you deleted connecter c101?
no i havnt deleted it, i guess ive been putting that off for a while. but i did clean it. I would think that it would run like total crap with the tps umplugged. i ruled it out by replacing it.
Gmaster is offline  
Old 10-02-2016, 07:37 PM
  #6  
CF Veteran
 
88whitecomanche's Avatar
 
Join Date: Oct 2013
Location: Miami, fl
Posts: 7,374
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Originally Posted by Gmaster View Post
no i havnt deleted it, i guess ive been putting that off for a while. but i did clean it. I would think that it would run like total crap with the tps umplugged. i ruled it out by replacing it.
Shocking that it ran actually great with out it...
88whitecomanche is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rockchalk
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
16
09-28-2016 04:46 PM
Tenbears
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
21
09-18-2016 08:36 AM
GREY01
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
09-13-2016 04:06 PM
IJM
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
09-09-2016 06:57 AM
Kap
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
09-08-2016 03:50 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: stalling when coming to a stop... still


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: