Crank no start. - Jeep Cherokee Forum

Modified XJ Cherokee Tech XJ (84-01)
All modified tech questions. If it modifies your XJ beyond stock parts ask it here.

Crank no start.

Old 01-02-2019, 05:07 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2018
Location: Loxahatchee, Florida
Posts: 6
Year: 1999
Model: Cherokee (XJ)
Engine: 4.0
Default Crank no start.

99 Jeep XJ 4 door 12Ē lift 38s. Snorkel. Long arms Superchips programmed.

The list goes on. The problem I am having. I decided to completely water seal everything after I took it swimming. 😹. Skim activated after the dash was submerged in the pond and shut off. About a week of playing around and cleaning wires I had it running and driving again so I decided to go ahead and lay the interior dynomat so the entire dash and all came out after that I went ahead and inspected all interior wiring and electric grease alll connections I went ahead and reinstalled everything but the seats and carpet. I go ahead and try to start ( A+ charged 100% slow charge for 2 days) redtop battery. All fuses are good.
Turn the key on I have a couple dash lights No gauges no fuel pump prime but the fuel gets a prime the relay primes the fuel rail so that is good. On to the next one. No spark. Coil reading to the plug but no output. Just ordered a new cps. The code reader slot powers on the reader but does not read the codes. Spray starter fluid and does not start. Stumped 🤔

any sugustions.
How do you know when the computer takes a ****.
99xj12x38 is offline  
Old 01-04-2019, 08:27 PM
  #2  
Seasoned Member
 
SirCyber's Avatar
 
Join Date: Oct 2017
Location: Western Washington
Posts: 356
Year: 1990
Model: Cherokee
Engine: 4.0L Renix
Default

Ok so someone correct me if I'm wrong here. Call me out or something. Here goes.

The RELAY does nothing except tell the fuel pump to turn on and prime the fuel rail. You may have pressure, but if your fuel pump isn't priming, the system isn't receiving a prime. Test this with two people. Depress the valve at the end of your fuel rail, it's gonna squirt out a tiny bit of gas. When you turn the ignition to on, it will squirt out more. If it does, your fuel pump is indeed priming.

This is what I think may be your issue. I think you should check your ignition switch plug. See if there is a good connection, no corrosion, all connections are tight. Give those two test a chance and let us know
SirCyber is offline  
Old 01-07-2019, 11:03 PM
  #3  
Newbie
 
Join Date: Nov 2018
Location: Bronx, NY
Posts: 14
Year: 2000
Model: Cherokee (XJ)
Engine: 4.0
Default

When mine wouldn't start after a good engine bay cleaning and getting quite a bit of water everywhere, I pulled every connector and greased and dried them. Turned out I checked the ASD or ADS?? relay but not the 25 amp fuse in the passenger foot well. Cost me two days of checking everything, left my ecu in front of the heater for a whole day and changed the crank position sensor but in the end it was just the fuse and getting to know my new to me jeep for a whole weekend in the engine bay lol
jbusmc1986 is offline  
Old 01-14-2019, 04:07 PM
  #4  
Newbie
Thread Starter
 
Join Date: Oct 2018
Location: Loxahatchee, Florida
Posts: 6
Year: 1999
Model: Cherokee (XJ)
Engine: 4.0
Default Update.

Ordered a new crank sens. All fuses and relays are good the Jeep is now on my trailer and Iím going higher on the lift. I also changed the gauge cluster and pulled an ignition switch. Have Not had the chance to do the switch yet. Everything else is 100.

I can still not communicate with the computer through the diagnostics port. Has power to and from.

I changed the guage cluster and the and the same thing. No gauges work lights work but not the mileage this cluster shows the security key goes off then back on.

Ill try and get to the key switch tonight but it might be around 9pm working out of town.

I found a place to get the skim deleted and I need to go ahead and get that taken care of.

What are the solid silver fuses for on the kickpanel box ??
99xj12x38 is offline  
Old 01-15-2019, 12:17 AM
  #5  
Newbie
 
Join Date: Nov 2016
Posts: 23
Model: Cherokee
Default

my jeep shut off the other night when I came to a stop. wouldnt start back up for 30 minutes. no spark. finally started back up randomly. knockin my head on this too
Brett Hiltz is offline  
Old 01-15-2019, 05:15 PM
  #6  
Newbie
Thread Starter
 
Join Date: Oct 2018
Location: Loxahatchee, Florida
Posts: 6
Year: 1999
Model: Cherokee (XJ)
Engine: 4.0
Default

Originally Posted by Brett Hiltz View Post
my jeep shut off the other night when I came to a stop. wouldnt start back up for 30 minutes. no spark. finally started back up randomly. knockin my head on this too

did the security light come on ?
If not might be time to check ignition parts and ff
99xj12x38 is offline  
Old 01-15-2019, 11:40 PM
  #7  
Newbie
 
Join Date: Nov 2016
Posts: 23
Model: Cherokee
Default

Originally Posted by 99xj12x38 View Post



did the security light come on ?
If not might be time to check ignition parts and ff
no the security light didnít come on. Had fuel pressure just no spark.
Brett Hiltz is offline  
Old 01-16-2019, 07:19 AM
  #8  
Junior Member
 
odie64's Avatar
 
Join Date: Oct 2018
Posts: 33
Model: Cherokee (XJ)
Default

No gauges and no communication from the ALDL (assembly line data link) port for diagnostics and the dash was removed. First step is to go back and recheck all wiring under the dash. I am guessing something is loose or left disconnected.

Cranks/no start but has fuel pressure and no spark. you have replaced the crank position sensor and still does not start. The car went for a swim. Check the cam position sensor/hall effect switch/ coil pick-up sensor, ( it is the plastic disc piece in the distributor below the rotor button) if it has failed it will not trigger the coil to fire. and the car will crank but not start
odie64 is offline  
Old 01-31-2019, 10:47 AM
  #9  
Newbie
Thread Starter
 
Join Date: Oct 2018
Location: Loxahatchee, Florida
Posts: 6
Year: 1999
Model: Cherokee (XJ)
Engine: 4.0
Default More

Originally Posted by odie64 View Post
No gauges and no communication from the ALDL (assembly line data link) port for diagnostics and the dash was removed. First step is to go back and recheck all wiring under the dash. I am guessing something is loose or left disconnected.

Cranks/no start but has fuel pressure and no spark. you have replaced the crank position sensor and still does not start. The car went for a swim. Check the cam position sensor/hall effect switch/ coil pick-up sensor, ( it is the plastic disc piece in the distributor below the rotor button) if it has failed it will not trigger the coil to fire. and the car will crank but not start

pickup coil oil had an open circuit Iím guessing. Replaced with new. Something is not triggering the asd relay. Manually push the asd and it sends 12v to injectors fuel and coil. No coil output. And still no start. Getting another CPAís today and a coil just to check if I got a bad part. Still no gauges and still no initial fuel prime associated with the asd relay. The headlight switch does not work properly Iím guessing because I donít get any illumination lights with the lights on or off.
99xj12x38 is offline  
Old 02-12-2019, 05:28 AM
  #10  
Newbie
Thread Starter
 
Join Date: Oct 2018
Location: Loxahatchee, Florida
Posts: 6
Year: 1999
Model: Cherokee (XJ)
Engine: 4.0
Default Finally we have a start and run by key




After tracing wires for 3 weeks externally we have a crank and start by key. It ended up being a asd relay communication problem. All wires had signal and finally after I waited for ever for a helper just for a couple minutes I ended up getting someone to hit the key for me while I was outside under the hood.

I ran 2 relays to signal the original asd relay because it will not send the power through the rite way. I now have it down to 1 relay triggering the asd relay And we are good. No matter what way I run the asd relay it will not function properly. Or drained the battery. The second relay is hooked up to the original computer ground signal and the output goes to the fuses and triggers the asd.

As as far as that. When I hooked the relays up that way I got working gauges and can again read the obd port. As far as now everything else works properly.

In in the end.............. it ended up being security and asd.

Thanks for everyoneís input
99xj12x38 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ChadMagruderhasaJeep
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
5
10-21-2017 07:33 PM
Jeo228
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
19
10-21-2017 07:37 AM
besthaticouldo
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
6
05-26-2015 01:53 PM
gasouthernxj
Cherokee Chat
2
12-23-2013 09:17 PM
Haulin
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
16
03-15-2012 02:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Crank no start.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: