turn signals wont work - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

turn signals wont work

Reply
 
 
 
Thread Tools Search this Thread
Old 10-26-2011, 09:47 AM   #1
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default turn signals wont work

The turn signals on my 89xj wont work.The front and back signals dont work and the arrows dont show up on the dash. I just replaced the bulbs so thats not it. I just dont know where to start.
my89xj is offline   Reply With Quote
Old 10-26-2011, 11:17 AM   #2
Senior Member
 
cpnwrench's Avatar
 
Join Date: Jun 2009
Location: West Texas
Posts: 551

View cpnwrench's Photo Album My Photos
Default



replace the turn signal assembly which is easliy accessed by removing the colum cover and steering wheel.

the turn signal lever comes out by pushing it straight in and rotating it. then pull straight out away from column.

then you can get to the turn signal switch assembly.

before doing this, have you changed out the turn signal relay located in the fuse panel?


cpnwrench

cpnwrench is offline   Reply With Quote
Old 10-27-2011, 05:34 AM   #3
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default

I haven't replaced the relay yet, ill do that first.
my89xj is offline   Reply With Quote
Old 10-27-2011, 05:35 AM   #4
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 46,530

View freegdr's Photo Album My Photos
Default

do the emergency flashers work
freegdr is offline   Reply With Quote
Old 10-27-2011, 08:10 AM   #5
Newbie
 
Join Date: Oct 2011
Posts: 14

View goolsbayjeep's Photo Album My Photos
Default

before you replace the assembly try changing the relay and fuses first, always start with the cheapest/simplest part
goolsbayjeep is offline   Reply With Quote
Old 10-27-2011, 08:41 AM   #6
CF Veteran
 
no rdplz's Avatar
 
Join Date: Jan 2010
Location: Virginia Beach by way of Michigan
Posts: 5,473

View no rdplz's Photo Album My Photos
Default

agreed, check the fuse and relay. the relay is a pretty common issue on XJ's and it's a cheap and easy fix.
no rdplz is offline   Reply With Quote
Old 11-10-2011, 06:07 AM   #7
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default

Where do you guys buy parts from? I've been buying from morris but is there a cheaper place?
my89xj is offline   Reply With Quote
Old 11-14-2011, 12:50 PM   #8
CF Veteran
 
jomps's Avatar
 
Join Date: Apr 2010
Location: knoxville, tn
Posts: 3,966

View jomps's Photo Album My Photos
Default

i found the relay under dash at a jy for under three dollars with warranty...do your hazards work? my hazards worked and i could hear relay clicking but when i used turn signal it would click once and stop...maybe that info will be helpful: good luck
jomps is offline   Reply With Quote
Old 11-16-2011, 07:58 PM   #9
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default

My hazards don't work. I don't even hear the clicking for the turnsignals or the hazards.
my89xj is offline   Reply With Quote
Old 11-17-2011, 12:00 AM   #10
CF Veteran
 
jomps's Avatar
 
Join Date: Apr 2010
Location: knoxville, tn
Posts: 3,966

View jomps's Photo Album My Photos
Default

id start with the relay...
jomps is offline   Reply With Quote
Old 11-17-2011, 12:35 AM   #11
CF Veteran
 
F1Addict's Avatar
 
Join Date: Nov 2011
Location: SoCal
Posts: 2,280

View F1Addict's Photo Album My Photos
Default

I would also check the harness under the dash that comes from the column. It's a wide, blade type harness. I was having an issue with my indicators as well and found that somehow, the harness had been partially disconnected. It was either done by the person who installed the stereo twelve years ago or they come loose on their own.
F1Addict is offline   Reply With Quote
Old 11-26-2011, 04:22 PM   #12
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default

Ok so I have flashers now. My right turn signal worked for a few seconds. Also were do I find the relay
my89xj is offline   Reply With Quote
Old 11-26-2011, 06:39 PM   #13
CF Veteran
 
jomps's Avatar
 
Join Date: Apr 2010
Location: knoxville, tn
Posts: 3,966

View jomps's Photo Album My Photos
Default

mine was under the headlight switch on my 2000....google will help!
jomps is offline   Reply With Quote
Old 11-26-2011, 06:58 PM   #14
CF Veteran
 
alsxj's Avatar
 
Join Date: Sep 2010
Location: Coos Bay, Or
Posts: 1,024

View alsxj's Photo Album My Photos
Default

There is no relay for the turn signals on the older xjs, just the flasher on the fuse box. In the fuse box, check out the slots where the flashers plug in, make sure there corrision free and in good condition. Did you check the connection at the steering colomn to the switch. If you know how to use a multimeter, this would be the time to bust it out.
alsxj is offline   Reply With Quote
Old 11-28-2011, 06:05 AM   #15
CF Veteran
Thread Starter
 
my89xj's Avatar
 
Join Date: Sep 2011
Location: Frederick, MD
Posts: 10,429

View my89xj's Photo Album My Photos
Default

Connections are good. And my bad I meant my hazards work now.
my89xj is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Harmonic balancer and overheating Aryl OEM Cherokee Technical. All factory issues and info go here! 8 11-20-2016 09:17 AM
Headlight switch isn't working. Help! BayArea93xj OEM Cherokee Technical. All factory issues and info go here! 8 06-11-2016 10:43 AM
No buS help ammonllewis1 OEM Cherokee Technical. All factory issues and info go here! 9 08-31-2015 11:27 AM
Need help troubleshooting tail light problem rusty_bucket OEM Cherokee Technical. All factory issues and info go here! 3 08-29-2015 06:42 AM
Cam Sensor Hard Failure CCKen OEM Cherokee Technical. All factory issues and info go here! 3 08-20-2015 08:07 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:31 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send