Missing - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Missing

Reply
 
 
 
Thread Tools Search this Thread
Old 12-09-2012, 08:50 AM   #1
Junior Member
Thread Starter
 
resqman911's Avatar
 
Join Date: Oct 2012
Location: Rancho Cucamonga CA
Posts: 84

View resqman911's Photo Album My Photos
Default Missing

Hey guys I have run into an issue twice now while out wheeling my 98 Xj. The Jeep runs fine but once it gets warm after crawling for awhile and I shut it off, it will run rough on restart but only for a minute and only at low rpm, if I rev it up a few times it seems to clean itself up. I thought maybe a leaky injector was fouling a cylinder, but someone else mentioned the crank shaft sensor, what do you guys think.
resqman911 is offline   Reply With Quote
Old 12-09-2012, 07:30 PM   #2
Senior Member
 
scottmphoto's Avatar
 
Join Date: Jan 2011
Location: Russellville, Arkansas
Posts: 955

View scottmphoto's Photo Album My Photos
Default

It could also be a heat soak problem. My '91 used to do this until the engine cooled off a bit then it'd run fine.
scottmphoto is offline   Reply With Quote
Old 12-09-2012, 07:33 PM   #3
Junior Member
Thread Starter
 
resqman911's Avatar
 
Join Date: Oct 2012
Location: Rancho Cucamonga CA
Posts: 84

View resqman911's Photo Album My Photos
Default

I did a little more research and thats what I came up with also. " Heat Soak " seems to be pretty common under the conditions I described.
resqman911 is offline   Reply With Quote
Old 12-09-2012, 09:13 PM   #4
CF Veteran
 
captainwoot's Avatar
 
Join Date: Aug 2009
Location: Hanover,Ont, Canada
Posts: 1,047

View captainwoot's Photo Album My Photos
Default

You are right on the money, heat soak is a common issue.\
captainwoot is offline   Reply With Quote
Old 12-09-2012, 09:21 PM   #5
CF Veteran
 
peep's Avatar
 
Join Date: Oct 2010
Location: Ontario, Canada
Posts: 2,050

View peep's Photo Album My Photos
Default

Georgia? Yep you got some heat there. you could vent the hood or for sh & gig experiment, raise the hood at rear for some venting and see if same conditions occur?
peep is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AX15 to Aw4 swap Cherospeed99 Modified Cherokee Tech 9 10-07-2015 09:34 PM
Suddenly, rotting carcass smell - BAD SouthSeaPirate OEM Cherokee Technical. All factory issues and info go here! 26 10-06-2015 07:43 AM
2001 XJ problems? pmd1995 OEM Cherokee Technical. All factory issues and info go here! 1 09-29-2015 11:37 PM
FS[MidAtl]: K&N Drop In Air Filter M4RK Accessories 0 09-29-2015 11:19 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:12 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send