Notices
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

96 xj, running rough while in gear, but fine at idle

Old 05-13-2019, 12:17 PM
  #1  
Junior Member
Thread Starter
 
Wrongholefool's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Posts: 32
Year: 1999, 1996X3, 1997
Model: Cherokee (XJ)
Engine: 4.0
Default 96 xj, running rough while in gear, but fine at idle

Hi, just looking for some advice. My 96 xj 5 speed seems like its not getting fuel sporadically. Sometimes at start up, but mostly after being driven for about 20-30 minutes. Has never stalled of shut off completely, just have to slip the clutch and over rev the **** out of it to get moving. No check engine light, the cat is removed, but still has both o2 sensors. Not sure if its a fuel supply issue, or something else. It will idle and rev in neutral or with the clutch in, but once i get it in gear it feels like its not getting fuel. Any help is appreciated. Im about to throw a few sensors at it, mainly crank, and cam. might replace the fuel pump as well. jeep is a project and is made from running jeeps that had sat for some time. thanks for reading.
Wrongholefool is offline  
Old 05-16-2019, 09:47 AM
  #2  
Junior Member
 
Join Date: Feb 2018
Location: Montana
Posts: 56
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0
Default

sounds similar to what was going on with my 96, new fuel pump fixed it
CastorTroy is offline  
Old 05-16-2019, 02:54 PM
  #3  
Junior Member
Thread Starter
 
Wrongholefool's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Posts: 32
Year: 1999, 1996X3, 1997
Model: Cherokee (XJ)
Engine: 4.0
Default

i think that might be my problem too. First im gonna put a cat on it to see if that makes a difference. i have a 97 wrangler that acted the same way when it an o2 sensor was bad. engine light stayed off the first few times it happened, but came on eventually. the cherokee has both new sensors and my obd2 says theyre working, but it wont finish the catalyst ready monitor.
Wrongholefool is offline  
Old 05-17-2019, 06:06 PM
  #4  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,653
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

Don't just throw parts at it. This forum does not support that mode of repair.
Sounds like a fuel problem, so the thing to do is a fuel pressure test with a tester. Then a leakdown test. What you describe is more like a plugged fuel filter, which, there are 2 on the fuel pump, but also could be just low pressure. Either way, test it. If it takes a long time to start that would be the regulator, also on the pump... Also can be tested with pressure tester leak down test.
97grand4.0 is offline  
Old 05-18-2019, 09:01 AM
  #5  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,772
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by 97grand4.0 View Post
Don't just throw parts at it. This forum does not support that mode of repair.
Sounds like a fuel problem, so the thing to do is a fuel pressure test with a tester. Then a leakdown test. What you describe is more like a plugged fuel filter, which, there are 2 on the fuel pump, but also could be just low pressure. Either way, test it. If it takes a long time to start that would be the regulator, also on the pump... Also can be tested with pressure tester leak down test.

I love THAT part: This forum does not support that mode of repair.
cruiser54 is offline  
Old 05-18-2019, 09:12 AM
  #6  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,653
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

Heh! Just checking your alertness! I may have outdid myself with that one
97grand4.0 is offline  
Old 05-18-2019, 09:13 AM
  #7  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,772
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by 97grand4.0 View Post
Heh! Just checking your alertness! I may have outdid myself with that one
No kidding!! Good "signature" material.
cruiser54 is offline  
Old 05-18-2019, 07:14 PM
  #8  
CF Veteran
 
Join Date: May 2012
Location: Lost in the wilds of Virginia
Posts: 4,547
Year: 1998 Classic (I'll get it running soon....) and 96 (just purchased) and 02 Grand
Model: Cherokee (XJ)
Engine: 4.0
Default

The chances of a cat fixing your problem are slim to none. Do the pressure test.

Don't fire the parts cannon.
BlueRidgeMark is offline  
Old 05-18-2019, 07:15 PM
  #9  
CF Veteran
 
Join Date: May 2012
Location: Lost in the wilds of Virginia
Posts: 4,547
Year: 1998 Classic (I'll get it running soon....) and 96 (just purchased) and 02 Grand
Model: Cherokee (XJ)
Engine: 4.0
Talking

Originally Posted by 97grand4.0 View Post
Don't just throw parts at it. This forum does not support that mode of repair..



BlueRidgeMark is offline  
Old 05-20-2019, 09:25 AM
  #10  
Junior Member
Thread Starter
 
Wrongholefool's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Posts: 32
Year: 1999, 1996X3, 1997
Model: Cherokee (XJ)
Engine: 4.0
Default

i reload all my own parts cannon rounds, i have about 5 cherokees worth of parts sitting around. it would cost more to get a pressure tester than for me to just swap in another sending unit with a new pump and filter. sorry to trigger all you parts cannon control nuts.
Wrongholefool is offline  
Old 05-20-2019, 09:57 AM
  #11  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,653
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

Originally Posted by Wrongholefool View Post
i reload all my own parts cannon rounds, i have about 5 cherokees worth of parts sitting around. it would cost more to get a pressure tester than for me to just swap in another sending unit with a new pump and filter. sorry to trigger all you parts cannon control nuts.
As long as you are not spending MONEY on it and your time is expendable, then absolutely, go for the Hanes manual "exchange for a known good" method. I admit to having a box of junkyard parts also.
97grand4.0 is offline  
Old 05-20-2019, 12:32 PM
  #12  
Junior Member
Thread Starter
 
Wrongholefool's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Posts: 32
Year: 1999, 1996X3, 1997
Model: Cherokee (XJ)
Engine: 4.0
Default

Id be a little more discerning if it were my daily driver, but it can sit in the garage till its good n ready to hit the streets. thanks for all your input,
Wrongholefool is offline  
Old 05-20-2019, 01:41 PM
  #13  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,653
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

[QUOTE=Wrongholefool;3555606] once i get it in gear it feels like its not getting fuel.
Probably isn't. That's a symptom of plugged filter or bad pump. I think the big box stores will lend you a tester.
97grand4.0 is offline  
Old 05-22-2019, 08:17 AM
  #14  
Junior Member
Thread Starter
 
Wrongholefool's Avatar
 
Join Date: Apr 2016
Location: Pittsburgh
Posts: 32
Year: 1999, 1996X3, 1997
Model: Cherokee (XJ)
Engine: 4.0
Default

Fuel pump, pulled it out and the screen looked like it was collapsing. Put a new one in and it runs great. Took about 30 minutes start to finish. Thanks again for the advice.
Wrongholefool is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
XJGirl
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
20
04-08-2018 07:14 AM
91WhiteXJ
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
22
06-21-2016 10:01 AM
DJKnightmare
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
07-23-2015 08:33 AM
BIGISLANDHIKERS
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
05-26-2012 04:03 PM
captlim72
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
01-02-2011 11:32 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 96 xj, running rough while in gear, but fine at idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: