Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 02-20-2011, 04:34 PM   #1
Newbie
 
Join Date: Sep 2009
Posts: 10

View Go Mifuni's Photo Album My Photos
1996 Cherokee
Default No Directionals, No Hazards, No Clue!

Hi! I'm pretty new to this forum, but I was a member of a Mercury Marauder forum for the 7 years I owned one so I know this is the best place to go for help and answers! I've done a search and couldn't find anything that helped me so...
A week or so ago, I noticed my Directionals stopped working as well as my Hazards. I've ohmed out every fuse, both under the dash (the driver's side of the steering column), and under the hood, and replaced both the combo Directional/Hazard flasher as well as the switch. Still nothing! Anyone encounter anything similar with a '96 Sport? I don't know where else to look. Any help would greatly be appreciated!
Go Mifuni is offline   Reply With Quote
Old 02-20-2011, 04:40 PM   #2
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,232

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

have you checked the groungs
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 02-20-2011, 04:43 PM   #3
Newbie
 
Join Date: Sep 2009
Posts: 10

View Go Mifuni's Photo Album My Photos
1996 Cherokee
Default

Quote:
Originally Posted by freegdr View Post
have you checked the groungs
Not quite sure how to check those. Details please?
Go Mifuni is offline   Reply With Quote
Old 02-20-2011, 04:48 PM   #4
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,232

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

if you remove the turn signal lens in fromt of battery hook the test light/meter to the postive side of battery take the other end and test the bulb socket it should light if one of the two contacts in the socket are grounded its reverse of checking for volts
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 02-20-2011, 05:06 PM   #5
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,232

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

turn signal switch in arm is suspect here to as you checked all fuse for 12 volts on both sides correct feed and supply
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 02-20-2011, 05:18 PM   #6
CF Veteran
 
The Rooster's Avatar
 
Join Date: Feb 2011
Location: Bergen County, New Jersey U.S.A.
Posts: 3,048

View The Rooster's Photo Album My Photos
1990 Laredo Cherokee
Default

i know this sounds dumb but did you check your bulbs? or the bulb sockets... stranger things have happened...
__________________
1990 Jeep Cherokee Laredo Renix 4.0
All Stock org.
I seem to have a lot of Shiney Chrome on my Jeep am I Alone...
R.I.P. 96_XJ
Make your Renix Jeep "Cruiser54 Certifed" Click the link below
(Fixes most(87-90) Renix Jeep problems)
http://www.cherokeeforum.com/f51/cru...x-tips-153657/
The Rooster is offline   Reply With Quote
Old 02-20-2011, 05:19 PM   #7
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,232

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Quote:
Originally Posted by The Rooster View Post
i know this sounds dumb but did you check your bulbs? or the bulb sockets... stranger things have happened...
that be some thing all 4 bulbs bad lol
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 02-20-2011, 05:24 PM   #8
CF Veteran
 
The Rooster's Avatar
 
Join Date: Feb 2011
Location: Bergen County, New Jersey U.S.A.
Posts: 3,048

View The Rooster's Photo Album My Photos
1990 Laredo Cherokee
Default

Quote:
Originally Posted by freegdr View Post
that be some thing all 4 bulbs bad lol
i brought a jeep like that... that is why it was for sale it had no turn signals.. turns out 2 bulbs where bad and the other 2 the sockets were rusty... so thats why i say to check it... just going by experince... I hated the 2.8 it had tho...
__________________
1990 Jeep Cherokee Laredo Renix 4.0
All Stock org.
I seem to have a lot of Shiney Chrome on my Jeep am I Alone...
R.I.P. 96_XJ
Make your Renix Jeep "Cruiser54 Certifed" Click the link below
(Fixes most(87-90) Renix Jeep problems)
http://www.cherokeeforum.com/f51/cru...x-tips-153657/
The Rooster is offline   Reply With Quote
Old 02-20-2011, 05:29 PM   #9
Junior Member
 
Join Date: Feb 2011
Posts: 50

View MisAdventure's Photo Album My Photos
Cherokee
Default

fret no longer my friend, I have the same truck and three weeks ago i had the same problem. feel under your knee panel dash thing. it should be to the right of your steering wheel that you feel two square relays, you will find that one is red and one is blue. The blue relay is actually multifunction and controls both your hazards and your signals. I ran into a problem where my signals wouldn't do anything at all. So I removed the entire relay panel (two screw cap thingys) and looked on the back portion of the panel where the blue relay sits. After studying the wiring diagram for the whole duration of going to the bathroom, I realized that the panel was fed hot at all times power from the pdc under the hood and that it recieved switched power from the fuse panel under the dash. So instead of rippingoff the fuse panel (nightmare), I decided to jump the hot at all times with the fused power. I believe it was tan and red, however once you get looking at it, it will be fairly obvious what to do. You can also try replacing the multi function flasher, but its about twenty bucks so get one from the wreckers, fyi you can also take them from Grand Cherokees of the same year, just look for the same steering column cover and you will know its okay to dig in that one.

Before I figured out it was the flasher, I replaced the chassis grounds, engine grounds, cleaned all contact in the PDC, I cleaned the contacts in the ignition switch and the turn signal switch, and replaced a couple of sockets and cut and connectored the harness for the front lights under the air filter box. Trust me, try the relay first. Please, its the easiest and all you might need is a jumper wire.

The end result of my fix, is that the ignition switch has to be on in order to use the 4 ways.

hope this helps.

refer to my other post "Cherokee Teeth Puller"
MisAdventure is offline   Reply With Quote
Old 02-20-2011, 06:09 PM   #10
Senior Member
 
Join Date: Nov 2009
Location: McCall,Idaho
Posts: 539

View goblinish15's Photo Album My Photos
1991 Cherokee
Default

for my i had no hazards cuz there is a red wire going to my battery and it was not connected to the battery. it conrolled my brake lightss and hazards start there
goblinish15 is offline   Reply With Quote
Old 02-20-2011, 06:32 PM   #11
Junior Member
 
Join Date: Feb 2011
Posts: 50

View MisAdventure's Photo Album My Photos
Cherokee
Default

Look at a wiring diagram.
MisAdventure is offline   Reply With Quote
Old 02-21-2011, 07:01 AM   #12
Newbie
 
Join Date: Sep 2009
Posts: 10

View Go Mifuni's Photo Album My Photos
1996 Cherokee
Default

Quote:
Originally Posted by MisAdventure View Post
fret no longer my friend, I have the same truck and three weeks ago i had the same problem. feel under your knee panel dash thing. it should be to the right of your steering wheel that you feel two square relays, you will find that one is red and one is blue. The blue relay is actually multifunction and controls both your hazards and your signals. I ran into a problem where my signals wouldn't do anything at all. So I removed the entire relay panel (two screw cap thingys) and looked on the back portion of the panel where the blue relay sits. After studying the wiring diagram for the whole duration of going to the bathroom, I realized that the panel was fed hot at all times power from the pdc under the hood and that it recieved switched power from the fuse panel under the dash. So instead of rippingoff the fuse panel (nightmare), I decided to jump the hot at all times with the fused power. I believe it was tan and red, however once you get looking at it, it will be fairly obvious what to do. You can also try replacing the multi function flasher, but its about twenty bucks so get one from the wreckers, fyi you can also take them from Grand Cherokees of the same year, just look for the same steering column cover and you will know its okay to dig in that one.

Before I figured out it was the flasher, I replaced the chassis grounds, engine grounds, cleaned all contact in the PDC, I cleaned the contacts in the ignition switch and the turn signal switch, and replaced a couple of sockets and cut and connectored the harness for the front lights under the air filter box. Trust me, try the relay first. Please, its the easiest and all you might need is a jumper wire.

The end result of my fix, is that the ignition switch has to be on in order to use the 4 ways.

hope this helps.

refer to my other post "Cherokee Teeth Puller"
Yeah, the flasher was $25. I'll try checking the grounds and pulling that relay block and checking for both the constant hot and the switchable hot. Finding a wiring diagram for a '96 has been a nightmare!
Go Mifuni is offline   Reply With Quote
Old 02-23-2011, 03:46 PM   #13
Junior Member
 
Join Date: Feb 2011
Posts: 50

View MisAdventure's Photo Album My Photos
Cherokee
Default

your 96 xj may have the same wiring as a 97 keep that in mind.
MisAdventure is offline   Reply With Quote
Old 02-23-2011, 05:54 PM   #14
Member
 
Join Date: May 2009
Location: Rochester NY
Posts: 193

View Bigclubs's Photo Album My Photos
1996 Cherokee
Default

With the age of your vehicle I would check the wiring under your air filter box for a broken wire. My 96 had the same problem last year where my turn signals stopped working, but hazzard did. Checked, bulbs, sockets, grounds and started tracing wiring and found the wires had corroded at broken at the connecter under the air filter box. Thought I would have to replace the whole harness, so asked a jeep dealer mechanic friend and he said "We have see this on older vehicles and just cut out the connector, there us usually just enough wire to solder them together or just leave the connector in place and jump the broken wires and bypass the connector" I jumped my 3 broken wires and my lights work fine. Will get around to removing the connector when weather is better and I have more time.
Bigclubs is offline   Reply With Quote
Old 02-23-2011, 05:54 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
96 ZJ shaking and jerking.... :o( No clue where to start! AngelFire Grand Cherokee Tech 6 11-09-2010 06:08 PM
track bar what is up with this i have no clue jasonsk1984 OEM Cherokee Tech 10 06-27-2010 03:31 PM
Have no clue what to do. GoreXJ95 OEM Cherokee Tech 12 05-06-2010 10:23 PM
i have no clue whats wrong!!! carencro xj OEM Cherokee Tech 13 03-31-2010 08:48 PM
Anybody have a clue?? JerseyJeeper OEM Cherokee Tech 2 12-29-2009 08:03 PM


All times are GMT -5. The time now is 12:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup