KL Cherokee Tech KL (14+)
2014 Cherokee Forum for all new KL and Cherokee Trailhawk discussion and tech information.
Sponsored by:
Sponsored by:

Uconnect problem after update

Old 01-22-2018, 03:58 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default Uconnect problem after update

Hello everyone, I'm a new member and this is my first post. I recently purchased a 2014 Cherokee Limited when my old faithful '98 Grand Cherokee finally gave up on me for the last time. Anyway, shortly after buying the vehicle, I started getting messages on the UConnect 8.4 screen wanting me to perform a software update. I went ahead and did the update, and ever since my Navigation system has lost it's mind. It'll work fine early in the morning, but then it starts wandering all over the map. At the end of a recent 5 mile trip from my work, it showed the jeep sitting in the middle of a resevoir some 30 miles away. Also the compass is all screwed up and won't recalibrate. I was going to reinstall the update and downloaded it from the UConnect site. The site says that version 17.11.07 is the most current for my vehicle, however when l check the version number on the UConnect screen, it says version 17.11.17, and the system won't let me install the downloaded software. I've tried to find any information on ver. 17.11.17, but to no avail. Is there any way to "roll back" the software to an earlier version (Nav was working just fine before the update)? If not, I've seen how to reset the system back to factory spec, but I don't want to do that until l find out exactly what that would do. Murphy's law is a way of life. What l'm asking is if l have any options open to me to get the Nav working correctly or not. Thanks for any input you can give me on this.
jpcherok2014 is offline  
Old 01-22-2018, 04:19 PM
  #2  
Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 135
Model: Cherokee
Default

Originally Posted by jpcherok2014 View Post
Hello everyone, I'm a new member and this is my first post. I recently purchased a 2014 Cherokee Limited when my old faithful '98 Grand Cherokee finally gave up on me for the last time. Anyway, shortly after buying the vehicle, I started getting messages on the UConnect 8.4 screen wanting me to perform a software update. I went ahead and did the update, and ever since my Navigation system has lost it's mind. It'll work fine early in the morning, but then it starts wandering all over the map. At the end of a recent 5 mile trip from my work, it showed the jeep sitting in the middle of a resevoir some 30 miles away. Also the compass is all screwed up and won't recalibrate. I was going to reinstall the update and downloaded it from the UConnect site. The site says that version 17.11.07 is the most current for my vehicle, however when l check the version number on the UConnect screen, it says version 17.11.17, and the system won't let me install the downloaded software. I've tried to find any information on ver. 17.11.17, but to no avail. Is there any way to "roll back" the software to an earlier version (Nav was working just fine before the update)? If not, I've seen how to reset the system back to factory spec, but I don't want to do that until l find out exactly what that would do. Murphy's law is a way of life. What l'm asking is if l have any options open to me to get the Nav working correctly or not. Thanks for any input you can give me on this.
Hi jpcherok2014,

We recommended a hard reset after the OTA update for those who had the backup camera, and it appeared to be washed out. A hard reset will set you back to factory specs, so you will lose saved information, like Bluetooth pairings, station favorites, saved locations, etc.

Kori
Jeep Social Care Specialist
JeepCares is offline  
Old 01-22-2018, 04:23 PM
  #3  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

Thanks for your quick reply Kori. One quick question...the hard reset you refer to is disconnecting the battery cables, tie them together with string or zip tie and leave it overnight, right? I'll give it a try and let you know what happens.
jpcherok2014 is offline  
Old 01-22-2018, 04:45 PM
  #4  
Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 135
Model: Cherokee
Default

Originally Posted by jpcherok2014 View Post
Thanks for your quick reply Kori. One quick question...the hard reset you refer to is disconnecting the battery cables, tie them together with string or zip tie and leave it overnight, right? I'll give it a try and let you know what happens.
Almost, not quite: on your screen go to Settings -> System Information -> Reset to Factory Default.

Kori
Jeep Social Care Specialist
JeepCares is offline  
Old 01-23-2018, 06:22 PM
  #5  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

I tried the hard reset you recommended and what do you know...success!! I have to admit it did come with some tense moments and raised blood pressure. When the reset was finished the screen went "prehistoric" and I lost a lot of the functions I had previously. Also the Check Engine light came on. I figured l would have to bite the bullet and visit the Jeep Dealer. When I came back to the car after work, the full screen with all the options I had previously had come back. The Nav system had to be recalibrated but was working fine within 5 minutes. The check engine light took a while longer but after a while went out. Kori, thanks so much for your help...you've saved me lots of stress and anger over the issue l was having. Thanks again.
jpcherok2014 is offline  
Old 01-24-2018, 10:10 AM
  #6  
Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 135
Model: Cherokee
Default

Originally Posted by jpcherok2014 View Post
I tried the hard reset you recommended and what do you know...success!! I have to admit it did come with some tense moments and raised blood pressure. When the reset was finished the screen went "prehistoric" and I lost a lot of the functions I had previously. Also the Check Engine light came on. I figured l would have to bite the bullet and visit the Jeep Dealer. When I came back to the car after work, the full screen with all the options I had previously had come back. The Nav system had to be recalibrated but was working fine within 5 minutes. The check engine light took a while longer but after a while went out. Kori, thanks so much for your help...you've saved me lots of stress and anger over the issue l was having. Thanks again.
Very glad to hear this worked!

Kori
Jeep Social Care Specialist
JeepCares is offline  
Old 01-24-2018, 06:33 PM
  #7  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

Just an update....My Nav system is wacky again. I called UConnect and they told me that other people have had the same problem and they have a new update coming out within the next 2 weeks that will take care of the problem. I'll just have to wait and see what happens....
jpcherok2014 is offline  
Old 02-10-2018, 07:57 AM
  #8  
Junior Member
 
Join Date: Nov 2014
Posts: 55
Model: Cherokee
Default Have you seen a new update yet?

My bet is an new update won't happen for a while....Went to the site, no new updates....
guitar54 is offline  
Old 03-16-2018, 04:23 PM
  #9  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

You are absolutely correct. It's now mid March and still no update and the Nav System is no longer working again. I sent a request to Jeep customer service and was told they're aware of the problem (again) and that an update was in the works. They wouldn't give me a time frame for the update availability but that it was coming. Starting to sound like the old joke of a promoter coming to town and putting up a sign saying "It's coming!" A couple of weeks later he comes back and puts up another sign saying "It'll be here, tickets on sale and so on." FInially the day of the show the promoter sneaks into town and puts up a sign that says "It's gone folks, you missed it!!. It just seems to me that all l'm going to get is lip service and not much else. I know several people who have the UConnect system and they all have had problems. Chrysler would be wise to get rid of UConnect and get another system that works.
jpcherok2014 is offline  
Old 03-17-2018, 07:57 AM
  #10  
Junior Member
 
Join Date: Nov 2014
Posts: 55
Model: Cherokee
Default

Yep! I've been down this "software update" path many times now. Other car companies update their software with no issues...know this from another car...
guitar54 is offline  
Old 04-04-2018, 07:33 PM
  #11  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

I am finding it impossible to find information on what exactly was fixed or changed in the Uconnect software version 17.11.17. It's like it's some big corporate secret for FCA. One thing I have found is that the version 17.11.17 was supposed to be for the Dodge Ram vehicles and not the Jeep. Jeep was supposed to still have 17.11.07. Don't know what difference the vehicle would make as the Uconnect system should work the same in both vehicles. Anyway all l know is that everything (including NAV) worked fine with version 17.11.07 and with 17.11.17 not so much.
jpcherok2014 is offline  
Old 05-30-2018, 07:04 PM
  #12  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

Software Update. I found that UConnect has a new update out for it's system. The version is: 17.43.01 and was released in March of this year. To date there has been no OTA update notification or any update notification of any kind. Of course there is no information on what the update adds or fixes. With the problems I've experienced with the previous update, I'm a bit gun shy about installing it. If anyone has any information on what this update does, it would be greatly appreciated. Thanks, in advance.
jpcherok2014 is offline  
Old 05-31-2018, 11:14 PM
  #13  
Newbie
 
Join Date: Mar 2018
Posts: 15
Model: Cherokee(SJ)
Default

I updated to 17.43.01 mainly because my nav system was doing what you described.... it didn't help. Some days it will track nicely for a little while but it always loses track and shows i am going in a direction other than what i really am. Very disappointing that i spent so much money on activating my navigation and it's totally worthless.
jpregione is offline  
Old 06-02-2018, 07:26 PM
  #14  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 16
Model: Cherokee(SJ)
Default

Sorry to hear that the update doesn't help. When I updated my system, the update failed at 67% at Unit 11. It reattempted to perform the update several times and I spent an hour and a half burning gas for nothing. Now all of the UConnect controlled functions no longer work. I called UConnect and was told that now I have to take my Jeep to the dealership to get a diagnostic to determine the problem. No doubt it's going to cost a small fortune to get it diagnosed and repaired. If l can get this fixed, l'm never going update this thing again. If l need NAV, I'll break out my Garmin...it always works.
jpcherok2014 is offline  
Old 06-02-2018, 07:48 PM
  #15  
Newbie
 
Join Date: Mar 2018
Posts: 15
Model: Cherokee(SJ)
Default

My update failed multiple times as well, at the same unit and was stuck in a cycle where it kept asking me to insert usb. On my way to work I put the usb stick in and the update took... so don't be afraid to keep trying, you have nothing to lose from where you are now.
jpregione is offline  

Thread Tools
Search this Thread
Quick Reply: Uconnect problem after update


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: