KL Cherokee Tech KL (14+)
2014 Cherokee Forum for all new KL and Cherokee Trailhawk discussion and tech information.
Sponsored by:
Sponsored by:

Stop/start issues

Old 10-28-2017, 10:26 AM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Sacramento, CA
Posts: 6
Year: 2015
Model: Cherokee(SJ)
Engine: 3.2L V6
Default Stop/start issues

2015 Cherokee Limited, V6, Active Drive II. I keep having issues with the stop/start function. The first 2 times when I took it to the dealer they said it was a software issue (the first time was a software update for that feature, the second time it was multiple unrelated software updates that affected that feature). Both times they said it would take about 24 hours for all the updates to process at which time the feature would work again. It did. The last time it stopped working I had them check the battery and the charging system (the message stated function could not work as the battery was charging - even after driving for several hours). This happed this past April. They said both were fine. They decided it was an issue with the battery sensor and replaced it. It has worked fine until about 2 weeks ago (coincidentally - or not - about 2 weeks ago was when the weather began to cool down). I love this feature because it really helps the fuel mileage (about 90% of my driving is city type). Any thoughts are welcome. Thanks in advance.
Beeper51` is offline  
Old 10-31-2017, 04:45 PM
  #2  
Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 135
Model: Cherokee
Default

Originally Posted by Beeper51` View Post
2015 Cherokee Limited, V6, Active Drive II. I keep having issues with the stop/start function. The first 2 times when I took it to the dealer they said it was a software issue (the first time was a software update for that feature, the second time it was multiple unrelated software updates that affected that feature). Both times they said it would take about 24 hours for all the updates to process at which time the feature would work again. It did. The last time it stopped working I had them check the battery and the charging system (the message stated function could not work as the battery was charging - even after driving for several hours). This happed this past April. They said both were fine. They decided it was an issue with the battery sensor and replaced it. It has worked fine until about 2 weeks ago (coincidentally - or not - about 2 weeks ago was when the weather began to cool down). I love this feature because it really helps the fuel mileage (about 90% of my driving is city type). Any thoughts are welcome. Thanks in advance.
Beeper51`,

If you return to your Jeep dealership for any further diagnostic work, please feel free to reach out if you need additional assistance.

Kori
Jeep Social Care Specialist
JeepCares is offline  
Old 11-06-2017, 05:01 PM
  #3  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Sacramento, CA
Posts: 6
Year: 2015
Model: Cherokee(SJ)
Engine: 3.2L V6
Default

Kori,

I have an appointment for Friday, November 10, at 8:00 AM at Hanlee's CDJR in Davis, CA. to have this issue revisited. Is there anything I should be aware of beforehand?
Beeper51` is offline  
Old 11-07-2017, 11:39 AM
  #4  
Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 135
Model: Cherokee
Default

Originally Posted by Beeper51` View Post
Kori,

I have an appointment for Friday, November 10, at 8:00 AM at Hanlee's CDJR in Davis, CA. to have this issue revisited. Is there anything I should be aware of beforehand?
If you'd like to send me a private message with your VIN and contact info, I would be happy to get a case opened up for you and escalated to our handling team. They can assist you while the Jeep is in service.

Kori
Jeep Social Care Specialist
JeepCares is offline  
Old 11-07-2017, 05:27 PM
  #5  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Sacramento, CA
Posts: 6
Year: 2015
Model: Cherokee(SJ)
Engine: 3.2L V6
Default

Thanks, Kori. Only problem is, I can't figure out how to PM on this site.
Beeper51` is offline  
Old 11-08-2017, 06:40 AM
  #6  
Newbie
 
Join Date: Sep 2017
Posts: 4
Model: Cherokee
Default

Originally Posted by Beeper51` View Post
Thanks, Kori. Only problem is, I can't figure out how to PM on this site.
click on JeepCares and PM messages will appear
2017jeep is offline  
Old 11-08-2017, 09:39 AM
  #7  
Newbie
Thread Starter
 
Join Date: Oct 2017
Location: Sacramento, CA
Posts: 6
Year: 2015
Model: Cherokee(SJ)
Engine: 3.2L V6
Default Thank you

Thank you, 2017Jeep. Got it.
Beeper51` is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: