Bad luck with new Trailhawk - Jeep Cherokee Forum
Jeep Cherokee Forum


KL Cherokee Tech KL (14+)
2014 Cherokee Forum for all new KL and Cherokee Trailhawk discussion and tech information.

Bad luck with new Trailhawk

Reply
 
 
 
Thread Tools Search this Thread
Old 10-22-2016, 04:03 PM   #1
Newbie
Thread Starter
 
Join Date: Oct 2016
Posts: 4

View DeltHawk28's Photo Album My Photos
Default Bad luck with new Trailhawk

Bought a new 2016 Cherokee Trailhawk V6 on Tuesday and new the Jeep community. Absolutely loved everything about it until I suddenly started having issues …
Loss of power steering
Service shifter warning
Auto stop/start unavailable-Service auto stop/start warning
Battery Light
Traction control light on/off and beeping
Strange plastic or rubber burning smell
Display and ambient lighting flashing on and off/ headlights and cabin lights dimming/pulsing
All of this happened randomly over the past couple days. I brought into the dealership this morning and as I was literally down the street from the dealership the TH made a loud wirring noise and gave me a Trans error message shut down the vehicle and said to reset system with the car off. Very nervous and upset with what this could mean.
Any insights/comments/suggestions are welcome. Thank you
DeltHawk28 is offline   Reply With Quote
Old 10-22-2016, 05:13 PM   #2
Member
 
metaldemon7's Avatar
 
Join Date: Jul 2010
Location: Easton, PA
Posts: 209

View metaldemon7's Photo Album My Photos
Default

I don't own a Cherokia, but my 2012 Wrangler isn't very reliable. I will never buy anything new again. I bought a real 1994 Cherokee to replace the 2012. My other Cherokee that my son drives now is 18 years old, and has had less issues than my 2012 Wrangler.
metaldemon7 is offline   Reply With Quote
Old 10-22-2016, 06:11 PM   #3
Senior Member
 
abodyjoe's Avatar
 
Join Date: Mar 2012
Location: s.jersey
Posts: 629

View abodyjoe's Photo Album My Photos
Default

its a fiat, i'd expect nothing less.
abodyjoe is offline   Reply With Quote
Old 10-22-2016, 06:31 PM   #4
CF Veteran
 
Big David's Avatar
 
Join Date: Jun 2011
Location: Murrayville,Ga.
Posts: 2,471

View Big David's Photo Album My Photos
Default

Why all the hate? LOL

Seriously, since it's only 4 freaking days old I'd take it back to the dealer, throw the keys on the desk & tell them that they can have their junk back.
That is insane.

Last edited by Big David; 10-22-2016 at 06:34 PM.
Big David is offline   Reply With Quote
Old 10-22-2016, 07:19 PM   #5
Junior Member
 
Join Date: Jan 2012
Posts: 42

View emx72's Photo Album My Photos
Default

Start researching for a Lemon Law lawyer!!
emx72 is offline   Reply With Quote
Old 10-22-2016, 07:58 PM   #6
CF Veteran
 
Join Date: May 2012
Location: Lost in the wilds of Virginia
Posts: 3,116

View BlueRidgeMark's Photo Album My Photos
Default

Wrong section of the forum.

Last edited by Outlaw Star; 10-22-2016 at 09:26 PM.
BlueRidgeMark is offline   Reply With Quote
Old 10-22-2016, 09:27 PM   #7
CF Admin
 
Outlaw Star's Avatar
 
Join Date: Sep 2010
Location: Lantana, Fl
Posts: 31,308

View Outlaw Star's Photo Album My Photos
Default

Quote:
Originally Posted by BlueRidgeMark View Post
Wrong section of the forum.
Moving to KL Tech now. Hope you can find the root of the problem and get this issue resolved OP.
Outlaw Star is offline   Reply With Quote
Old 10-22-2016, 11:56 PM   #8
Senior Member
 
Join Date: Nov 2012
Location: Harrisburg, Pennsylvania
Posts: 872

View dmill89's Photo Album My Photos
Default

Definitely sounds like an electrical issue, possibly the TIPM (totally-integrated power module), one of the electronic control modules, a bad wiring harness, or a combination of the above. Regardless 4 days old and still under warranty take it to the dealer and let them fix it (and look into your options for return/lemon-law/lawyers if the don't or don't fix it properly).

Last edited by dmill89; 10-23-2016 at 06:42 PM.
dmill89 is offline   Reply With Quote
Old 10-23-2016, 07:50 AM   #9
CF Veteran
 
peep's Avatar
 
Join Date: Oct 2010
Location: Ontario, Canada
Posts: 2,054

View peep's Photo Album My Photos
Default

Straight to the Dealership!
peep is offline   Reply With Quote
Old 10-23-2016, 08:03 AM   #10
CF Veteran
 
caged's Avatar
 
Join Date: Nov 2008
Location: Northern Ontario, Canada
Posts: 7,223

View caged's Photo Album My Photos
Default

i would bring it back to the dealership in true fashion... on the back of a flatbed tow truck, just to make a statement.
caged is offline   Reply With Quote
Old 10-23-2016, 11:02 AM   #11
Newbie
Thread Starter
 
Join Date: Oct 2016
Posts: 4

View DeltHawk28's Photo Album My Photos
Default

BlueRidgeMark Outlaw Star - Sorry about that
dmill89 - thanks for the info gives me some hope it's not something much worse
caged - Wish I had done that didn't think about it til the TH shut down in front of the dealership
Everyone else thanks for comments and advice. Started looking up some info on Illinois Lemon Laws but hopefully it won't come to that; as I said it's been in the dealership since yesterday morning so hopefully I'll get some good news tomorrow or Tuesday.
Please pardon my forum ignorance I don't really go on them much.
DeltHawk28 is offline   Reply With Quote
Old 10-24-2016, 12:27 PM   #12
Junior Member
 
JeepCares's Avatar
 
Join Date: Apr 2016
Posts: 64

View JeepCares's Photo Album My Photos
Default

Quote:
Originally Posted by DeltHawk28 View Post
Bought a new 2016 Cherokee Trailhawk V6 on Tuesday and new the Jeep community. Absolutely loved everything about it until I suddenly started having issues
Loss of power steering
Service shifter warning
Auto stop/start unavailable-Service auto stop/start warning
Battery Light
Traction control light on/off and beeping
Strange plastic or rubber burning smell
Display and ambient lighting flashing on and off/ headlights and cabin lights dimming/pulsing
All of this happened randomly over the past couple days. I brought into the dealership this morning and as I was literally down the street from the dealership the TH made a loud wirring noise and gave me a Trans error message shut down the vehicle and said to reset system with the car off. Very nervous and upset with what this could mean.
Any insights/comments/suggestions are welcome. Thank you
Hi DeltHawk28,

I'm sorry to hear about this! I would recommend visiting your local dealership for further diagnosis. I'd be happy to follow up with them for you after your appointment, just let me know!

Andrea
Jeep Social Care Specialist
JeepCares is offline   Reply With Quote
Old 10-25-2016, 08:18 PM   #13
Member
 
MoToad's Avatar
 
Join Date: Sep 2015
Location: Nelson BC
Posts: 124

View MoToad's Photo Album My Photos
Default

Sounds like it's haunted. It is Halloween almost, after all. I'd call the auto stop/start not working a blessing.
MoToad is offline   Reply With Quote
Old 03-01-2017, 08:28 PM   #14
Newbie
 
Join Date: Mar 2017
Posts: 1

View rs-mn's Photo Album My Photos
Default

Bad battery or battery connection?
rs-mn is offline   Reply With Quote
Old 03-16-2017, 08:07 AM   #15
Newbie
 
Join Date: Mar 2017
Posts: 2

View levelhead's Photo Album My Photos
Default 3 Cherokees...no problems

We've bought 3 Cheokees new (2014 Sport, 2016 Trailhawk, 2017 Latitude) and not a single problem. The 2014 and 2016 are up in Canada and the 2017 we just bought is in Florida...which by the way has a "lemon law" (you are given the info by your salesman)
levelhead is offline   Reply With Quote
 
 
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:15 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: