Modified XJ Cherokee Tech XJ (84-01)
All modified tech questions. If it modifies your XJ beyond stock parts ask it here.

TC noise/ HELP

Old 03-22-2017, 08:56 PM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Year: 91 & 98
Model: Cherokee
Engine: 4.0 both
Default TC noise/ HELP

Have had 98xj for 5 yrs, stock and no drivetrain issues ( auto with 242tc)190k. Highway miles. Within last few months have put Zone 3" lift on (coil front, add a leaf rear). Ended up 3-1/4 front, 4 rear. Wasn't driven much immediately (200 miles?) because youngest was taking it over after 16 birthday. Put tc drop on because of slight vibration. After approx 100 miles after that - he just got legal- noticed a pop underneath at highway speed. I then noticed it again, loud this time. First thought was pin in rear was coming out of carrier hitting housing. Then again realized it felt more as if tc was trying to engage. Pulled onto gravel road, engaged 4wh, and a little pop, fine for a few hundred yards, then almost a grinding noise, comparable to a parking pawl trying to engage when vehicle is still moving. Adjusted tc linkage and seemed to solve issue. Almost, but no. Still have a pop-clunk in tc ( seems like source) and the grinding noise. Nothing is consistent. May drive 20 miles and nothing. Maybe 100 yards and grinding.
So, disconnected tc linkage with it in 2wd and drove. Still have grinding noise, seems mostly around 30-40 mph. Reconnected linkage, no change. Tranny shifts smooth. 4wd works. Under acceleration (hard or easy) in or out of 4wd it pulls and shifts smooth. Cruise speed/ light throttle is problem area with the noise/ grinding. Sounds like a standard with synchronizers gone, except it's an auto, and it's not at a shift or downshift point. I'm baffled! Help, he wants his ride back.
Bulldog85 is offline  
Old 03-23-2017, 08:42 AM
  #2  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,876
Year: 1990
Model: Comanche
Engine: 4.0
Default

How are the engine and trans mounts?
cruiser54 is offline  
Old 03-23-2017, 12:01 PM
  #3  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Year: 91 & 98
Model: Cherokee
Engine: 4.0 both
Default

Originally Posted by cruiser54 View Post
How are the engine and trans mounts?
they seem fine. Still factory mounts. No noticable movement when going from park to d or r.
Bulldog85 is offline  
Old 03-23-2017, 03:56 PM
  #4  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,876
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Bulldog85 View Post
they seem fine. Still factory mounts. No noticable movement when going from park to d or r.
Have you visually inspected them?
cruiser54 is offline  
Old 03-23-2017, 04:23 PM
  #5  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 3
Year: 91 & 98
Model: Cherokee
Engine: 4.0 both
Default

Originally Posted by cruiser54 View Post
Have you visually inspected them?
yes, when I put drop kit on. No visual cracks, not collapsed, not oil soaked. Just 20 year old parts.
Bulldog85 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: