P1737 troubleshooting issue 45rfe - Jeep Cherokee Forum

Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

P1737 troubleshooting issue 45rfe

Reply

 
 
 
Old 05-28-2017, 03:16 PM
  #1  
Newbie
Thread Starter
 
Join Date: May 2017
Posts: 2
Model: Cherokee
Default P1737 troubleshooting issue 45rfe

I have a 2000 Grand Cherokee Laredo V8 45RFE transmission. It was throwing codes P1781 & P1732 stuck in limp mode. I replaced the solenoid pack and rear speed sensor. When I replaced the solenoid pack the trans fluid looked great. I replaced the trans filters and ensured the push on filter was seated right by inserting the O ring into the trans first. I pulled the battery cables and clamped them together overnight. I am now throwing code P1737. It is still in limp mode and dies sometimes when I put in drive. Do I need to relearn the TCM after the solenoid pack replacement? Any assistance is greatly appreciated.
dustinfej is offline  
Reply With Quote
Old 05-28-2017, 04:44 PM
  #2  
Seasoned Member
 
Join Date: May 2017
Posts: 338
Model: Cherokee
Default

Was the harness in good shape to the solenoids?
GreaseMonkey17 is offline  
Reply With Quote
Old 05-28-2017, 09:16 PM
  #3  
Newbie
Thread Starter
 
Join Date: May 2017
Posts: 2
Model: Cherokee
Default

Seemed to be. Anything I should be looking for specifically?
dustinfej is offline  
Reply With Quote
 
 
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: