Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

Audio wiring

Old 10-31-2016, 05:56 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2016
Location: Bethel, Ak
Posts: 96
Year: 2001
Model: Cherokee
Engine: 4.7 v8...
Default Audio wiring

Good afternoon,
I have a busy week planned for my WJ. The Led headlights, 2" budget boost lift and my new sony cd player. I have an issue tho, I am not getting any output to the speakers, I show an input from the antenna. My question revolves around the yellow wire and black single wires on the back of the stock player. The black is a ground Im guessing, and yellow Im hoping is power? I bought an Oem-1 for this, but Im not sure i have the wiring quite right, and thus Im confused. I cant find it in my manual, but is the Yellow single wire in the back of the stock radio battery or switched power that I need to splice in? Second, can I use the black pin as the ground for both harness sections? Thanks for any help, this is my first attempt at an aftermarket cd player install.
rivman05 is offline  
Old 10-31-2016, 07:21 PM
  #2  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 11,288
Year: 2000
Model: Grand Cherokee (WJ)
Engine: 4.0L
Default

This belongs in Aftermarket Electrical Systems
dave1123 is offline  
Old 10-31-2016, 08:20 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2016
Location: Bethel, Ak
Posts: 96
Year: 2001
Model: Cherokee
Engine: 4.7 v8...
Default

Can a mod nove it? I cant on my phone.
rivman05 is offline  
Old 10-31-2016, 08:56 PM
  #4  
Senior Member
 
94zj318's Avatar
 
Join Date: Feb 2012
Location: Baltimore
Posts: 539
Year: 2002
Model: Grand Cherokee
Engine: 4.0L (AMC) Straight Six
Default

You shouldn't need to splice anything... you only need the wiring harness adapter... the bare ends connect to the matching color wires on the harness that came with the Sony radio, and the black and gray harnesses plug into their respective factory plugs, so you don't need to cut the factory wiring.... the factory antenna plugs right into the back of the new radio without any adapter.

One note, though... if your Jeep has the Infinity Gold system (if you have the emblem on the front door speaker grilles that says so), you'll need to connect the amplifier turn-on wire (I think it's a blue wire? But it's labeled and it tells you in the install guide) on the aftermarket (NOT factory) black-and-gray harness to the amplifier turn-on wire on the Sony's harness to send a signal to the factory amplifier under the rear right bench seat when you power on your Sony radio... if you don't, you'll get no sound when you turn on your new radio. If you DON'T have the Infinity Gold system, you'll just leave that wire un-stripped and don't strip it.

The WJ's don't support the radio dimmer wire (you'll have to use the Sony radio's dimmer control in the setup menu to dim the radio screen and buttons), and it doesn't have a power antenna, so you WON'T strip OR connect those wires. Just leave them un-stripped and don't strip them.

Most likely if you have the Inifinty system, you haven't connected the amplifier turn-on wires, which is a common mistake to make. Just connect the two wires, and you're good to go.

Hope this helps!

-Vince
94zj318 is offline  
Old 10-31-2016, 11:12 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Apr 2016
Location: Bethel, Ak
Posts: 96
Year: 2001
Model: Cherokee
Engine: 4.7 v8...
Default

I did that. the blue/white to the blue/ white. all colors matched but no sound. Is the yellow/green wire the dimmer wire? the deck powers but fails to put out sound, yes its the infinity premium factory sound. And yes it was just wiring in the sony plug to the a plug of the oem-1.

rivman05 is offline  
Old 11-01-2016, 12:13 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Apr 2016
Location: Bethel, Ak
Posts: 96
Year: 2001
Model: Cherokee
Engine: 4.7 v8...
Default

got it. thanks to 94zj, yes in my diagram solid blue is power antenna, and blue/white is amp trigger. once i swung it the other way blue/white to blue it wirks flawlessly.
rivman05 is offline  
Old 11-01-2016, 03:59 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Apr 2016
Location: Bethel, Ak
Posts: 96
Year: 2001
Model: Cherokee
Engine: 4.7 v8...
Default

This thread can be closed/deleted as its resolved. Thanks.
rivman05 is offline  
Old 11-02-2016, 09:51 PM
  #8  
Senior Member
 
94zj318's Avatar
 
Join Date: Feb 2012
Location: Baltimore
Posts: 539
Year: 2002
Model: Grand Cherokee
Engine: 4.0L (AMC) Straight Six
Default

Glad I was able to help!
94zj318 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: