1995 Grand Cherokee Engine Problem - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!
Presented by the all-new Yokohama
Presented by the all-new Yokohama

1995 Grand Cherokee Engine Problem

Reply
 
 
 
Thread Tools Search this Thread
Old 02-12-2010, 04:40 PM   #1
Newbie
Thread Starter
 
Join Date: Feb 2010
Location: Brandon, SD
Posts: 4

View emrys_hawke's Photo Album My Photos
Default 1995 Grand Cherokee Engine Problem

Got a 95 grand cherokee. engine runs great if i got the gas down but wont idle at all. check engine light is on. took it to a shop and they said after scanning that the only problem was the batter wasn't holding a good enough charge. so bought a battery. problem didn't go away. alternator is good, plugs and wires are good. where should i look next? other symptoms are horrible fuel economy, soot coming out the exhaust, wont downshift correctly and sometimes will stumble when getting up to speed. all the electronics checked out....
emrys_hawke is offline   Reply With Quote
Old 02-12-2010, 06:33 PM   #2
Newbie
 
Join Date: Feb 2010
Location: NoVa
Posts: 13

View DemonGrinder's Photo Album My Photos
Default

soot coming out of the exhaust is usually a sign of too rich condition and you are dumping too much fuel which points to an air/fuel mixture problem or a sensor that adjusts these values. I would start with checking cooling temp sensor, there is usually a separate one for the engine computer which adjusts fuel mixture in conjunction with the oxygen sensors.

by the way, what engine do you have, and did they tell you any codes for the CEL ?
DemonGrinder is offline   Reply With Quote
Old 02-12-2010, 08:53 PM   #3
Newbie
Thread Starter
 
Join Date: Feb 2010
Location: Brandon, SD
Posts: 4

View emrys_hawke's Photo Album My Photos
Default

It has the 5.2. The shop guy told me the code was 41. dont know what that codes for tho and cant seem to find a jeep code guide that i don't have to pay for
emrys_hawke is offline   Reply With Quote
Old 02-12-2010, 08:59 PM   #4
Caracticus Potts The Mod
 
Willys55's Avatar
 
Join Date: Jul 2009
Location: Hainsville, NJ
Posts: 5,015

View Willys55's Photo Album My Photos
Default

code 41 is for when the alternator is not charging, and if the battery is run down the alternator is not ramping up the voltage. This can cause rough idle, stalling and internitting surge. Check that the coolant temp sensor is not shorted or open.
Willys55 is offline   Reply With Quote
Old 02-13-2010, 05:07 PM   #5
Newbie
Thread Starter
 
Join Date: Feb 2010
Location: Brandon, SD
Posts: 4

View emrys_hawke's Photo Album My Photos
Default

the coolant temp sensor inside the overflow? And out of curiosity how does the coolant sensor effect the fuel? One more question... went to go check that sensor and the overflow is full of ice... Could that be causing the problem?
emrys_hawke is offline   Reply With Quote
Old 02-13-2010, 05:29 PM   #6
Member
 
zedpapa's Avatar
 
Join Date: Dec 2009
Location: san diego
Posts: 205

View zedpapa's Photo Album My Photos
Default

when the engine is cold, the computer injects extra fuel much like a choke. when the engine warms up the computer can then run at the correct fuel mixture. if your coolant overflow bottle is full of ice, it could be that your ANTIFREEZE mixture is incorrect. i would suggest draining and filling with the correct mixture. < one thing i would check is the TPS(throttle position sensor). if that is incorrect or missing, it will cause the problems you are describing.

zedpapa
zedpapa is offline   Reply With Quote
Old 02-22-2010, 12:18 PM   #7
Newbie
Thread Starter
 
Join Date: Feb 2010
Location: Brandon, SD
Posts: 4

View emrys_hawke's Photo Album My Photos
Default

k went through and changed the tps. put it on wrong the first time... adjusted it into the right position. Still has many of the same problems. Just for kicks i even replaced the ect (coolant temp sensor), but nothing changed. the only solution at all is i turned the idle screw up to prevent stalling... where should i look next? ive been told that mopar 318s are notorious for having vacuum leaks under the intake manifold... do i need to pull that all apart or is there an easier fix i should start with?
emrys_hawke is offline   Reply With Quote
Old 02-22-2010, 01:35 PM   #8
CF Veteran
 
ol"blue's Avatar
 
Join Date: Mar 2009
Location: Tenn. and Mich.
Posts: 28,069

View ol"blue's Photo Album My Photos
Default

You can check the codes yourself. Here's how. >-> http://jeephorizons.com/phpbb/viewtopic.php?t=2719
ol"blue is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LiamLikeNeeson's '89 Jeep XJ Limited 4.0L LiamLikeNeeson Jeep Builds 12 12-26-2016 06:48 AM
1995 Grand Cherokee Orvis Edition anti theft issues Katt Dogg OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 1 08-25-2015 08:03 PM
97 Laredo Neutral Starter Switch 14lgreer OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 3 08-21-2015 01:46 AM
ABS??????? Buddylove1991 OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 2 08-20-2015 08:28 PM
please helppp! dgkallday3291 OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 1 08-20-2015 09:43 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:53 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: