Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

Weird overheating/oil pressure problem?...

Old 06-04-2010, 10:40 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Yorktown, VA
Posts: 39
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0L 6 Cylinder
Default Weird overheating/oil pressure problem?...

So my manual 98 cherokee runs at about 210 during normal operation, just replaced everything in the cooling system but the heater core and radiator about 2 months ago, so the water pump all the hosing and thermostat, even the fan clutch. When in stop and go traffic my temp goes up to 220 and the oil pressure drops to 5 psi... no idea why. Getting into first gear even seems to put strain on the engine like it has lost power or something. Right now i'm thinking it's time to get the thing exorcised because i have no idea how to solve this, any help would be greatly appreciated!
ytownxj is offline  
Old 07-26-2010, 09:30 PM
  #2  
Junior Member
 
OcalaXJ's Avatar
 
Join Date: Jul 2010
Posts: 88
Likes: 0
Received 0 Likes on 0 Posts
Model: Cherokee
Default

I have the same problem. Except my oil pressure drops down to zero at stop lights. Looking for a answer myself.
OcalaXJ is offline  
Old 08-13-2010, 12:55 PM
  #3  
Member
 
Free Jeep's Avatar
 
Join Date: Feb 2010
Location: Harford County, MD
Posts: 213
Likes: 0
Received 0 Likes on 0 Posts
Year: 1995
Model: Cherokee
Engine: 4.0L
Default

I am having a similar problem. Anybody have any ideas?
Free Jeep is offline  
Old 08-13-2010, 01:59 PM
  #4  
Member
 
jth877's Avatar
 
Join Date: Sep 2009
Location: Albany/Saratoga, NY
Posts: 150
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999 Stone White
Model: Cherokee
Engine: 4.0
Default

What oil filter are you using? I've noticed that different brands result in different oil pressures- Fram being the worst.
jth877 is offline  
Old 08-14-2010, 09:36 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Yorktown, VA
Posts: 39
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0L 6 Cylinder
Default

I'm running a stp oil filter and just yesterday cranked up my remaned engine i dropped in. Oil pressure still gets to 5 when it's hot. Thinking this may just be normal for 10w30 in the xj
ytownxj is offline  
Old 08-14-2010, 10:49 AM
  #6  
Senior Member
 
Throttle Jockey's Avatar
 
Join Date: Feb 2009
Posts: 811
Likes: 0
Received 0 Likes on 0 Posts
Model: Cherokee
Default

the hotter it gets the lower the oil pressure will be. i think if we can get the coolant temp under control then the oil pressure problem will be resolved as well. you replaced all the normal things. was it running hot before all this?
Throttle Jockey is offline  
Old 08-14-2010, 11:05 AM
  #7  
CF Veteran
 
djb383's Avatar
 
Join Date: Nov 2009
Location: The Republic of TEXAS
Posts: 8,172
Likes: 0
Received 2 Likes on 2 Posts
Year: 1998
Model: Cherokee
Engine: 4.0L HO
Default

Think u could have a oil pressure gauge problem (false reading)? Take it to a reliable shop, have the oil pressure tested. Usually, if oil pressure is too low not at all, really bad noises can be heard. We've momentarily seen 230F coolant temp displayed on the ScanGauge with a/c on stopped in traffic triple digit ambient and the dash idiot light never flickered.
djb383 is offline  
Old 08-15-2010, 07:41 AM
  #8  
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Yorktown, VA
Posts: 39
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0L 6 Cylinder
Default

It is possible it's giving a false reading, i've figured a manual oil pressure gauge wouldn't hurt just haven't gotten around to checking it yet
ytownxj is offline  
Old 08-16-2010, 01:05 AM
  #9  
Newbie
 
Join Date: Aug 2010
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Model: Cherokee
Default

Mine just started overheating, flushed it ,new fluid, cap,thermostat.New fan clutch. ? Still runs 210 - 230 .As far as oil pressure ,went thru 3 of them .No warranty on electrical parts that don't even work. they either weren't reading right or leaked oil. the 1 in it now reads 80 psi when it's running.
kautman1 is offline  
Old 08-16-2010, 02:11 AM
  #10  
Registered Users
 
Join Date: Sep 2009
Location: morrisonville ny
Posts: 1,371
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000 @ 1994 givin away
Model: Cherokee
Engine: 4.0
Default

I think your fine mine runs at less than 210 normally, but idle it in traffic with the a/c on and it goes up to about 218 ,and the electric fan kicks on,and when hot I ilde at 15 psi for oil pressure, I think your gauge is just off a bit too.I also run 10w30 castrol synthtic, I used to run 10w30 castrol high mileage and it is all the same.Filter either a mopar or napa.

Last edited by rich; 08-16-2010 at 02:13 AM.
rich is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nildnas
Off-Topic Discussion
89
12-16-2015 11:43 AM
Ye Ol' Cherokee
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
8
10-09-2015 10:29 PM
Dannymac1216
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
13
09-08-2015 06:28 AM
Ricardo Siqueiros
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
09-03-2015 09:17 PM
Jeepy11
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
2
09-03-2015 09:32 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Weird overheating/oil pressure problem?...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: