Notices
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Rough idle / bucking on acceleration at start

Old 09-20-2015, 06:32 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 1
Model: Cherokee
Default Rough idle / bucking on acceleration at start

Hey, I've been reading a bit and can't quite find the exact problem I'm having on here. So I figured I would make a post and hopefully someone here can help me out as there seems to be quite a few knowledgeable people here!

For quite some time now my 99 Jeep Cherokee 4x4 has started every time without fail but upon starting it starts normal and then after a few seconds will start putting loudly (almost like its backfiring but not that loud)....When I start my jeep and drive within the first few minutes of it being started the gas will not accept full acceleration...it will start to accelerate then put put put put rejecting fuel almost it seems (i can feel some sort of backfire or something happening it seems)....so then I must let off the gas and press it down again...acceleration...put put put shortly into the acceleration once again.....nothing, have to let off the gas and press back down repeatedly. This has been this way for some time and is gradually getting worse. I don't have a lot of money so I haven't even been able to get it looked at. I have saved now though and would like to see if I can get any ideas here first of what it could be.


Sorry if this is a bit of a ramble....

Cliffs:
Jeep starts fine but will put put / not accelerate continually until warmed up for a few minutes, after warming up it drives fine but is loud.
justown is offline  
Old 09-20-2015, 06:54 AM
  #2  
CF Veteran
 
CCKen's Avatar
 
Join Date: Aug 2010
Location: Canton, MI
Posts: 8,357
Year: 1999
Model: Cherokee
Engine: 4.0
Default

You may want to inspect your ignition coil for cracks. If okay, test it.


Requires a digital multimeter and removal of the coil. See procedure below.


Name:  testingcoil.jpg
Views: 335
Size:  550.2 KB


Also, check the Oxygen Sensors heaters fuse in the PDC,


Name:  99PDCREV3_26_14.jpg
Views: 296
Size:  446.9 KB

Cracked coil:


Name:  cracked%20coil_hesitation_backfire_chugging.jpg
Views: 345
Size:  123.0 KB
.

Last edited by CCKen; 09-20-2015 at 06:57 AM.
CCKen is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Blackcherokee290
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
24
04-16-2019 06:04 PM
rdr8887
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
7
08-25-2015 11:12 PM
Gtrsrlly
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
08-25-2015 11:50 AM
rdr8887
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
7
08-24-2015 07:48 AM
cbowl
Cherokee Chat
2
08-19-2015 09:14 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Rough idle / bucking on acceleration at start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: