Radiator Fan Not Working - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Radiator Fan Not Working

Reply
 
 
 
Thread Tools Search this Thread
Old 04-15-2011, 09:40 PM   #1
Newbie
Thread Starter
 
Tatokee's Avatar
 
Join Date: Sep 2010
Location: Southbridge,Ma
Posts: 19

View Tatokee's Photo Album My Photos
Default Radiator Fan Not Working

My radiator fan isent working. Any ideas, I don't think the motor is bad. Any ideas? I don't wanna spend too much money either. Thanks!!!
Tatokee is offline   Reply With Quote
Old 04-15-2011, 09:53 PM   #2
CF Veteran
 
sthon's Avatar
 
Join Date: Mar 2011
Location: California
Posts: 2,570

View sthon's Photo Album My Photos
Default

What fan are you talking about? Mech or electric? Electric should only come on with a/c or when the temp reaches 210 (I think 210, someone correct me if I'm wrong)
sthon is offline   Reply With Quote
Old 04-15-2011, 10:29 PM   #3
CF Veteran
 
peep's Avatar
 
Join Date: Oct 2010
Location: Ontario, Canada
Posts: 2,053

View peep's Photo Album My Photos
Default

Jump power with wires direct to the fan motor plug from battery, this will prove if the fan motor is good or not. Next could be the relay, trace the stock wires back, next could be the temp sensor. As Sthon advises, the elec fan is an auxilliary and only comes on in a high temp condition.
peep is offline   Reply With Quote
Old 04-16-2011, 08:28 AM   #4
CF Veteran
 
djb383's Avatar
 
Join Date: Nov 2009
Location: The Republic of TEXAS
Posts: 8,155

View djb383's Photo Album My Photos
Default

On at 218F, according to the FSM.
djb383 is offline   Reply With Quote
Old 04-16-2011, 10:31 AM   #5
Senior Member
 
john deer green's Avatar
 
Join Date: Apr 2011
Location: west virginia
Posts: 582

View john deer green's Photo Album My Photos
Default

i have a 1989 and my electric fan stoped working it was th temperature sensoe in the radiator on the driver side at the bottom u can unplug the conector and jump the connector over on the wiring harnes side and the fan should come on and stay on if the sensor is bad
john deer green is offline   Reply With Quote
Old 04-16-2011, 10:41 AM   #6
CF Veteran
 
sthon's Avatar
 
Join Date: Mar 2011
Location: California
Posts: 2,570

View sthon's Photo Album My Photos
Default

Quote:
Originally Posted by djb383
On at 218F, according to the FSM.
Thanks
sthon is offline   Reply With Quote
Old 04-16-2011, 10:52 AM   #7
Newbie
Thread Starter
 
Tatokee's Avatar
 
Join Date: Sep 2010
Location: Southbridge,Ma
Posts: 19

View Tatokee's Photo Album My Photos
Default

Oh alright, I thought it had tobe on! Phew lol If you stood infront of your jeep looking at the motor,im talking about the fan on the right. So it only kicks on when its wicked hot? Also my ac don't work so does affect anything? lol
Tatokee is offline   Reply With Quote
Old 04-16-2011, 11:19 AM   #8
CF Veteran
 
sthon's Avatar
 
Join Date: Mar 2011
Location: California
Posts: 2,570

View sthon's Photo Album My Photos
Default

Quote:
Originally Posted by Tatokee
Oh alright, I thought it had tobe on! Phew lol If you stood infront of your jeep looking at the motor,im talking about the fan on the right. So it only kicks on when its wicked hot? Also my ac don't work so does affect anything? lol
Sounds like you're fine then.
sthon is offline   Reply With Quote
Old 04-16-2011, 06:27 PM   #9
CF Veteran
 
Disoriented Hillbilly's Avatar
 
Join Date: Nov 2010
Location: chillicothe, OH
Posts: 2,136

View Disoriented Hillbilly's Photo Album My Photos
Default

Turn your heat on to defrost. Think fan should kick on then too. Mine does.

Sent from my iPhone using CherokeeFM
Disoriented Hillbilly is offline   Reply With Quote
Old 04-16-2011, 08:04 PM   #10
Senior Member
 
john deer green's Avatar
 
Join Date: Apr 2011
Location: west virginia
Posts: 582

View john deer green's Photo Album My Photos
Default

i know on newer jeeps that if the electric fan dont kick on the ac pump wont engage but not sure about the older ones
john deer green is offline   Reply With Quote
Old 04-16-2011, 09:10 PM   #11
CF Veteran
 
djb383's Avatar
 
Join Date: Nov 2009
Location: The Republic of TEXAS
Posts: 8,155

View djb383's Photo Album My Photos
Default

Other way around....on '00/'01s the efan doesn't turn on when the a/c is engaged.
djb383 is offline   Reply With Quote
Old 04-16-2011, 09:16 PM   #12
CF Veteran
 
peep's Avatar
 
Join Date: Oct 2010
Location: Ontario, Canada
Posts: 2,053

View peep's Photo Album My Photos
Default

On my 89 the AC is pooched, (future on board air compressor project) and has nothing to do with the electric fan. the elec fan used to come on in summer on really hot days when the temp would rise, ok 218 seems about right according to gauge, since new rad/pump went in the heat doesn't rise and fan doesn't come on. Jumper tested and the fan and relay work fine, assume the heat sensor still works, just the new parts don't get hot. Base line hear is on the 89 the elec fan has nothin to do with my AC.
peep is offline   Reply With Quote
Old 04-16-2011, 09:43 PM   #13
Senior Member
 
john deer green's Avatar
 
Join Date: Apr 2011
Location: west virginia
Posts: 582

View john deer green's Photo Album My Photos
Default

i did work at a jeep dealer ship and on the 2008 wranglers the ac dont engage when the fans not runnin cus i remeber a woman comin in and said her ac didnt work she had a pichure infront of her temp gauge so she didnt relize her jeep was over heatin also all she was worried about was the ac lol
john deer green is offline   Reply With Quote
Old 04-17-2011, 11:29 AM   #14
CF Veteran
 
djb383's Avatar
 
Join Date: Nov 2009
Location: The Republic of TEXAS
Posts: 8,155

View djb383's Photo Album My Photos
Default

What you're describing is a malfunction condition/situation. Normally, on '99 down XJs, switching on the a/c compressor or 218F coolant temp turns the efan on.....'00 up, efan turns on at 218F coolant temp only.

Last edited by djb383; 04-17-2011 at 11:35 AM.
djb383 is offline   Reply With Quote
Old 08-10-2011, 10:06 AM   #15
Member
 
Join Date: Aug 2011
Posts: 169

View jretzky's Photo Album My Photos
Default electric fan not working

Where is the electric fan relay and the electric fan sensor located?
jretzky is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Harmonic balancer and overheating Aryl OEM Cherokee Technical. All factory issues and info go here! 8 11-20-2016 09:17 AM
Roaring from the....diff? RunnerInPink OEM Cherokee Technical. All factory issues and info go here! 22 09-15-2015 07:54 PM
First Jeep -1999 Cherokee- Front End Collision Remington Introductions 6 09-01-2015 01:23 PM
Weird electric fan problem. Chick-N-Picker OEM Cherokee Technical. All factory issues and info go here! 21 08-27-2015 12:27 PM


Tags
help me, not working, radiator fan, relay


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:53 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send