Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

mysterious broken plug in engine bay

Old 05-02-2016, 04:49 PM
  #1  
Senior Member
Thread Starter
 
kyle96xj's Avatar
 
Join Date: Jul 2015
Location: Southern Maryland
Posts: 550
Likes: 0
Received 0 Likes on 0 Posts
Year: 1993
Engine: 4.0
Default mysterious broken plug in engine bay

So I was looking around under my hood today and I discovered this plug with what appears to be a broken off part of an electrical connector thing it it? It's a 1996 4.0 aw4 which supposedly had an engine from a 95 swapped in it before I bought it about 9 months ago. Nothing appears to be functioning improperly any ideas?
Attached Images   
kyle96xj is offline  
Old 05-02-2016, 04:50 PM
  #2  
Senior Member
Thread Starter
 
kyle96xj's Avatar
 
Join Date: Jul 2015
Location: Southern Maryland
Posts: 550
Likes: 0
Received 0 Likes on 0 Posts
Year: 1993
Engine: 4.0
Default

Also any idea why my pictures uploaded sideways?
kyle96xj is offline  
Old 05-02-2016, 05:19 PM
  #3  
CF Veteran
 
madmanmarty's Avatar
 
Join Date: Jun 2014
Location: PA
Posts: 1,052
Likes: 0
Received 0 Likes on 0 Posts
Year: 1994
Model: Cherokee
Engine: 4.0 HO
Default

If it's back at your firewall it could be to a hood light.
A pic father away would help.
madmanmarty is offline  
Old 05-02-2016, 05:39 PM
  #4  
Senior Member
Thread Starter
 
kyle96xj's Avatar
 
Join Date: Jul 2015
Location: Southern Maryland
Posts: 550
Likes: 0
Received 0 Likes on 0 Posts
Year: 1993
Engine: 4.0
Default

Originally Posted by madmanmarty View Post
If it's back at your firewall it could be to a hood light.
A pic father away would help.
Yeah it's at the back left of the engine bay at the firewall, I don't have a underhood light or anything that looks like one was there, I kinda thought that was what I could have been but idk
kyle96xj is offline  
Old 05-02-2016, 10:47 PM
  #5  
CF Veteran
 
Join Date: Dec 2015
Location: PA
Posts: 1,962
Likes: 0
Received 1 Like on 1 Post
Year: 1997
Model: Cherokee
Engine: 4.0L
Default

The under hood lamp mounts to the hood just above the heater hoses. Look for two holes right next to or above each other. I just replaced my lamp a couple weeks ago and your plug looks identical.
fb97xj1 is offline  
Old 05-03-2016, 05:21 AM
  #6  
Senior Member
Thread Starter
 
kyle96xj's Avatar
 
Join Date: Jul 2015
Location: Southern Maryland
Posts: 550
Likes: 0
Received 0 Likes on 0 Posts
Year: 1993
Engine: 4.0
Default

Originally Posted by fb97xj1 View Post
The under hood lamp mounts to the hood just above the heater hoses. Look for two holes right next to or above each other. I just replaced my lamp a couple weeks ago and your plug looks identical.
Thanks man I'll have to check that out, I figured it couldn't have been that important since my jeeps not broken yet lol
kyle96xj is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Martlor13
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
16
04-16-2016 03:11 PM
Baconhunter
Jeep Builds
0
04-08-2016 11:59 PM
JohnWilkesBootsyCollins
Modified XJ Cherokee Tech
2
04-07-2016 08:19 AM
Zackqb2
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
3
04-04-2016 01:45 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: mysterious broken plug in engine bay


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: