Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

My nobus no gauges saga

Old 09-05-2015, 11:33 PM
  #1  
Junior Member
Thread Starter
 
sikkev's Avatar
 
Join Date: Jun 2011
Location: High Dersert CA
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Year: 2001
Model: Cherokee
Default My nobus no gauges saga

I know there are many threads on this issue on many forums, but I wanted to post my experience in hopes that someone else might benefit from it.



Like nearly every other late 90's early 00's chrysler I started having the nobus and loss of gauges issue somewhere between 80,000 and 100,000 miles. intermittent at first never for long, then it gradually became more often and for longer periods.
I had done the pull the cluster and clean the connectors fix a couple times, but
it finally got to the point that the gauges almost never worked, and when they did it was only for a short period of time.

For about a year I made do by using an OBDII blue tooth adapter and the Torque app.

Unfortunately Eduardo is do for a smog check this year, and they wont pass your vehicle if the check engine light is on (which it is when the nobus happens) so I decided to try and fix it.

Since he would start and run fine I assumed it was not the CPS.

Having already done some research I went ahead with the Service Bulletin:
NO: 08-15-99, thinking that this was a sure fix.

Thanks to 2001XJWeekender for this write up.
https://www.cherokeeforum.com/f51/fi...gauge-cluster-
88247/

Did the new connectors, and still had the problem.
Ordered another gauge cluster from ebay, and still not fixed.

Let the trouble shooting and head banging begin!

I checked the CPS anyway and it was good.
Checked all the fuses and they all checked out.
Rechecked all the wiring and couldn't find anything.

Finally I tried disconnecting the ECU connectors one at a time, when I disconnected the middle one and turned the key to run the gauges came on!
Reconnected and they would still come on, so I tried to start the Jeep, and nothing. WHAT!!??
Now I was about to come unglued.
Thought maybe the battery had drained during the idle time and troubleshooting, so I tried to jump it, still nothing.
I was about to start checking relays and decided to double-check the fuses.
Yeah I can be pretty dumb. I did not put the Engine Start Motor Relay (no. 19) fuse back in. threw a fuse in there and everything is working fine again.

Hope this helps somebody out there.
sikkev is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sluger17
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
07-16-2018 05:20 PM
scooterc
Accessories
14
12-23-2015 06:50 PM
Jeapers94
Wanted
12
12-03-2015 08:50 AM
LittleRed94
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
10-06-2015 08:09 PM
tleed
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
3
10-04-2015 01:20 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: My nobus no gauges saga


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: