Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

axle problems

Old 04-28-2009, 09:29 PM
  #1  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default axle problems

My axle in my 98xj is just not working for me, when I turn the wheel to the right the tie rod rubs the steering shock, I just put a 4.5 RC kit on it and everything in the front is new what can I do to fix this.
littleleonard0909 is offline  
Old 04-28-2009, 09:32 PM
  #2  
CF Veteran
 
a1racer's Avatar
 
Join Date: Feb 2009
Location: socal
Posts: 7,244
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.0
Default

i never had that issue can you post pics
a1racer is offline  
Old 04-28-2009, 09:41 PM
  #3  
CF Veteran
 
winston427's Avatar
 
Join Date: Feb 2009
Posts: 5,900
Likes: 0
Received 0 Likes on 0 Posts
Model: Cherokee
Default

I'm sitting at 6.5 of lift and my tie rod hits the sway bar link mount. To resolve this issue I will be installing extended link mounts when I transplant the jy D30 I just picked up.
Attached Images  
winston427 is offline  
Old 04-28-2009, 09:42 PM
  #4  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default



littleleonard0909 is offline  
Old 04-28-2009, 10:12 PM
  #5  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default

yours dont look like mine
littleleonard0909 is offline  
Old 04-29-2009, 12:21 AM
  #6  
Senior Member
 
Join Date: Jan 2009
Posts: 545
Likes: 0
Received 0 Likes on 0 Posts
Year: 1994
Model: Cherokee
Engine: 4.0L Air Intake and TB Spacer
Default

Did you listen to what the people said on the other forum that you posted this problem on? What were the results?
94xjstud is offline  
Old 04-29-2009, 09:04 AM
  #7  
CF Veteran
 
BuckB91XJ's Avatar
 
Join Date: Nov 2008
Location: Oak Harbor, WA.
Posts: 6,989
Likes: 0
Received 0 Likes on 0 Posts
Year: 1987
Model: Cherokee
Engine: 4.0 liter RENIX I-6, DIY Cold Air Intake, 2.5 FM Exhaust, 3 Core Radiator
Default

I can't really see from that picture you posted but, I'm betting that your drag link or tierod is bent. I started my lift with a Rusty's 4.5 inch kit and never had your rubbing problem. Give the draglink and tierod a good close inspection.
BuckB91XJ is offline  
Old 04-29-2009, 02:22 PM
  #8  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default

i just up all that on everything in the front is new
littleleonard0909 is offline  
Old 04-29-2009, 03:10 PM
  #9  
CF Veteran
 
mike37's Avatar
 
Join Date: Nov 2008
Location: Paso Robles Ca
Posts: 2,473
Likes: 0
Received 0 Likes on 0 Posts
Year: 1991
Model: Cherokee
Engine: 4.0
Default

Originally Posted by littleleonard0909 View Post
i just up all that on everything in the front is new
did you install a dropped pitman arm
mike37 is offline  
Old 04-29-2009, 03:18 PM
  #10  
Senior Member
 
jd4x426's Avatar
 
Join Date: Jan 2009
Posts: 920
Likes: 0
Received 0 Likes on 0 Posts
Year: 1996
Model: Cherokee
Engine: 4.0
Default

make sure nothing is bent and if nothing is bent you probably didnt put on a dropped pitman arm that would be your problem
jd4x426 is offline  
Old 04-29-2009, 03:31 PM
  #11  
CF Veteran
 
mike37's Avatar
 
Join Date: Nov 2008
Location: Paso Robles Ca
Posts: 2,473
Likes: 0
Received 0 Likes on 0 Posts
Year: 1991
Model: Cherokee
Engine: 4.0
Default

and did you re aligned the front end with a lift you will get toe in and that will make the tie rods to close and bad tire wear
mike37 is offline  
Old 04-30-2009, 03:42 PM
  #12  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default

no i just eye balled it b/c its off road only
littleleonard0909 is offline  
Old 04-30-2009, 03:55 PM
  #13  
Banned
Thread Starter
 
Join Date: Apr 2009
Location: Mt.Airy NC
Posts: 599
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Engine: 4.0
Default

post up some of ya's front end pic maybe I can go by that
littleleonard0909 is offline  
Old 04-30-2009, 05:03 PM
  #14  
CF Veteran
 
4.3L XJ's Avatar
 
Join Date: Aug 2008
Location: Chico, CA
Posts: 4,462
Likes: 0
Received 0 Likes on 0 Posts
Year: 1986
Model: Cherokee
Engine: 4.3L with headers and full 3" exhaust system
Default

Originally Posted by winston427 View Post
I'm sitting at 6.5 of lift and my tie rod hits the sway bar link mount. To resolve this issue I will be installing extended link mounts when I transplant the jy D30 I just picked up.
I am sitting at the same height and had the same problem. I lowered the mount and extended the sway bar link.
4.3L XJ is offline  
Old 04-30-2009, 07:37 PM
  #15  
::CF Moderator::
 
JeepingDan's Avatar
 
Join Date: Apr 2009
Location: CT.
Posts: 18,741
Likes: 0
Received 0 Likes on 0 Posts
Year: 88
Engine: 4.0 HO
Default

Adjust that bolt on the steering knuckel.
JeepingDan is offline  

Thread Tools
Search this Thread
Quick Reply: axle problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: