99 XJ A/C blower intermittently working - Jeep Cherokee Forum

Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

99 XJ A/C blower intermittently working

Reply

 
 
 
Old 09-06-2015, 03:06 PM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2015
Posts: 11
Year: 1999
Model: Cherokee
Default 99 XJ A/C blower intermittently working

Hi y'all! I'm a fairly new member to CherokeeForums (well this is my first thread).

I just got my XJ a year ago and have fixed up A LOT of things after it was passed on to me from my mom by searching through these threads (I also got a hellbox here, great box!)

Context: I got my O2 sensor replaced 1 week ago after a high voltage short circuit, and left my car with my dad who said it was running fine (he uses the AC a lot anyways). I'm guessing I might have some sort of short here as well, then.

Anyways, When I got into my car yesterday, my A/C wouldn't turn on. By not turn on I mean I could hear the switch on the **** try change the setting (like moving water in a cup) but no AIR flow came through, as in no fan, no heating, no defrost.

I popped the hood, looked around, nothing. Five minutes later, I tried my AC again, it worked, as in COLD air. It works on 1,2,3, and 4, easily. (I think this means the blower resistor is OK. The blower works fine when it works, it's just it doesn't always work).

Today, I put my car in the ON position, no air. Started it, got air. Ran into a temporary resolution.

If I left the AC setting on before starting the car, when it turned over it would blow air, but not if ignition was in the ON position. On the other hand, if the AC was left off, and I started my car, no air when I try to switch on my air.

I checked again an hour later, no A/C at all. I popped the hood again, this time learning about the clutch.

The clutch engages fine when the A/C is turned on. The clutch has always turned off after a while though as it did since I got the car, but would restart when it needs to. I'm aware that the belt spin is separate from the clutch. Even if the clutch is spinning, there's no guarantee of air flow.

Half an hour later, I decided to try a few times to turn the A/C on because it wouldn't at this time. On the last try, I turned the ignition over half a second longer than necessary to get the engine to run, and it came on full blast. I took the XJ out for a 30 minute ride. The thing is, if I get the A/C running, so long as I don't turn it off, it runs as long as I keep it on. If I turn it off, wait just a second or so, turn it back on, it generally remains working.

But if I turn it off, wait about 15 seconds, it won't turn back on again. If I restart the car, it sometimes brings it back. It may be important to note when I turn the A/C or car off, I hear a "hiss" for a few seconds that sounds like depressurization, but I believe this has always happened with this Cherokee.

At this point though, I can at least have air flow when ignition is ON not started if it is in working state, as compared to earlier.

Another inspection by yours truly:
I've inspected the visible wires in the hood, and felt the hose going out from what I assume is the canister of r134, it is cold. where it connects to the high pressure valve, the pipe adjacent that is that flows the other way by the clutch/compressor, it is HOT. The canister itself has some condensation around it, and there's some water dripping to the floor underneath the car, but there seems to be no other dripping of any kind.

Fuses look fine.

I'm guessing I have a short of some kind, or a broken switch, but my basic, inexperienced inspection has yielded no results, no corroded or frayed connectors wherever I see the A/C unit.


To summarize:

A/C clutch seems to engage fine, but often times, there's no air flow in my car, so I can't cool, heat, or defrost my car. If the A/C is running, it won't turn off unless I turn it off (as normal), but generally won't turn back on if I wait too long.

I plan on taking it to a mechanic or A/C shop tomorrow to get it checked out, but I'm just stumped as to what the hell is going on.
--------------------------------------------------------------------------------------
UPDATE: I replaced the relay behind the glovebox and it resolved it.

Last edited by shotseven; 08-25-2017 at 11:34 AM.
shotseven is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RonnieD
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
05-09-2014 12:11 PM
pdowty68
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
01-19-2014 04:01 AM
Utahfisher
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
3
06-18-2012 02:32 PM
freakaccident
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
11
11-13-2009 07:01 AM
Laddie
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
10-03-2009 09:00 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 99 XJ A/C blower intermittently working


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: