LED Front Sidemarker Problem - Jeep Cherokee Forum
Jeep Cherokee Forum


Aftermarket electrical systems Aftermarket electronics only! stereo head units, CD players, MP3 players, speaker systems, amplifiers, hardmounted GPS devices, computers, headlight upgrades, fog lights, off-road lights, general wiring and anti-theft devices.

LED Front Sidemarker Problem

Reply
 
 
 
Thread Tools Search this Thread
Old 10-08-2017, 06:07 PM   #1
Newbie
Thread Starter
 
Join Date: Oct 2017
Posts: 3

View xjcoric's Photo Album My Photos
Year: 2000
Model: Cherokee
Engine: 4.0
Default LED Front Sidemarker Problem

I need help figuring out why the front sidemarker lights are not working properly. I changed all my interior and exterior lights to LEDs, except the headlights which I just upgraded to brighter halogen bulbs, and changed the flasher relay to an EP27L. Whenever the parking lights are turned on the front sidemarkers are very dim, so dim that you would have to look close at night to even tell they're on, and both blinker indicators stay lit on the instrument cluster but still blink left or right. All other lights work properly and when the parking lights are off the sidemarkers light up properly with the blinkers. I contacted tech support but they said to install the old flasher relay and install load resisters on all the LEDs, which I don't think is right since I've seen people do this before with just a relay. The picture below shows how the sidemarker looks like it's not on with the headlights on.
xjcoric is offline   Reply With Quote
Old 12-06-2017, 10:33 AM   #2
Member
 
BooGTS's Avatar
 
Join Date: Sep 2009
Location: Rochester, MI
Posts: 128

View BooGTS's Photo Album My Photos
Model: Cherokee
Default

I hate how this is a "catch all" answer but I really think it sounds like a ground issue. Either that, or since it affects both sides, possibly a short in the 4 way e-flasher.

I have LEDs everywhere and don't have load resistors, do have LED flasher, everything works perfectly.
BooGTS is offline   Reply With Quote
Old 12-10-2017, 06:16 PM   #3
Newbie
Thread Starter
 
Join Date: Oct 2017
Posts: 3

View xjcoric's Photo Album My Photos
Year: 2000
Model: Cherokee
Engine: 4.0
Default

I thought maybe it was a problem with the LED flasher since the first one they sent me was bad so I bought the Novita EP27 flasher since I've seen people use it before but my turn signals didn't even work with that one. Everything worked fine before LEDs so I figured it had to be something I replaced. I'm decent with electrical but not that good so I'm not really sure how to go about checking it
xjcoric is offline   Reply With Quote
 
 
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: