KL Cherokee Tech KL (14+)
2014 Cherokee Forum for all new KL and Cherokee Trailhawk discussion and tech information.
Sponsored by:
Sponsored by:

Safety features stopped working

Old 10-03-2017, 11:34 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Model: Cherokee
Default Safety features stopped working

About a week ago, I got a message that my lane departure Warning system was not working and there was an Icon in the lower right section of the speedometer showing a yellow lane departure symbol, also a warning that some features of the Front crass control system were limited.
I brought the car into the dealer and was told that the Adaptive Cruise Control module need to be replaced, Cost for the part $2250!! Plus Plus!!
I have also found that the Auto High Beam Control system is not working.
Interestingly I have full use of the Cruise Control System. Used on a 3,000 trip and it worked fine.
Has anyone also had this problem and was there a better solution?
Does anyone know of an after market part or used part to replace this at a lower cost?

Lane departure works for a short time them the warning appears and it turns off.
lensethb is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: