throttle valve or throttle valve cable? - Jeep Cherokee Forum
Jeep Cherokee Forum


MODIFIED XJ Cherokee Tech XJ (84-01)
All modified tech questions. If it modifies your XJ beyond stock parts ask it here.
Sponsored by:
Sponsored by:

throttle valve or throttle valve cable?

Reply
 
 
 
Thread Tools Search this Thread
Old 09-29-2011, 03:24 PM   #1
Junior Member
Thread Starter
 
shade_tree's Avatar
 
Join Date: Jun 2011
Posts: 44

View shade_tree's Photo Album My Photos
Default throttle valve or throttle valve cable?

Okay Guys bear with me on this cause it confuses me just trying to explain it.
My Jeep has been acting kinda weird as of late. In town she's fine and while accelerating she's fine. BUT when I start cruising anywhere around 60-70 I can cruise for 10-15 sometimes 30 miles and its fine, then all of the sudden it will act as if I'm pressing on the throttle and the rpm's jump up a little(like from 2000 to 2400). i know it doesn't sound like much but when it does this i can feel it shift, kinda like the tranny is coming out of OD.
When these symptoms first started I thought, time to change the fluid and filter. Since it had been about 20k since the last one. Everything still looks brand new under the pan.
When it does this I can play with the t.v. cable and drive it for another 10-30 miles and it's nicest jeep I've ever rode in and then after a few bumps and hills its right back to where it was.
I should also mention throttle position has a little to do with this issue. When the throttle jumps up I'm only pressing on the throttle like an inch and when I press back into the throttle it goes back into OD the rpm's go back down a lil and it starts accelerating.
Sounds weird right? I'm open to any suggestions. I'm lost. i just ordered the TV cable from the dealer at 55 bucks so that's not as bad as i thought it was gonna be.
oh i about forgot specs

1996 Cherokee sport
4.0
Asian Warner trans

and the only code I'm throwing is a coil code but that's because i put a complete msd system on it and the factory stuff is unhooked

thanks in advance everyone
shade_tree is offline   Reply With Quote
Old 09-29-2011, 03:33 PM   #2
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Broward County Fl.
Posts: 47,148

View freegdr's Photo Album My Photos
Default

id try adjusting the cable see if it helps search detent cable adjustment ,its simple to do
freegdr is offline   Reply With Quote
Old 09-29-2011, 03:36 PM   #3
CF Veteran
 
93gc40's Avatar
 
Join Date: Mar 2009
Location: Visalia, Kalifornia, ussa
Posts: 2,750

View 93gc40's Photo Album My Photos
Default

What size tires????
When was trans serviced last?
Quit Playing with th TPS cable setting, adjust it.. Stop stomping on the gas pedal or flooring it, it knocks the TPS out of adjustment.
Could be a solenoid starting to fail.
Could be torque converter kicking out also.
93gc40 is offline   Reply With Quote
Old 09-29-2011, 03:48 PM   #4
Junior Member
Thread Starter
 
shade_tree's Avatar
 
Join Date: Jun 2011
Posts: 44

View shade_tree's Photo Album My Photos
Default

31 10.5 r15 i did a fluid and filter change about 3 weeks ago and i adjusted the TV cable to the Haynes manual specs. At first i adjusted the the cable like it was a Chevy.. i know I'll prolly get flamed on a lil for that. but then i found the right way to adjust it and that's how its been set. if it was the solenoid wouldn't it throw a code?
shade_tree is offline   Reply With Quote
Old 09-29-2011, 03:49 PM   #5
Junior Member
Thread Starter
 
shade_tree's Avatar
 
Join Date: Jun 2011
Posts: 44

View shade_tree's Photo Album My Photos
Default

oh and my tps doesn't have a adjustment it only goes on one way and its new also

Last edited by shade_tree; 09-30-2011 at 12:49 PM.
shade_tree is offline   Reply With Quote
Old 10-10-2011, 02:53 AM   #6
Junior Member
Thread Starter
 
shade_tree's Avatar
 
Join Date: Jun 2011
Posts: 44

View shade_tree's Photo Album My Photos
Default

Ok so it was the tv cable replaced and adjusted it now out runs great. And if I can't ever stomp the has there isn't any since keepin it around.
shade_tree is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Slow hard to start BlvdKreeper OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 2 09-20-2015 01:16 PM
Battery? Alternator? Both? Ye Ol' Cherokee OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 5 09-20-2015 02:13 AM
Please Help, Fuel Problems... I think Ella15 Cherokee Chat 0 09-04-2015 05:18 PM
98' XJ idling issues jurazov OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 0 09-03-2015 04:08 PM
TPS question mtoskippy OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! 0 09-03-2015 09:21 AM


Tags
shifting, throttle valve, transmission, transmission issues, tv cable


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:55 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: