Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

1997 5.2L Stalling At Idle

Old 12-04-2016, 11:14 AM
  #1  
Newbie
Thread Starter
 
Join Date: Dec 2016
Posts: 2
Model: Cherokee
Default 1997 5.2L Stalling At Idle

Hoping someone can help. Have a strange issue with my Son's 1997 Grand Cherokee limited with the 5.2. Has 78000 miles, and when it runs, it runs GREAT! Problem is, he can drive it for a day or two with no problems, then it will start stalling at idle. Will start right back up, but when you let the throttle off, it dies. Replaced IAC, thought that fixed it, but problem came back in a couple days. Then I noticed when this happens, I can clear it up for a day or two by removing the battery cable, which I did when I replaced the IAC.

Seems like the battery being removed fixes it. Also, the battery was dead from him turning it over I assumed, and when I jumped it, ran fine for a 30 minute drive no stalling. Runs fine with battery disconnected, so shade tree test of alternator passes. One other thing I can think of is that the information center in the dash was throwing a coolant level alarm, which was not accurate, see this a lot with these as well. But recently the information center smoked and is no longer working.

I see a lot of the same issues with these vehicles, and no one really seems to have a handle on what the issue is. Also, when I run my reader on it, the only code it throws is the battery disconnected recently code, which I expect. No other codes. Seems like a computer issue, but not sure. Also, I suspect if battery is failing could cause issues, but alternator seems to be keeping up when at idle, so not sure if battery is even in play at this point. Any help is appreciated.
MikeiVan is offline  
Old 12-24-2016, 07:56 AM
  #2  
Newbie
Thread Starter
 
Join Date: Dec 2016
Posts: 2
Model: Cherokee
Thumbs up UPDATED

Originally Posted by MikeiVan View Post
Hoping someone can help. Have a strange issue with my Son's 1997 Grand Cherokee limited with the 5.2. Has 78000 miles, and when it runs, it runs GREAT! Problem is, he can drive it for a day or two with no problems, then it will start stalling at idle. Will start right back up, but when you let the throttle off, it dies. Replaced IAC, thought that fixed it, but problem came back in a couple days. Then I noticed when this happens, I can clear it up for a day or two by removing the battery cable, which I did when I replaced the IAC.

Seems like the battery being removed fixes it. Also, the battery was dead from him turning it over I assumed, and when I jumped it, ran fine for a 30 minute drive no stalling. Runs fine with battery disconnected, so shade tree test of alternator passes. One other thing I can think of is that the information center in the dash was throwing a coolant level alarm, which was not accurate, see this a lot with these as well. But recently the information center smoked and is no longer working.

I see a lot of the same issues with these vehicles, and no one really seems to have a handle on what the issue is. Also, when I run my reader on it, the only code it throws is the battery disconnected recently code, which I expect. No other codes. Seems like a computer issue, but not sure. Also, I suspect if battery is failing could cause issues, but alternator seems to be keeping up when at idle, so not sure if battery is even in play at this point. Any help is appreciated.

UPDATE: UPDATED: So after the IAC went ahead and swapped the TPS. Interesting, tested the old TPS with my Fluke ohm meter. Nothing glaring in the changes in resistance as I cranked the TPS. But when I put my meter on continuity check, I noticed that, in just about the same spot every time I rotated the throttle position sensor as if the accelerator is being depressed, there was a dead short in the TPS. I could not pick this up in OHM check mode, but the meter caught it in continuity check. Has been installed for 3 weeks now and no stalling.
MikeiVan is offline  
Old 12-24-2016, 08:14 AM
  #3  
Senior Member
 
wingless's Avatar
 
Join Date: May 2015
Posts: 578
Year: 1994
Model: Grand Cherokee
Engine: 5.2L Magnum V8 220hp 285ft-lbs
Default

Welcome to the forum!

Great update! This is very good information! Good job!
wingless is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: