Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 01-14-2011, 11:59 AM   #1
Junior Member
 
Join Date: Jan 2011
Location: Tulsa, OK
Posts: 35

View OKBrian's Photo Album My Photos
1990 Cherokee
Default Transmission issue

I have a 1990 4x4 xj with 4.0L & automatic trans. The problem is, intermittently the trans has delayed shifting (engine revs higher) from 1st to 2nd. From 3rd to 4th is just fine. sometimes the shift from 1st to 2nd is just fine as well. Any ideas? Thx for any help!
OKBrian is offline   Reply With Quote
Old 01-14-2011, 02:17 PM   #2
"CF Moderator"
 
TrekkerJmm's Avatar
 
Join Date: Sep 2008
Location: N.J. Shore Area
Posts: 3,030

View TrekkerJmm's Photo Album My Photos
1994 Cherokee
Default

Quote:
Originally Posted by OKBrian View Post
I have a 1990 4x4 xj with 4.0L & automatic trans. The problem is, intermittently the trans has delayed shifting (engine revs higher) from 1st to 2nd. From 3rd to 4th is just fine. sometimes the shift from 1st to 2nd is just fine as well. Any ideas? Thx for any help!
Hi and welcome to CF from Tj...How many miles on the Trans/fluid?
__________________
Become a CF Premium Member Here
Search Here
-----------------------------------
CF Rules Here
TrekkerJmm is offline   Reply With Quote
Old 01-14-2011, 02:32 PM   #3
CF Veteran
 
BuckB91XJ's Avatar
 
Join Date: Nov 2008
Location: Oak Harbor, WA.
Posts: 6,971

View BuckB91XJ's Photo Album My Photos
1987 Cherokee
Default

There is a servo in the AW4 that controls that 1-2 shift. It could be getting worn out. If you drive around a lot like crawling trails for instance with your tranny selector in your lowest gear which in the AW4 is 1-2 because it doesn't give you the ability to select 1st and 2nd gear individually. Having your gear shifter in that position and crawling around will cause your tranny to constantly be hunting between 1st and 2nd gear. If you or the previous owner of your Jeep did this alot it could cause that 1-2 servo to wear out and cause slipping or a pause between those two gears.
__________________
Brian "Buck" Buchanan, U.S. Navy Chief Petty Officer (RETIRED) - 87 XJ Laredo - 8.5" Rusty's Offroad/Rough Country lift, D30 trussed up and D44 high clearance shock mounts, 4.56's, Aussies and Disc Brakes front and rear, JCR Offroad Belly Skid Plate and Stage 2 Rock Sliders, Off Road Fab Winch Bumper and Quarter panel Guards, Liberal Front Wheel Well trimming and Rear Wheel Well Cut N Fold, 35" Goodyear MTR with Kevlars, Cobra CB and AW4 First Gear Lock Crawl switch, SYE, Stock XJ driveshafts front and rear and Milemarker SEC8000 Winch.

91 XJ Sport (Old Gray Jeep) - Layed to Rest (04-01-13)
87 XJ Laredo (Ole Red) - (My Jeep)
87 XJ Base (The Boys Jeep)
96 XJ Country (The Daughters Jeep)
08 Dodge Charger R/T (The Wifes Ride)
04 Silverado 2500HD Duramax/Allison (tow rig)
BuckB91XJ is offline   Reply With Quote
Old 01-14-2011, 03:49 PM   #4
Junior Member
 
Join Date: Jan 2011
Location: Tulsa, OK
Posts: 35

View OKBrian's Photo Album My Photos
1990 Cherokee
Default

Quote:
Originally Posted by TrekkerJmm View Post
Hi and welcome to CF from Tj...How many miles on the Trans/fluid?
I unfortunately don't know. The fluid is not filthy but it's not clean/new either. I was planning on changing it soon.
OKBrian is offline   Reply With Quote
Old 01-14-2011, 04:13 PM   #5
Junior Member
 
Join Date: Jan 2011
Location: Tulsa, OK
Posts: 35

View OKBrian's Photo Album My Photos
1990 Cherokee
Default

Quote:
Originally Posted by BuckB91XJ View Post
There is a servo in the AW4 that controls that 1-2 shift. It could be getting worn out. If you drive around a lot like crawling trails for instance with your tranny selector in your lowest gear which in the AW4 is 1-2 because it doesn't give you the ability to select 1st and 2nd gear individually. Having your gear shifter in that position and crawling around will cause your tranny to constantly be hunting between 1st and 2nd gear. If you or the previous owner of your Jeep did this alot it could cause that 1-2 servo to wear out and cause slipping or a pause between those two gears.
Is the servo a tough fix or replacement? Could it be the TCU?

Last edited by OKBrian; 01-14-2011 at 04:20 PM.
OKBrian is offline   Reply With Quote
Old 01-14-2011, 04:23 PM   #6
CF Veteran
 
BuckB91XJ's Avatar
 
Join Date: Nov 2008
Location: Oak Harbor, WA.
Posts: 6,971

View BuckB91XJ's Photo Album My Photos
1987 Cherokee
Default

Honestly bro I've never had to do it to my rig yet. Sorry I can't help you with that. Awhile back I found a way to put in a toggle switch and manually turn my TCU on and off. If you come to a complete stop i.e. your tranny is in 1st gear then I flip the switch turning my TCU off. Then, I can crawl around on the trails all day without the tranny stuck in 1st gear until I flip the switch back turning my TCU back on and she shifts automatically like normal again.
__________________
Brian "Buck" Buchanan, U.S. Navy Chief Petty Officer (RETIRED) - 87 XJ Laredo - 8.5" Rusty's Offroad/Rough Country lift, D30 trussed up and D44 high clearance shock mounts, 4.56's, Aussies and Disc Brakes front and rear, JCR Offroad Belly Skid Plate and Stage 2 Rock Sliders, Off Road Fab Winch Bumper and Quarter panel Guards, Liberal Front Wheel Well trimming and Rear Wheel Well Cut N Fold, 35" Goodyear MTR with Kevlars, Cobra CB and AW4 First Gear Lock Crawl switch, SYE, Stock XJ driveshafts front and rear and Milemarker SEC8000 Winch.

91 XJ Sport (Old Gray Jeep) - Layed to Rest (04-01-13)
87 XJ Laredo (Ole Red) - (My Jeep)
87 XJ Base (The Boys Jeep)
96 XJ Country (The Daughters Jeep)
08 Dodge Charger R/T (The Wifes Ride)
04 Silverado 2500HD Duramax/Allison (tow rig)
BuckB91XJ is offline   Reply With Quote
Old 02-09-2011, 01:29 PM   #7
Junior Member
 
Join Date: Jan 2011
Location: Tulsa, OK
Posts: 35

View OKBrian's Photo Album My Photos
1990 Cherokee
Default

bump...anyone else with any ideas I changed the transmission fluid & filter and installed a new TPS. Still the same problem.
OKBrian is offline   Reply With Quote
Old 02-09-2011, 01:45 PM   #8
Seasoned Member
 
SamSissine2's Avatar
 
Join Date: Jan 2011
Location: Charlotte, NC
Posts: 313

View SamSissine2's Photo Album My Photos
2001 Cherokee
Default

what kind of fluid are you using.?
__________________


Advance Auto 40% off $85 or More Discount code: (follow link below and hit shop, code now updates)
http://advanceautoparts.tellapal.com/a/clk/ZNqfD

http://www.engineoilinfo.com/index.htm

http://bobistheoilguy.com/forums/ubb...oard=11&page=1

For all you Equity/Future Traders Check out Tastytrade (open an account and get a free ROKU Player): https://www.tastytrade.com/ref?id=d7...c7c180bdf41db4
SamSissine2 is offline   Reply With Quote
Old 02-09-2011, 01:49 PM   #9
Junior Member
 
Join Date: Jan 2011
Location: Tulsa, OK
Posts: 35

View OKBrian's Photo Album My Photos
1990 Cherokee
Default

Dex III
OKBrian is offline   Reply With Quote
Old 02-09-2011, 01:49 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission/Drivetrain Issue??? Not Sure tkclow OEM Cherokee Tech 7 11-22-2010 07:32 PM
Transmission issue JTE32 Grand Cherokee Tech 2 09-28-2010 08:12 PM
Transmission Issue? uh60infidel OEM Cherokee Tech 6 09-23-2010 07:14 PM
1998 JGC 4.0L Transmission issue Chief008 Grand Cherokee Tech 1 10-29-2009 07:24 PM
Cherokee transmission issue: HNRclothing OEM Cherokee Tech 3 02-25-2009 08:32 AM


All times are GMT -5. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup