rich condition and stall. no codes - Jeep Cherokee Forum
Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Log In 
Search


rich condition and stall. no codes

Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-22-2013, 12:58 PM   #1
Junior Member
 
Buzzbomber's Avatar
 
Join Date: Dec 2012
Location: Lyons, KS
Posts: 56

View Buzzbomber's Photo Album My Photos
1996 Cherokee
Default rich condition and stall. no codes

Ok. My jeep has been running rough recently mainly at idle. It runs perfectly fine down the road but sputters at idle like a slight misfire and when coming to a stop while driving sometimes it will choke itself out and die unless you give it gas to ease itself to idle speed. when you hammer down it blows black smoke out the exhaust. I may add it isnt throwing any codes whatsoever.
'96 4.0. changed distributor to a brand new one about 2 weeks ago due to a ticking sound coming from it being the rotor hitting the terminals in the cap. wobbling shaft so it is new along with the cap/rotor. changed plugs to champion #412's last week. wires are msd streetfire and are in good condition. put on about 6mos ago. coil is also an msd streetfire coil put on at same time as wires. fuel filter was changed about 2mos ago. air filter is a k&n drop in i just cleaned/oiled like 3 weeks ago. replaced alternator 3days ago and checked all wires/grounds/fuses at the time. tps was replaced. iac was cleaned. map sensor was cleaned and vacuum lines checked and are good. o2 sensors were both replaced. it was throwing lean/rich condition codes a while back but after replacing plugs/welding manifold/cleaning tb and sensors/replacing gasket i cleared the codes and they havent returned and it ran fine for a few days and now its doing this. anything i'm missing?
__________________
'96 2door XJ project dd/family rig
'87 K5 tubed crawler on tons/40's
Buzzbomber is offline   Reply With Quote
Join Cherokee Forum

Join CherokeeForum.com Today - It's Totally Free!

Do you love your Jeep? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Jeep Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your jeep, and have a great time with other Jeep Cherokee fans.. Whether your an old timer or just bought your Jeep you'll find that CherokeeForum.com is a great community to join. Best of all it's totally free!

Join CherokeeForum.com Today! - Click Here JOIN FOR FREE


-->
Old 02-22-2013, 03:35 PM   #2
Junior Member
 
Buzzbomber's Avatar
 
Join Date: Dec 2012
Location: Lyons, KS
Posts: 56

View Buzzbomber's Photo Album My Photos
1996 Cherokee
Default

fuel pressure tested good. havent checked for vacuum leaks. will try that this evening.
__________________
'96 2door XJ project dd/family rig
'87 K5 tubed crawler on tons/40's
Buzzbomber is offline   Reply With Quote
Old 02-25-2013, 09:06 AM   #3
Junior Member
 
Buzzbomber's Avatar
 
Join Date: Dec 2012
Location: Lyons, KS
Posts: 56

View Buzzbomber's Photo Album My Photos
1996 Cherokee
Default

checked timing and is spot on, no vacuum leaks but went ahead and changed the L shaped one on the map sensor and made a tighter connection on the big vacuum line on the side of the intake. drove it around for a bit and it halfway surges intermittently and is just chugging fuel. then it tossed codes p0171 and p0172 again.
__________________
'96 2door XJ project dd/family rig
'87 K5 tubed crawler on tons/40's
Buzzbomber is offline   Reply With Quote
Old 02-26-2013, 08:22 AM   #4
Junior Member
 
Buzzbomber's Avatar
 
Join Date: Dec 2012
Location: Lyons, KS
Posts: 56

View Buzzbomber's Photo Album My Photos
1996 Cherokee
Default

finally got another code to pop up leading to the o2 sensor so i unplugged my upstream o2 and it ran better. looks like when i hydrolocked the water may have killed one of my brand new o2 sensors? gonna warranty it out and see what happens
__________________
'96 2door XJ project dd/family rig
'87 K5 tubed crawler on tons/40's
Buzzbomber is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi-Lift Day at Redbird marcy_1990 Introductions 9 09-01-2015 01:27 PM
Cam Sensor Hard Failure CCKen OEM Cherokee Tech 3 08-20-2015 08:07 PM
please helppp! dgkallday3291 Grand Cherokee Tech 1 08-20-2015 09:43 AM
92XJ Code 35 wont go away XJRex OEM Cherokee Tech 2 08-14-2015 07:21 AM
Check Engine codes and live info, What else bigwave Grand Cherokee Tech 1 08-14-2015 04:58 AM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:42 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup