Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 01-12-2011, 08:22 AM   #1
Newbie
 
Join Date: Jan 2011
Posts: 10

View blown07gt's Photo Album My Photos
Cherokee
Default jeep will start but wont stay running..

Woke up this morning went to start jeep dead battery.. changed it out and now jeep wont run. It will start and stay running only if u give it the gas but runs very smooth when running. Stumped.. any ideas??
blown07gt is offline   Reply With Quote
Old 01-12-2011, 08:48 AM   #2
Senior Member
 
Ol' Bloo's Avatar
 
Join Date: Dec 2010
Location: Anderson, South Carolina
Posts: 562

View Ol' Bloo's Photo Album My Photos
1998 Cherokee
Default

This happened to me once before, got stuck in a food lion parking lot for 3 hours trying to get my jeep running again. I just had to keep revving the engine til it finally stayed on long enough to get home.
__________________
Mud's and Bud's Offroad Club

Team Leader
Anderson, SC
Team rigs:
1998 Jeep Cherokee Sport
1990 Isuzu Trooper
1998 Jeep Grand Cherokee Laredo
1992 Jeep Wrangler
Check us out on FaceBook!
Ol' Bloo is offline   Reply With Quote
Old 01-12-2011, 08:55 AM   #3
Newbie
 
Join Date: Jan 2011
Posts: 10

View blown07gt's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by Ol' Bloo
This happened to me once before, got stuck in a food lion parking lot for 3 hours trying to get my jeep running again. I just had to keep revving the engine til it finally stayed on long enough to get home.
Do you recall what fixed it or was it just one of those freak things? I don't know where to start lol its been fine, changed the battery and then this.. I know it doesn't have anything to do with the battery just coincidence I guess. After u kept revving it, it cleared up and it was fine?
blown07gt is offline   Reply With Quote
Old 01-12-2011, 09:28 AM   #4
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Happyville...
Posts: 31,399

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Quote:
Originally Posted by blown07gt View Post
Woke up this morning went to start jeep dead battery.. changed it out and now jeep wont run. It will start and stay running only if u give it the gas but runs very smooth when running. Stumped.. any ideas??
did you make sure you did not knock ant thing loose in the area of the battery accidents happen,vacuum lines wires wont hurt to bouble check
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-12-2011, 09:35 AM   #5
Newbie
 
Join Date: Jan 2011
Posts: 10

View blown07gt's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by freegdr
did you make sure you did not knock ant thing loose in the area of the battery accidents happen,vacuum lines wires wont hurt to bouble check
Yea gonna check all that as soon as I get outta work it sound to me vacuum related but ill keep u posted thanks alot
blown07gt is offline   Reply With Quote
Old 01-12-2011, 09:39 AM   #6
CF Veteran
 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Happyville...
Posts: 31,399

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

there is a line in that area goes to the vacuum ball and cruise is in that area if you have it
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-12-2011, 09:49 AM   #7
Member
 
Join Date: Sep 2010
Location: St Louis Park, MN
Posts: 112

View textherex's Photo Album My Photos
1998 Cherokee
Default

A vacuum leak would not allow the truck to idle or run smooth, it would either be reving high or sputtering. My guess going on the Coil pack or system in the fuel system. How does it rev, how long does it take to get started? Also, is the battery fully charged when you have it running or are you having to jump start it everytime you need to start it? If you are having to jump it, it might be your alturnator.. but it very very hard to tell you what could be the issue.
textherex is offline   Reply With Quote
Old 01-12-2011, 10:01 AM   #8
Newbie
 
Join Date: Jan 2011
Posts: 10

View blown07gt's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by textherex
A vacuum leak would not allow the truck to idle or run smooth, it would either be reving high or sputtering. My guess going on the Coil pack or system in the fuel system. How does it rev, how long does it take to get started? Also, is the battery fully charged when you have it running or are you having to jump start it everytime you need to start it? If you are having to jump it, it might be your alturnator.. but it very very hard to tell you what could be the issue.
Battery is good just put it in, its revs great no miss or anything and no hesitation at all. If I hit the gas rite as I first crank it it will start rite up but if I take my foot off re gas it wont stay running on its own.
blown07gt is offline   Reply With Quote
Old 01-12-2011, 11:26 AM   #9
Newbie
 
Join Date: Jan 2011
Location: prince edward island
Posts: 1

View yeedogy's Photo Album My Photos
1995 Grand Cherokee
Default

might be anti theft ? mine does this when i change the battery. To disarm i have to lock then unlock rear hatch
yeedogy is offline   Reply With Quote
Old 01-12-2011, 12:09 PM   #10
Newbie
 
Join Date: Jan 2011
Posts: 10

View blown07gt's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by yeedogy
might be anti theft ? mine does this when i change the battery. To disarm i have to lock then unlock rear hatch
Wow I feel super dumb battery terminal wasn't tightened all the way.. very interesting. And that to the fellas..
blown07gt is offline   Reply With Quote
Old 01-12-2011, 01:46 PM   #11
CF Veteran
 
Bustedback's Avatar
 
Join Date: Feb 2010
Location: Oroville, CA
Posts: 10,412

View Bustedback's Photo Album My Photos
1995 Grand Cherokee
Default

The PCM has to do a relearn after you jump start it, just start it and keep your foot on the gas for a minute or two.
__________________
Steering stabilizers will not cure or cause death wobble, they only mask the real problem that is causing death wobble. Oil pumps do not make pressure, they create flow. Bearing clearence and restrictions make pressure. It's the crank sensor.
Bustedback is offline   Reply With Quote
Old 07-28-2011, 09:57 AM   #12
Newbie
 
Join Date: Jul 2011
Location: VA
Posts: 2

View VTMeg's Photo Album My Photos
2000 Cherokee
Default

I had the exact same problem several months ago. Turned out I had crazy carbon build up on the engine. But it would run fine, I would just have to keep giving it gas, esp when at stoplights or stop signs or else it'd die. And sometimes when starting had to jump straight on gas to keep running. At garage, they had to run through process of cleaning out carbon build up 5x then it ran like brand new!! Had 190,000 miles on it at the time haha
VTMeg is offline   Reply With Quote
Old 07-28-2011, 12:45 PM   #13
OEJ
CF Veteran
 
OEJ's Avatar
 
Join Date: Dec 2010
Location: S.Jersey
Posts: 1,700

View OEJ's Photo Album My Photos
1999 Cherokee
Default

WOW. this is the 3-4th time in 2 days that i have typed the following with the same symtons that u r having.lol.

it could also be an 02 sensor. even though you don't have a ces light, the 02 could still be bad. tps or iac would throw a code imediately.

my 02 was bad and i had no ces light. a couple of days before this, when i went to start it up for the first time of the day, it had a slight rough idle. it soon went away and ran fine. it acted the same way both times before i changed the 02's out.

it went on me on monday and 2 weeks ago i put an aftermarket 02 in it. that went bad. went to the dealer and got a mopar 02 sensor. he told me that chrysler products don't run on bosch o2's. there was a very noticable difference in appearence of the bosch and mopar sensor probes on the 02's.

so make sure you get it a dealer. if that is the problem. just an fyi.
__________________
Jay.

Last edited by OEJ; 07-28-2011 at 12:53 PM.
OEJ is offline   Reply With Quote
Old 07-28-2011, 12:45 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Grand Cherokee Wont Start - Fuel Pump Won't Run/Stay Running RHStorm11 Grand Cherokee Tech 27 09-18-2014 07:37 PM
wont stay running lubeboss09 OEM Cherokee Tech 3 08-18-2010 07:57 PM
Wont stay running posjeepxj OEM Cherokee Tech 5 07-24-2010 12:06 AM
93 xj not wont stay running.. 00xj-classic Cherokee Chat 0 01-11-2010 02:17 PM
wont stay running jeeper92 OEM Cherokee Tech 7 09-09-2009 04:09 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:17 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup