Defroster problem - Jeep Cherokee Forum
Jeep Cherokee Forum


Defroster problem

Reply
 
 
 
Thread Tools Search this Thread
Old 12-11-2009, 10:59 AM   #1
Newbie
Thread Starter
 
Join Date: Sep 2009
Location: Western NY
Posts: 14

View Truckedup's Photo Album My Photos
Default Defroster problem

Yes a problem,like it doesn't work,99 Cherokee with air.The dial selector seems to work ok on all settings but defrost.When you select defrost,hot air blows out real hard from the side widow vent but nothing from the defroster vents.In fact it is really loud blowing out the side vent.The AC compressor also cycles when the outside temp is very cold. My other 99 Cherokee's AC does not cycle when the outside temp is below about 35 degrees.Just a comparison between my two Jeeps.
Obiviously something is wrong,maybe a vent flap broken? Asking for opinions before I tear into this,thanks
Truckedup is offline   Reply With Quote
Old 12-12-2009, 12:02 PM   #2
Junior Member
 
mcgoaw's Avatar
 
Join Date: Oct 2009
Location: Wilkes-Barre, Pa
Posts: 88

View mcgoaw's Photo Album My Photos
Default

Funny, today I popped on here because I have the same problem and before I started to look at it I figured I'd cheat and see if anyone experienced this. I am thinking it's related to some vacuum issue? Not too long ago some jackass broke into my ride and just tore out anything he could. There were some wires that just got destroyed from the Xm radio that were tucked up under the dash so thats where I am headed for. Maybe I will be lucky and find my prob in that area? Good luck with yours, later. Mike
mcgoaw is offline   Reply With Quote
Old 12-24-2009, 09:36 AM   #3
Junior Member
 
Join Date: Jul 2009
Posts: 35

View Shadetree61's Photo Album My Photos
Default

I have the same problem. Go to NAXJA.org & search, there is a thread for this exact problem with the cause & a temp fix. Not sure of a permanent fix but I'm going to try to figure something out. I'll post if I come up with something.
Shadetree61 is offline   Reply With Quote
Old 12-27-2009, 09:32 PM   #4
Newbie
 
lex1125's Avatar
 
Join Date: Jan 2009
Posts: 12

View lex1125's Photo Album My Photos
Default 99 xj no windshield de-froster.

I have the same (exact) problem. 99xj fan selector works fine except no windshield defrost. I have vacuum under the hood at the check valve. (on my 95, I would only get windshield defrost - until I found and fixed a vacuum leak).

Any ideas? Did anyone find the problem?
lex1125 is offline   Reply With Quote
Old 01-02-2010, 10:56 AM   #5
Member
 
Join Date: Jun 2008
Location: DFW
Posts: 139

View TeXJ's Photo Album My Photos
Default

i found the one on NAXJA, apparently there is a rod that comes out, and you have to stick it back in. The rod is behind where the radio is. This was on a 98 or 99 xj, cant remember which. And they said to leave the fan speed to "1" or "2" position, as the higher speed spits out the rod....

that is what i got from it. Also there is a video that a guy made, but it doesnt really show anything then it goes really dark.
TeXJ is offline   Reply With Quote
Old 01-05-2010, 09:04 AM   #6
Newbie
 
lex1125's Avatar
 
Join Date: Jan 2009
Posts: 12

View lex1125's Photo Album My Photos
Default Update - FIxed

The problem turned out to be the actuator(?) in back of the radio just as described in the Naxja thread. Plastic rod 'pops' out when you select the windshield de-frost button. I was able to push it back in, although it keeps popping out at high fan speed (3 or 4). Once I manually pushed the vent in position, though, the air comes out of the top windshiled de-frost position.
I have a hunch I'll have to fix it again though in time.

(thanks for pointing me to that naxja link, saved me a bunch of time!)
lex1125 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AW4 P0753 issue heat related Psiegrist1 OEM Cherokee Technical. All factory issues and info go here! 9 09-30-2015 10:45 PM
99 XJ A/C blower intermittently working shotseven OEM Cherokee Technical. All factory issues and info go here! 0 09-06-2015 04:06 PM
Engine problems cbowl Cherokee Chat 1 09-04-2015 02:56 PM
Jeep cherokee 1994 starting problem Jeepy11 Grand Cherokee Tech 2 09-03-2015 10:32 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:17 AM.