Go Back  Jeep Cherokee Forum > General > Off-Topic Discussion
Question for the AC pros (not Jeep related) >

Question for the AC pros (not Jeep related)

Question for the AC pros (not Jeep related)

Old 06-11-2019, 05:32 PM
  #1  
Great White Jeep
Thread Starter
 
5-Speed's Avatar
 
Join Date: Dec 2016
Location: SoCal
Posts: 2,813
Likes: 0
Received 6 Likes on 6 Posts
Year: Jeepless
Model: Cherokee (XJ)
Default Question for the AC pros (not Jeep related)

First off, this is not a question about a Jeep problem. This is about my daily beater, an 04 Saturn Vue. I need to ask the AC pros a couple questions on the issue I am having. I used to work on car AC systems daily, but I was young and that was over 15 years ago so a lot of the info in my head has been lost. Anyways, on to the issue.

My AC works absolutely great when cruising down the road, to the point where it will freeze you out. Its when I am sitting still idling that it stops working. Now I know most of you will say the e-fan isnt kicking on but it is and its moving a good amount of air. Now here is the thing, if I am sitting still and bring the RPM up to 2000, it works just fine. When I got the car, it has zero r134 in it. I replaced the seals that were leaking, vacuumed the system, made sure it held vac and charged the system with the proper amount of fluid/pag oil. I did this all with professional equipment and not one of those cheap add r134 to the low side with only one gauge dealios that they sell at Autozone. At idle, both the high and low side read really low. At 2000 RPM, the high side reads just a tad low but the low side is still pretty low. Adding more fluid didnt really do anything. I can plug back in to it to get you real #s if that helps.

Now here is the thing, this vehicle does not have a orifice valve, it has an expansion valve. Typically I would think this sounds like an orifice valve issue but seeing that I dont have one, the closest thing to one is the expansion valve. From my research, it seems that expansion valves do not like r134 with sealant in it as they tend to clog. I have no idea if the PO used that stuff or not. I know I didnt. I have also read that it could be the compressor going bad, maybe both. So what do you guys think it could be? Both the compressor and the valve? One or the other? Something else? Its 110 out today and sitting in the drive thru at lunch was horrible so I would like to fix this right the first time. I am going to park this beater until the problem is fixed so I dont have to deal with it but I really dont like driving my other car every day (its a garage queen). So the sooner I can fix it the better! Any input would be great!
5-Speed is offline  
Old 06-11-2019, 06:35 PM
  #2  
Newbie
 
Join Date: May 2019
Location: York, Ne
Posts: 3
Received 0 Likes on 0 Posts
Year: 1996
Model: Cherokee (XJ)
Engine: 4.0
Default

On some cars especially ones with very small engines the computer kills the ac at idle.
nuttyprof is offline  
Old 06-11-2019, 07:10 PM
  #3  
CF Veteran
 
4.3L XJ's Avatar
 
Join Date: Aug 2008
Location: Chico, CA
Posts: 4,471
Likes: 0
Received 1 Like on 1 Post
Year: 1986
Model: Cherokee
Engine: 4.3L with headers and full 3" exhaust system
Default

Does this system that has a TXV also have a sight glass?
4.3L XJ is offline  
Old 06-11-2019, 08:13 PM
  #4  
Great White Jeep
Thread Starter
 
5-Speed's Avatar
 
Join Date: Dec 2016
Location: SoCal
Posts: 2,813
Likes: 0
Received 6 Likes on 6 Posts
Year: Jeepless
Model: Cherokee (XJ)
Default

Originally Posted by nuttyprof View Post
On some cars especially ones with very small engines the computer kills the ac at idle.
It does have a small engine, 2.2L but the ac clutch stays engaged at idle leading me to say no it's not kicking off.

Originally Posted by 4.3L XJ View Post
Does this system that has a TXV also have a sight glass?
By Txv valve, I assume you are referring to what I call the expansion valve? If so, no sight glass. Being able to see bubbles vs no bubbles would be nice.
5-Speed is offline  
Old 06-11-2019, 08:20 PM
  #5  
CF Veteran
 
4.3L XJ's Avatar
 
Join Date: Aug 2008
Location: Chico, CA
Posts: 4,471
Likes: 0
Received 1 Like on 1 Post
Year: 1986
Model: Cherokee
Engine: 4.3L with headers and full 3" exhaust system
Default

Did you use super heat or sub cooling to charge it? With a TXV you have to use subcooling (difference between measured heat after the condenser vs pressure?temp n the gauges. You cannot measure the pressure/temp on the return line. The TXV by definition is a thermal expansion valve and regulates its own super heat and that value is near useless on the return side
4.3L XJ is offline  
Old 06-11-2019, 09:30 PM
  #6  
Great White Jeep
Thread Starter
 
5-Speed's Avatar
 
Join Date: Dec 2016
Location: SoCal
Posts: 2,813
Likes: 0
Received 6 Likes on 6 Posts
Year: Jeepless
Model: Cherokee (XJ)
Default

I did neither. What difference would it make since I filled it with the factory recommend amount? That should get it in the ballpark right? To me it just seems like the compressor just cant make enough psi at idle, aka worn out/damaged. I have another I can throw on it.

So if readings on the return line are useless, do I just judge the other side like normal?
5-Speed is offline  
Old 06-21-2019, 12:40 PM
  #7  
Great White Jeep
Thread Starter
 
5-Speed's Avatar
 
Join Date: Dec 2016
Location: SoCal
Posts: 2,813
Likes: 0
Received 6 Likes on 6 Posts
Year: Jeepless
Model: Cherokee (XJ)
Default

Well just going to take a guess at whats wrong at this point. New parts ordered and here. Lets hope it works like normal after this!

- Compressor
- Expansion valve
- Dryer

Will install and charge this weekend and hope for the best.
5-Speed is offline  
Old 06-28-2019, 11:50 PM
  #8  
Great White Jeep
Thread Starter
 
5-Speed's Avatar
 
Join Date: Dec 2016
Location: SoCal
Posts: 2,813
Likes: 0
Received 6 Likes on 6 Posts
Year: Jeepless
Model: Cherokee (XJ)
Default

Got sent the wrong compressor which made for a delay. Long story short, ordered a different line and made the compressor work. Ac now works at idle. Just had to replace about 90% of the system. Was by no means a fun task.




5-Speed is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
darknezz
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
25
12-22-2010 03:19 PM
Ls1Powerz
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
16
10-22-2010 12:48 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Question for the AC pros (not Jeep related)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: