Aftermarket electrical systems Aftermarket electronics only! stereo head units, CD players, MP3 players, speaker systems, amplifiers, hardmounted GPS devices, computers, headlight upgrades, fog lights, off-road lights, general wiring and anti-theft devices.

Aftermarket Radio Issues

Old 05-29-2018, 02:13 PM
  #1  
Newbie
Thread Starter
 
Join Date: May 2018
Posts: 6
Model: Cherokee (XJ)
Default Aftermarket Radio Issues

Been trying to track down an issue with an aftermarket radio for months now. I installed a new Kenwood deck along with new speakers all around. I ordered the kit from Crutchfield and they sent their pre-wired harness that goes into the factory harness. The problem is the radio will at random times just shut off with no rhyme or reason. Sometimes it will come back on, other times, I have physically disconnect the radio from the harness and plug it back in to turn back on. Once the whole deck shut off and came back on but "locked up" with the lights on and didn't turn off when vehicle was powered off.

I've checked all the wires, jiggled them around, none appear to be loose or shorting out what-so-ever. I was using the factory ground so I thought that may have been the problem so I ran a new ground wire, still didn't solve the issue. I can remove the key from the ignition while its running, but that doesn't seem to effect the issue as I thought it may be that. I've tried many things to try and get it to shut off, but nothing works and it still does it at completely random times resulting in me having to pull it out of the dash.

2001 Jeep Cherokee Sport with out the infinity system

Last edited by the-order; 05-29-2018 at 02:22 PM.
the-order is offline  
Old 05-29-2018, 02:55 PM
  #2  
Senior Member
 
Join Date: Jun 2016
Location: Santa Clarita California
Posts: 774
Year: 2001
Model: Cherokee
Engine: 4.0L
Default

Check the fuses for corrosion and that they fit tight , it could be the problem .
tech is offline  
Old 05-29-2018, 03:00 PM
  #3  
Newbie
Thread Starter
 
Join Date: May 2018
Posts: 6
Model: Cherokee (XJ)
Default

Those were the first thing I checked, they all fit good and look fine. When it does shut off, the audio cuts out but the lights/backlight stay on for about half a second, than turns off completely.
the-order is offline  
Old 05-29-2018, 03:18 PM
  #4  
Senior Member
 
Join Date: Jun 2016
Location: Santa Clarita California
Posts: 774
Year: 2001
Model: Cherokee
Engine: 4.0L
Default

XJ's do have problems with the ignition switch , or it can be a problem with the radio .
tech is offline  
Old 05-29-2018, 03:36 PM
  #5  
Newbie
 
Join Date: May 2018
Location: Albuquerque
Posts: 14
Year: 1994
Model: Cherokee (XJ)
Engine: 4.0
Default

Have you tried going over the wiring that crutchfield supplied. I have a feeling that the radio is hooked up to constant power instead of ignition activated power. Also another thing that could be possible. Is that since your key comes out while in the on position its possible that you are rolling the key all the way back into the accessory on position and they key just comes out like normal. I had that issue with a copied key I got with my xj. Or its possible that kenwood is just trash because i also got a kenwood radio from crutchfiled and half of the functions dont work.
Heapyjeepy is offline  
Old 05-29-2018, 03:40 PM
  #6  
Newbie
Thread Starter
 
Join Date: May 2018
Posts: 6
Model: Cherokee (XJ)
Default

I would think a problem with the ignition would cause it to shut off in a similar manner when turning off the vehicle (when its working). The Kenwood deck does a small animation thing when shutting down. However, when it shuts off randomly, it doesn't play that animation. The screen just locks for half a second and than it turns off completely.

It is hooked to the ignition power as it shuts off with the vehicle, and its not going into accessory mode with the ignition as the requires a lot of force, and 99% of the time its shut off while driving. Sometimes it works great for a few days, other times, it refuses to stay on at all, typically when warmer.

Would a short in the speaker wires cause something like this to happen? Other than when it shuts off, the deck works and all the speakers work great.

Last edited by the-order; 05-29-2018 at 03:47 PM.
the-order is offline  
Old 05-29-2018, 03:45 PM
  #7  
Newbie
 
Join Date: May 2018
Location: Albuquerque
Posts: 14
Year: 1994
Model: Cherokee (XJ)
Engine: 4.0
Default

I wouldnt think a speaker wire short would change anything other than sound output. Could try pulling the radio, hooking up a multimeter to the power supply wire and start moving things around looking for a voltage drop. maybe something is moving around and shorting while driving? While at it play with the ignition switch to see if its affecting anything.
Heapyjeepy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ajk2005
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
20
03-16-2013 08:33 PM
NorthGaXJ
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
19
02-08-2011 09:23 AM
Metlic53
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
33
01-12-2011 01:47 AM
Rbngrt98xj
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
06-27-2010 12:05 AM
Kazman
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
11
09-14-2009 06:46 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Aftermarket Radio Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: