MJ Comanche Tech. Stock & Modified. MJ (86-92)
All discussion regarding the Jeep Comanche, the pickup truck related to the Cherokee platform.

renix throttle body question

Old 02-11-2015, 08:25 PM
  #1  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default renix throttle body question

Hey guys, just got my project 88' mj running. shes idling around 2k so I noticed if I plug that hole in the top (not the iac hole) in the throttle body she idles normal, whats it for? Is it supposed to be open? Thanks for any info. 88mj 91ho motor converted to renix. Egr delete, pacesetter header ba10/5 4x4

Name:  ForumRunner_20150211_212304.png
Views: 373
Size:  470.2 KB

Last edited by Gmaster; 02-11-2015 at 08:52 PM.
Gmaster is offline  
Old 02-12-2015, 06:27 AM
  #2  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Both of those are supposed to be open.

They provide the air for base idle and the air that the IAC controls.

Which intake manifold gasket did you use on the swap? Renix or HO?
You may have a vacuum leak at the intake manifold to head.
cruiser54 is offline  
Old 02-12-2015, 07:19 AM
  #3  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

I used a renix gasket from carquest. I figured its supposed to be open but its just strange it seems to idle fine with it plugged, ill have to check for vacuum leaks whenever I get the time to mess with it again.
Gmaster is offline  
Old 02-12-2015, 08:02 AM
  #4  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Gmaster View Post
I used a renix gasket from carquest. I figured its supposed to be open but its just strange it seems to idle fine with it plugged, ill have to check for vacuum leaks whenever I get the time to mess with it again.
It's pulling air from somewhere else.
cruiser54 is offline  
Old 02-12-2015, 03:58 PM
  #5  
Member
 
Bobolink's Avatar
 
Join Date: Feb 2014
Location: north of the Rio Grande, south of the Red, east of the Pecos, west of the Sabine
Posts: 172
Year: 1990
Model: Comanche
Engine: 4.0
Default

When you deleted the EGR, did you leave the valve in place and close it off somehow. or remove the valve and fabricate a blockoff plate? Just asking if that could be a source of your leak.
Bobolink is offline  
Old 02-12-2015, 03:59 PM
  #6  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Bobolink View Post
When you deleted the EGR, did you leave the valve in place and close it off somehow. or remove the valve and fabricate a blockoff plate? Just asking if that could be a source of your leak.
Excellent point.
cruiser54 is offline  
Old 02-13-2015, 08:07 PM
  #7  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Update!!! It was the throttle plate hanging open from the po udjusting the stop screw, i adjusted It to were it just rests on the screw. Now shes idling spot on, but surges down sometimes, like its going to stall but then it jumps back up to about 600rpm, what do you guys think this could be? And about the egr delete, I left the unhooked valve in place for now, but found out today its leaking slightly, im going to make a block off plate tomorrow.
Gmaster is offline  
Old 02-13-2015, 09:10 PM
  #8  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Gmaster View Post
Update!!! It was the throttle plate hanging open from the po udjusting the stop screw, i adjusted It to were it just rests on the screw. Now shes idling spot on, but surges down sometimes, like its going to stall but then it jumps back up to about 600rpm, what do you guys think this could be? And about the egr delete, I left the unhooked valve in place for now, but found out today its leaking slightly, im going to make a block off plate tomorrow.
Click on the link in my signature and go to Tip 14.
cruiser54 is offline  
Old 02-13-2015, 11:18 PM
  #9  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Originally Posted by cruiser54 View Post

Click on the link in my signature and go to Tip 14.
Thats basically what I did, I remembered reading that somewere, but ill check it again. Im also gona adjust the tps and clean the iac. Ill report back with results.
Gmaster is offline  
Old 02-14-2015, 06:47 AM
  #10  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Gmaster View Post
Thats basically what I did, I remembered reading that somewere, but ill check it again. Im also gona adjust the tps and clean the iac. Ill report back with results.
The TPS will definitely need adjustment after resetting the throttle butterfly stop screw.

Do the procedure on the Engine side of the TPS. Tip 8.
cruiser54 is offline  
Old 02-14-2015, 09:06 AM
  #11  
Newbie
 
Join Date: May 2010
Location: The Comfy Chair
Posts: 13
Year: 1990
Model: Cherokee
Engine: 4.7L
Default

Excellent 'how to' procedure in your list, Cruiser54.
lunghd is offline  
Old 02-14-2015, 09:07 AM
  #12  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by lunghd View Post
Excellent 'how to' procedure in your list, Cruiser54.
Glad to have you here!!!
cruiser54 is offline  
Old 02-14-2015, 03:12 PM
  #13  
Member
 
Bobolink's Avatar
 
Join Date: Feb 2014
Location: north of the Rio Grande, south of the Red, east of the Pecos, west of the Sabine
Posts: 172
Year: 1990
Model: Comanche
Engine: 4.0
Default

Yeah! Welcome aboard. I've read a lot of your stuff....
Bobolink is offline  
Old 02-15-2015, 10:30 AM
  #14  
Newbie
 
Join Date: May 2010
Location: The Comfy Chair
Posts: 13
Year: 1990
Model: Cherokee
Engine: 4.7L
Default

Thanks - that's what we're here for!

I've had my username registered here for quite a while but never have posted. (Which surprised me - I thought I had posted here before but reckon not). Not much happening over at JU & there seems to be an active userbase here so I'll drop in from time to time.

I was glad to see this thread as I could refer someone here faster than I could explain it myself.
lunghd is offline  
Old 02-23-2015, 10:03 AM
  #15  
Member
Thread Starter
 
Gmaster's Avatar
 
Join Date: Feb 2011
Location: Ocala, Florida
Posts: 189
Year: 1998
Model: Cherokee
Engine: 4.0
Default

Okay so I adjusted the tps and cleaned the iac and it seems to have worked, idling smooth after it warmed up. Thanks for the help guys.
Gmaster is offline  

Thread Tools
Search this Thread
Quick Reply: renix throttle body question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: