Go Back  Jeep Cherokee Forum > Technical Discussion > MJ Comanche Tech. Stock & Modified.
I think I found my shifting problem, but where can I find a new one? >

I think I found my shifting problem, but where can I find a new one?

MJ Comanche Tech. Stock & Modified. MJ (86-92)
All discussion regarding the Jeep Comanche, the pickup truck related to the Cherokee platform.

I think I found my shifting problem, but where can I find a new one?

Old 07-15-2015, 11:02 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2015
Location: Brownsville, Ohio
Posts: 47
Year: 1991
Model: Comanche
Engine: 4.0L HO
Default I think I found my shifting problem, but where can I find a new one?

After noticed my 1991 comanche nearly stalls out on hills, I did the "key off, key on" three times in 5 seconds and got the trouble code 15. Because I believe this can lead the transmission to malfunctioning, I replaced my speed sensor at the rear of my transfer case, but still got code 15. While tracing the wires for a broken or shorted circuit, I wondered across what appears to be another sensor. I ignore it because I'm focused on the wires, but after I determine the wires are OK, I return to this other sensor. I believe its called the "output" speed sensor, but I can't find it on my local part stores' websites under that designation. Am I just calling it the wrong thing, or is it in another place? Included arepictures detailing my situation to help those helping me.

AW4 transmission and NP-231 transfer case.









found this in the circled location on the T-case



Last edited by co-MAN-che; 07-15-2015 at 11:04 PM.
co-MAN-che is offline  
Old 07-16-2015, 06:54 AM
  #2  
Banned
 
Join Date: Jan 2014
Posts: 1,054
Model: Cherokee
Default

https://www.google.com/search?client...el=fs&tbm=shop


That is nothing more than the 4x4 indicator light switch.


You are chasing the rabbit down the wrong hole.
Jeep Driver is offline  
Old 07-16-2015, 08:25 AM
  #3  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by Jeep Driver View Post
https://www.google.com/search?client...el=fs&tbm=shop


That is nothing more than the 4x4 indicator light switch.


You are chasing the rabbit down the wrong hole.
Yup.
cruiser54 is offline  
Old 07-16-2015, 02:24 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jun 2015
Location: Brownsville, Ohio
Posts: 47
Year: 1991
Model: Comanche
Engine: 4.0L HO
Default

Hmm, well, it must be bad regardless because my indicator light in my dash don't light up when in 4wd. bulb is good.

So, anyone know where I can begin with my shifting problem? I just had a helluva time just trying to get the transmission going enough to get me out of the driveway just to learn it was my ******* mistake to leave the TCM unplugged for a month after some dash electrical work. I remember crawling home in 1st at 20 mph on several occasions before I realized this and I nearly cooked the fluid because one of the oil cooler lines was kinked. could the transmission possibly have suffered permanent damage because of these mishaps?

And I'm still getting a code 15

Last edited by co-MAN-che; 07-16-2015 at 02:29 PM.
co-MAN-che is offline  
Old 07-16-2015, 04:35 PM
  #5  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,741
Year: 1990
Model: Comanche
Engine: 4.0
Default

Originally Posted by co-MAN-che View Post
Hmm, well, it must be bad regardless because my indicator light in my dash don't light up when in 4wd. bulb is good.

So, anyone know where I can begin with my shifting problem? I just had a helluva time just trying to get the transmission going enough to get me out of the driveway just to learn it was my ******* mistake to leave the TCM unplugged for a month after some dash electrical work. I remember crawling home in 1st at 20 mph on several occasions before I realized this and I nearly cooked the fluid because one of the oil cooler lines was kinked. could the transmission possibly have suffered permanent damage because of these mishaps?

And I'm still getting a code 15
Very likely you cooked it. Kinked cooling lines and starting out in a high gear for how long?
cruiser54 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pyrogen
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
42
05-02-2018 09:42 AM
hpwrestler220
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
03-03-2017 01:13 AM
nicksan
Cherokee Chat
12
08-25-2015 03:42 PM
petejeep95
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
08-22-2015 11:39 AM
dgkallday3291
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
1
08-20-2015 09:43 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: I think I found my shifting problem, but where can I find a new one?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: