KL Cherokee Tech KL (14+)
2014 Cherokee Forum for all new KL and Cherokee Trailhawk discussion and tech information.
Sponsored by:
Sponsored by:

Something broke

Old 04-15-2018, 08:48 PM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2018
Posts: 4
Model: Cherokee(SJ)
Default Something broke

2015 cherokee Trailhawk, 52000 miles

I just broke something that sounds bad and dropped black hydraulic ( smells like it ) fluid all over my garage. I'm thinking pto? Jeep has 52000 miles and is in great shape. Latest issue happened when I switched from auto to snow mode.
Any ideas what it could be, Is this a common issue?
Moose58 is offline  
Old 04-16-2018, 08:03 PM
  #2  
Junior Member
 
Join Date: Jan 2018
Location: SK
Posts: 60
Year: 2016
Model: Cherokee(KL)
Engine: 3.2L
Default

Take it to the dealership, you either have a wrecked PTU or RDM (rear differential)
Tyler-98-W68 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
nicksdsm
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
13
03-30-2010 10:50 PM
trevor
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
03-08-2009 11:24 PM
dirk124
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
10
02-18-2009 05:36 AM
foxrider12390
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
02-02-2009 04:44 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Something broke


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: