Other Vehicles. Other Jeep models & cars and trucks of other makes Talk any vehicle tech in here other than Cherokees.

Hyrdo-locked 2.5 YJ

Old 07-05-2014, 08:06 AM
  #1  
Old School CF Moderator
Thread Starter
 
Xj88's Avatar
 
Join Date: May 2010
Location: Chattanooga
Posts: 9,652
Year: 2001
Model: Cherokee
Engine: 4.0
Default Hyrdo-locked 2.5 YJ

Guess this is what I get for driving a wrangler:

Alright, so after getting ballsy and taking my stock YJ on its maiden voyage I start the day with hydro locking the engine 5 minutes off the trail head.
This wasnt my first wheeling trip, so no need for criticism, im a fairly seasoned wheeler, simply took a bad line, and paid for it.

So, engine shuts off after taking water nearly to the top of the hood.
Jeep is sitting sunk in the water for maybe 10 minutes while the JK behind me pulled line and yanked me back out.

Initially trying to start I would just get 1 clunk, and that was it (all electronics still work fine).
Pulled all plugs, turned over and it puked out a good deal of water, pulled the dist, cleand it out. Put everything back together, will crank...but wont turn over.

Drove 30 minutes out to get new plugs and wires, come back to find around 500 dollars worth of tools stolen from me.. Anyways, we pull old plugs, install new ones and find that the wires the Autozone fellow gave me are for a ****ing V10 or something (11 total wires). We get them on regardless, shoot some starter fluid down the intake and try to crank. Thing will get SO close to turning over, but will not.

At this point I am basically mentally unstable, and decide to leave the Jeep and co-pilot my buds commanche on 40s.

Come back after several hours of letting YJ sit, still no go.

What the hell else could it be? Its getting spark, its getting fuel (pressure at the rail)..Only thing I can think of is somehow water got in my fuel.

Any thoughts appreciated.
Xj88 is offline  
Old 07-05-2014, 09:56 AM
  #2  
CF Veteran
 
VTJeep's Avatar
 
Join Date: Jul 2010
Location: 802
Posts: 4,930
Year: 99
Model: Cherokee
Engine: 4.0
Default

Well then.. First off, sorry for all the wheeling troubles.. Dealing with a stuck jeep is one thing, idiots who steal tools is another.. So right, air-fuel-sparků Did TPS get wet? Those temperamental bastards. Air filter wet/clogged? Full cranking power from alt. and starter? Recheck plugs for weird fouling/gapping? Best of luck!
VTJeep is offline  
Old 07-05-2014, 09:58 AM
  #3  
Old School CF Moderator
Thread Starter
 
Xj88's Avatar
 
Join Date: May 2010
Location: Chattanooga
Posts: 9,652
Year: 2001
Model: Cherokee
Engine: 4.0
Default

The air filter is gone, I pulled it immed cause it was soaked through.
The starter and alt both seem to be workign fine, starter spins at what seems like a normal rate, all electronics are working.
The plugs were brand new when we put them in after the jeep was wet...so not sure if they would have already fouled.
Xj88 is offline  
Old 07-05-2014, 10:32 AM
  #4  
CF Veteran
 
VTJeep's Avatar
 
Join Date: Jul 2010
Location: 802
Posts: 4,930
Year: 99
Model: Cherokee
Engine: 4.0
Default

Originally Posted by Xj88 View Post
The air filter is gone, I pulled it immed cause it was soaked through.
The starter and alt both seem to be workign fine, starter spins at what seems like a normal rate, all electronics are working.
The plugs were brand new when we put them in after the jeep was wet...so not sure if they would have already fouled.
CPS maybe? Not that it would have happened during the submerging, but it would sure stop it from firing up.. The plug suggestion was a long shot- I saw that they were new, but thought that if there was in issue with one already it would give some direction.. though if it won't turn over, IDK how one would look fouled.. Is there an option to vacuum out where plugs sit? maybe it didn't burp enough water out first time?
VTJeep is offline  
Old 07-05-2014, 10:49 AM
  #5  
Old School CF Moderator
Thread Starter
 
Xj88's Avatar
 
Join Date: May 2010
Location: Chattanooga
Posts: 9,652
Year: 2001
Model: Cherokee
Engine: 4.0
Default

We pulled plugs I think 3 if not 4 times and finally got it to stop misting water out
Xj88 is offline  
Old 07-05-2014, 10:51 AM
  #6  
CF Veteran
 
VTJeep's Avatar
 
Join Date: Jul 2010
Location: 802
Posts: 4,930
Year: 99
Model: Cherokee
Engine: 4.0
Default

Originally Posted by Xj88 View Post
We pulled plugs I think 3 if not 4 times and finally got it to stop misting water out
Hmm.. Try hitting the PCM while cranking?
VTJeep is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
studmuffin
Cherokee Chat
8
10-05-2015 01:54 PM
mattsmith
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
10-02-2015 04:46 PM
nicksan
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
18
09-25-2015 03:52 PM
Chick-N-Picker
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
8
09-18-2015 12:15 PM
RedStar
Modified XJ Cherokee Tech
10
09-09-2015 12:45 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Hyrdo-locked 2.5 YJ


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: