Other Vehicles. Other Jeep models & cars and trucks of other makes Talk any vehicle tech in here other than Cherokees.

92 f250 problems

Old 06-17-2015, 04:30 PM
  #1  
Seasoned Member
Thread Starter
 
diego94's Avatar
 
Join Date: Sep 2012
Location: thompson,okanogan,shushwap area in central British columbian
Posts: 304
Year: 91 laredo
Model: Cherokee
Engine: HO 4l
Default 92 f250 problems

Having trouble with my truck and don't know where to start with the problems its having, its got 351 Windsor and a 5 speed

Has trouble on cold starts if it hasn't been running within the last few hours, I have to hold the gas down for a minute or 2 before it will idle without dieing ,, always dies unless I give it gas at first till motors warm...

Also when driving if I let off the gas it bogs down really hard and starts to slow down fast...when I'm giving it just a bit its fine but as soon as I let off all the way it slows down like I hit the brakes....brakes r good they r brand new and I don't think it's related to the brakes at all

Any help and suggestions would be great thx
diego94 is offline  
Old 06-19-2015, 02:04 PM
  #2  
Member
 
Join Date: Feb 2014
Location: Victoria Texas
Posts: 120
Default

Originally Posted by diego94 View Post
Having trouble with my truck and don't know where to start with the problems its having, its got 351 Windsor and a 5 speed

Has trouble on cold starts if it hasn't been running within the last few hours, I have to hold the gas down for a minute or 2 before it will idle without dieing ,, always dies unless I give it gas at first till motors warm...

Also when driving if I let off the gas it bogs down really hard and starts to slow down fast...when I'm giving it just a bit its fine but as soon as I let off all the way it slows down like I hit the brakes....brakes r good they r brand new and I don't think it's related to the brakes at all

Any help and suggestions would be great thx
Hey buddy! sorry to hear about the issues.

I will start out by saying im no mechanic or expert

however after listening to your symptoms the first thing i thought about was a 87 f150 with the 351 in it my father had some 10 years ago. it was the hardest thing to start on cold days and did not start right up with out pumping the pedal way to many times and turning it over for minutes get it fired up finally have to keep on the pedal for about 5 min so it wouldnt die from still being cold.

One day he said it was time to fix the problem i asked him how? he went and bought a new eidlebrock carburetor. he put it on and we never had that problem again.

I have a carbed 350 in my gmc with a new holley carb on it and two pumps of the pedal and it starts right up just like its suppose to. Im not saying to go spend your money on a carb but i would research that with your symptoms.

sounds like the choke might not be functioning properly. my new carb has electric choke and vacuum secondaries was real simple to wire up the choke just needed to run a ground to the fuse block.

hope this might kind of help ya!

goodluck let us know!
Scott M is offline  
Old 06-21-2015, 02:46 PM
  #3  
Seasoned Member
Thread Starter
 
diego94's Avatar
 
Join Date: Sep 2012
Location: thompson,okanogan,shushwap area in central British columbian
Posts: 304
Year: 91 laredo
Model: Cherokee
Engine: HO 4l
Default

Thanks for the input but its injected
diego94 is offline  
Old 06-25-2015, 11:21 PM
  #4  
Seasoned Member
Thread Starter
 
diego94's Avatar
 
Join Date: Sep 2012
Location: thompson,okanogan,shushwap area in central British columbian
Posts: 304
Year: 91 laredo
Model: Cherokee
Engine: HO 4l
Default

Bump?
diego94 is offline  
Old 06-30-2015, 08:53 AM
  #5  
Member
 
Join Date: Feb 2014
Location: Victoria Texas
Posts: 120
Default

Originally Posted by diego94 View Post
Thanks for the input but its injected
I should have known that sorry....goodluck
Scott M is offline  
Old 07-03-2015, 09:40 AM
  #6  
Seasoned Member
Thread Starter
 
diego94's Avatar
 
Join Date: Sep 2012
Location: thompson,okanogan,shushwap area in central British columbian
Posts: 304
Year: 91 laredo
Model: Cherokee
Engine: HO 4l
Default

New problem a little more serious , I was driving home from work and twice it stalled on me slowing down coming to intersections with both clutch and brake on, its never done this before and it was completely unexpected if anyone has input that would be great thanks
diego94 is offline  
Old 07-07-2015, 06:45 AM
  #7  
CF Veteran
 
Join Date: Jun 2011
Location: Louisville,KY
Posts: 8,015
Model: Cherokee
Default

andrewmp6 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Psiegrist1
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
18
05-02-2019 08:14 AM
2heapjeeps
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
13
10-04-2015 10:52 PM
2heapjeeps
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
2
09-07-2015 11:30 PM
cbowl
Cherokee Chat
1
09-04-2015 01:56 PM
Jeepy11
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
2
09-03-2015 09:32 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 92 f250 problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: