What happened to my engine (video) - Jeep Cherokee Forum

Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

What happened to my engine (video)

Old 02-08-2019, 02:47 PM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 5
Model: Cherokee (XJ)
Default What happened to my engine (video)

Hey all. I'm new here. I have a 2005 Grand Cherokee Ltd. with the Hemi engine. Mileage is 205,000 and the car has been spectacular.

However today, I had someone come by for a test drive (I'm selling the vehicle). I put gas in it just before he arrived and it drove great. The guy took the car on a 15 minute test drive and then parked it. I drove it about 8 miles to a store. When I came out of the store, the vehicle wouldn't start. It was crank and crank, then try to start. The engine would rev all the way up and then die. I was guessing it was the fuel pump.

Anyway, I had the car towed home. I was able to start it and drive it into driveway, but there's now a tick. I'm hoping this video will help someone identify the problem.


As I said, the car was running great and has a perfect maintenance history.

Any ideas on what's happened? I'm a decent mechanic with Mercedes, but Jeeps are a bit "foreign" to me (LOL).

Thanks for the help!

Last edited by mikeybbrooks; 02-08-2019 at 02:51 PM. Reason: add video
mikeybbrooks is offline  
Old 02-09-2019, 03:45 PM
  #2  
Seasoned Member
 
Join Date: Oct 2012
Posts: 274
Model: Cherokee
Default

Did you go with him on this test drive? Any chance he abused the hell out of your jeep in those 15 minutes and broke it?
Kymasabe is offline  
Old 02-09-2019, 06:22 PM
  #3  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 5
Model: Cherokee (XJ)
Default

Originally Posted by Kymasabe View Post
Did you go with him on this test drive? Any chance he abused the hell out of your jeep in those 15 minutes and broke it?
unfortunately I didnít go with him on the test drive.
mikeybbrooks is offline  
Old 02-11-2019, 01:21 AM
  #4  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 10,963
Year: 2000
Engine: 4.0L
Default

It sounds to me he over-reved it and it now has a bad lifter or something.
dave1123 is offline  
Old 02-11-2019, 09:46 PM
  #5  
Seasoned Member
 
Join Date: Oct 2012
Posts: 274
Model: Cherokee
Default

Originally Posted by dave1123 View Post
It sounds to me he over-reved it and it now has a bad lifter or something.
I'm with Dave on this one.
Kymasabe is offline  
Old 02-11-2019, 10:22 PM
  #6  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 5
Model: Cherokee (XJ)
Default

Quick update - I've drained the gas and put in good fuel (plus a can of Seafoam). So there's 8 gallons of gas and a can of Seafoam in the tank.

The car runs better now. There's no tick or knock, but I'm getting a misfire at cylinder 6 and smoke coming out the exhaust (OBD2 code of P0306). I'm also getting the P1521 (I think) indicating the wrong oil??

I plan to switch the coils and see if the misfire follows the coil.

Anything else I should be doing?

I appreciate the help!
mikeybbrooks is offline  
Old 02-12-2019, 04:05 AM
  #7  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 10,963
Year: 2000
Engine: 4.0L
Default

I think that engine runs on the variable displacement system where it runs on 4 cylinders until power is demanded, then runs on all 8. I believe that's accomplished by holding the lifters and valves open with magnetic solenoids if I'm not mistaken.
dave1123 is offline  
Old 02-12-2019, 07:37 PM
  #8  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 5
Model: Cherokee (XJ)
Default

Switched the coils and the misfire stayed at cylinder 6. Hereís a video of the smoke. Could this be from the Seafoam I put in the gas??
mikeybbrooks is offline  
Old 02-13-2019, 01:18 PM
  #9  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 5
Model: Cherokee (XJ)
Default

Video didn't post. SO here it is. Please take a look (and listen) and let me know your thoughts!

mikeybbrooks is offline  
Old 02-23-2019, 09:54 PM
  #10  
Newbie
 
ihscouts's Avatar
 
Join Date: Nov 2017
Location: Traverse City MI
Posts: 19
Year: 2001
Model: Grand Cherokee(WJ)
Engine: 4.0
Default

Could be the Sea Foam, could be a head gasket. How much SF did you put in, the whole can in 8 gallons? Should be a can to 20 gallons. Have you checked the oil? Make sure it's not milky.
ihscouts is offline  
Old 03-14-2019, 09:05 PM
  #11  
Newbie
 
Join Date: Mar 2019
Location: East Bama
Posts: 5
Year: 1997
Model: Grand Cherokee (ZJ)
Engine: 5.2
Default

I'd say a compression test is needed at this point.
twinsig is offline  
Old 03-16-2019, 02:49 PM
  #12  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,523
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

month old post
97grand4.0 is offline  
Old 03-17-2019, 03:49 PM
  #13  
Newbie
 
ihscouts's Avatar
 
Join Date: Nov 2017
Location: Traverse City MI
Posts: 19
Year: 2001
Model: Grand Cherokee(WJ)
Engine: 4.0
Default

Probably sold it for cheap......
ihscouts is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
af_wheelin_oh
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
15
01-11-2011 09:42 AM
kickin_wayne
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
8
11-11-2008 01:53 PM
COSXJFAN
CF Suggestions & Questions
13
08-28-2008 10:22 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: What happened to my engine (video)


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: