Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

Starting problems 95 ZJ 4.0L

Old 02-27-2019, 01:23 AM
  #1  
Seasoned Member
Thread Starter
 
Muddz's Avatar
 
Join Date: Nov 2013
Location: USA
Posts: 269
Year: 1995
Model: Grand Cherokee (ZJ)
Engine: 4.0L
Default Starting problems 95 ZJ 4.0L

I was helping a friend repair his 92 XJ Laredo, with a torch and various tools. The entire time the rear hatch of my 95 ZJ was opened.

Hours later when I went to start the ZJ Limited 4.0L (with passive security system) There was no engine turn over only could here the starter solenoid clicking. Since it's a new starter and battery I thought several things such as a bad starter relay and possibly not enough juice from the battery to turn the starter.

So my friend gave me a jump but the same thing happened, sound from solenoid but no starter.

I then notice the headlights were flashing and security light was on steady.

I then reset the security and tried starting again the same thing happened
again. (no starting and the headlights flashing).

So I placed the battery on a 10 amp 3 stage charger thinking the "new" battery was drained perhaps from leaving the hatch and possibly one of the rear doors opened.

I tried starting with the battery charger connected and the same starting problem occured again

The charger amp light went from under two amps to 10 amps full charge.

I left the charger on for a while and came back out after a couple hours to try starting again. (can't remember if was also give a second jump)

Anyway after long cranking the 4.0L sputtering eventually started.

I remember this last time there was no security light flashing as if setting off an alarm.

The engine running I stopped the engine, upon a restart the 4.0L started right up.

I'm trying to figure out why the ZJ won't start in the first place along with what set off the (passive) security system?

I didn't have my DMM with so I couldn't take a measurement of the battery voltage.

I'm uncertain if the battery was drained because when having problems starting I turned on headlights and they were good a bright.

I'm wondering if the passive security system for some reason cut fuel to my fuel injectors?

That's one of the security systems features is the PCM will disable the fuel injectors delivery fuel to the engine if an alarm is tripped.
Muddz is offline  
Old 02-27-2019, 02:56 PM
  #2  
Seasoned Member
Thread Starter
 
Muddz's Avatar
 
Join Date: Nov 2013
Location: USA
Posts: 269
Year: 1995
Model: Grand Cherokee (ZJ)
Engine: 4.0L
Default

It's currently starting right up as before, on the first crank.

I have it home now and when the weather warms up I'll perform some tests with my DMM and also have a CCA battery tester, which should help determine the condition of the battery.

I'm planning on replacing battery terminals with military type. I'll further inspect the cables and connections between the alternator, battery and PDC. I've already cleaned and inspected the battery cable terminals and connections to the solenoid after replacing the starter. Also ground connections near the ignition coil.

I probably need to inspect and clean the rest of the ground points.

The battery is only a couple months old and previously checked it's electrolyte level.

I went back and read through a 1993 - 1995 Vehicle Theft Security paper FSM that has diagnostic procedures for the passive security system.

It shows

Power up alarm mode. When the battery is disconnected and reconnected the security system enters into a power up alarm mode.

- Flashes headlight
- Flashes Park and taillights
- Prevents the engine from starting.
__________

In order to prevent the engine from starting the PCM disables the fuel injectors fuel delivery (pulse).

What I think may have happened is battery power to the pcm and/or passive security system module (what ever monitors the battery) detected the battery had been briefly disconnected and reconnected. Possibly a loose, corroded connection somewhere? and the security system went into a Power up alarm mode.

Possibly the battery became so low that the secutity system thought the battery had been disconnected and reconnect or the problem is an intermittent loose and/or corroded connection, such as plug-in with bent, corroded pins, loose wire, etc. that makes the passive security system and pcm think the battery has been disconnected, places the security system into power up mode.

This connection problem needs to be found.

I'm uncertain where it would be exactly. I suppose I can attempt wiggle tests to see if there's any loose wires?

The battery and PDC connections seem to be ok. Possibly there could be a problem in or near the PDC, PCM, passive security system module, related relays, fuse connection, etc.

Last edited by Muddz; 02-27-2019 at 04:49 PM.
Muddz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mkawski
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
10-28-2016 02:27 PM
HighTekRedneK
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
3
07-19-2011 09:29 PM
swluther
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
15
03-28-2010 09:48 AM
x91j
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
12
03-10-2010 09:25 AM
BigRed93xj
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
11-22-2009 10:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Starting problems 95 ZJ 4.0L


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: