Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

Picking up a ZJ for parts. Won't start, fuel pump runs constantly, no guages

Old 12-02-2016, 04:52 PM
  #1  
Member
Thread Starter
 
Hatsuwr's Avatar
 
Join Date: Aug 2016
Location: Maryland
Posts: 205
Year: 1996
Model: Grand Cherokee
Engine: 4.0 I6
Default Picking up a ZJ for parts. Won't start, fuel pump runs constantly, no guages

So I'm about to buy a '97 4.0 Laredo. It won't start, when the key is turned to the position just before cranking, you can head the fuel pump running constantly. Checking the fuel pressure relief above the engine, there is at least some pressure (didn't measure how much). Some (or all) of the gauges are out. The fuel gauge is definitely out.
I'm guessing there is a short which is messing with the PCM, but I know very little about these things.

The owner said that just before all of this started, the O2 sensor on the cat was ripped out by something on the ground. The wires were torn apart. I'm thinking maybe this is the source of the problems. He had taped them back up, but I didn't take it all apart to make sure it was done right.

Any thoughts on what this might be? He also had the battery cable removed when I arrived, making me think there was a voltage drain somewhere, possible giving more evidence for a short.

I'll be following up the next day or two with a scan tool to get more info.
Hatsuwr is offline  
Old 12-04-2016, 04:01 PM
  #2  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,644
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

I would say that buying this not running is a pretty gutsy move. Sounds like multiple problems, I would only be guessing without more info. A factory service manual would help.
97grand4.0 is offline  
Old 12-04-2016, 04:42 PM
  #3  
CF Veteran
 
dave1123's Avatar
 
Join Date: Nov 2010
Location: Manlius, east of Syracuse, NY
Posts: 11,268
Year: 2000
Model: Grand Cherokee (WJ)
Engine: 4.0L
Default

What I find amusing is he said he bought it for parts! Now he wants to get it running! Jeep Fever is like a spider bite, you never see it coming, but you feel it afterwards for sure!

The downstream 02 sensor doesn't do anything but monitor the cat's efficiency, so you can disconnect it to start with, thus eliminating it as a possible short. Pull out the fuel pump relay and turn on the ignition. This will eliminate the relay as a possible short as well. It shouldn't run with the relay removed. The PO may have jumpered the fuel pump relay thinking it wasn't getting fuel to the engine.

Next, find out if you have spark. If you don't, I would suspect the PCM isn't turning on because the gauges aren't active. Check ALL the ground connections, fuses, and the plugs on the PCM.

There are 3 power circuits in a jeep. #1 is the main power from the battery to the starter. #2 is everything that's hot all the time, like headlights, brake lights, horn, hazard lights, interior lights, ignition key supply, and dashboard power outlet. #3 is everything controlled by the ignition key switch.

The way the system works is when you turn the key to run, the PCM becomes active and turns on the gauges and the fuel pump for a short time to charge the fuel rail. It's a TIME interval and has nothing to do with whether there's pressure or not. Then it waits for a CPS signal that tells it you are cranking the engine. When it gets this signal, it turns on the fuel pump relay and the ASD relay. The ASD relay turns on the ignition and injector circuits.

Do some diagnostics and get back to us.

Last edited by dave1123; 12-04-2016 at 05:07 PM.
dave1123 is online now  
Old 12-04-2016, 05:26 PM
  #4  
CF Veteran
 
Join Date: Nov 2015
Location: syracuse ny
Posts: 1,644
Year: 1997
Model: Grand Cherokee
Engine: 4.0
Default

Kind of like renting an apartment sight unseen on craigslist, just send the money to this western union account and....

Hey are you sure the ignition coil is off until the engine is cranking?
97grand4.0 is offline  
Old 12-04-2016, 05:43 PM
  #5  
Member
Thread Starter
 
Hatsuwr's Avatar
 
Join Date: Aug 2016
Location: Maryland
Posts: 205
Year: 1996
Model: Grand Cherokee
Engine: 4.0 I6
Default

Well it's only $800. Besides not starting and the electrical-taped O2 sensor, it's (superficially) in very good condition.

I'd be taking nearly the entire interior to swap with mine (I like its black compared to my tan) as well as some little things here and there that are in better condition on it. Then probably resell it to whoever can use it at that point. If it never runs, I'll probably resell for enough to make it a good deal. If I do get it going I might even be able to make a bit of a profit. Assuming I don't find it too hard to part with...

On another note, my ZJ's lower transmission oil cooler line popped off at the radiator today. Hoping I didn't damage the transmission at all. Thankfully it's safely parked on base and I don't have to rush to get it going. Won't be able to check out the '97 until Wednesday though - hoping it isn't sold in the meantime.

Will post back with what I find.

*edit*

97grand4.0, I actually bought my house without ever seeing it haha. I was PCSing with my wife in her 9th month and this - as far as pictures could show - was just about the perfect place. I definitely wouldn't recommend doing so for most situations, but we lucked out. Hopefully that luck holds here.

Last edited by Hatsuwr; 12-04-2016 at 05:46 PM.
Hatsuwr is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: