Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

High beams not working

Old 01-26-2019, 06:15 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 2
Year: 1999
Model: Grand Cherokee (WJ)
Engine: 4.0
Default High beams not working

[color=left=#000000]Sorry if I'm in the wrong place I'm new here, and have a problem that has me stumped.
I purchased a 1999 Jeep Grand Cherokee Laredo for my daughters first car. The Jeep had a blown engine (#3 piston skirt sheared off) rebuilt the engine re installed it and got it running like a top, took about a year to complete it all so the truck sat. The WJ had 207k on the clock when I purchased it so I have been replacing things as I find them to get the Jeep safe and reliable, and I have run into a major problem. The high beams wonít stay on. I pull the multifunction switch back and the high beams and indicator comes on but as soon as I release it the high beams go off, but the indicator stays on. So I started attacking the problem. I pulled a two multi-function switches from my local u pull, neither fixed the problem. I replaced the resistors and fuses, no dice. I chased down as many grounds as I could locate cleaned them and nothing. Thinking what are the odds I purchased a new multi-function switch on the outside chance that all three previous were bad, No Bueno. From the research I have done so far I have learned that there are two separate resistors that are ground activated, thatís why I started cleaning grounds. Is it possible that the body control module is bad? There was also an aftermarket radio in it and I donít know if that has anything to do with it or not. The air bag light is intermittent but the horn and cruise control work fine so I know the clock spring is good. I found a service bulletin saying to replace the air bag module with one form a 2004 because they were redesigned so I assume that will fix the air bag problem when I get to it. I hope someone has an idea, I have searched this forum and couldn't find this problem or fixÖI see this problem all over the web but with no solution. [/color]=left
[color=left=#000000]Thanks,[/color]=left
[color=left=#000000]Joe [/color]=left
=left
[color=left=#000000]2013 JK Rubicon Unlimited 2" old man Emu lift and 35's AEV bumpers front and Rear, and a whole lot of other stuff (wife's mall crawler)[/color]=left
[color=left=#000000]1999 Grand Just getting started[/color]=left
[color=left=#000000]1997 TJ built for trails way too much to mention. [/color]
Ugly Coyote is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
xj guy
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
08-13-2013 02:01 PM
shooting sticks
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
4
12-13-2011 01:28 PM
94XJCherokee
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
3
09-08-2010 12:54 PM
peternaputi
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
02-21-2010 10:43 PM
peternaputi
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
02-21-2010 10:32 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: High beams not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: